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PART ONE 
Introduction and Overview 
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1 Introduction and Overview 

Introduction 

This course guide accompanies the Level 1 training sessions. Level 1 shows you how to produce 3-D models using 

NURBS geometry and arrange models for export, annotation and plotting. 

In class, you will receive information at an accelerated pace. For best results, practice at a Rhino workstation 

between class sessions, and consult your Rhino reference manual and the Help file for additional information. 

Duration 

3 full days or 6 half day sessions 

Course Objectives 

In Level 1, you learn how to: 

• Utilize the features of the Rhino user interface 

• Customize your modeling environment 

• Create basic graphic objects—lines, circles, arcs, curves, solids, and surfaces 

• Model with precision using coordinate input, object snaps, and SmartTrack™ tools 

• Modify curves and surfaces with edit commands and Gumball 

• Use control point editing to modify curves and surfaces 

• Analyze your model 

• Display any portion of the model 

• Export and import models to and from different file formats 

• Render the model using Rhino Render 

• Dimension and annotate model with test and hatch 

• Use Layouts to arrange views of model on paper for printing  
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Schedule A: Three Classroom Days 

Day 1 Topic 

8-10AM Introduction, Rhino interface 

10AM-12PM Rhino interface, panning & zooming 

12-1PM Lunch 

1-3PM Creating geometry 

3 -5PM Creating geometry 

Day 2 Topic 

8-10AM Editing 

10AM-12PM Editing 

12-1PM Lunch 

1-3PM Editing 

3 -5PM Control point editing, modeling with solids 

Day 3 Topic 

8-10AM Surfacing 

10AM-12PM Surfacing 

12-1PM Lunch 

1-3PM Modeling practice 

3 -5PM Import/export, rendering, dimensioning, printing, customization 

Schedule B: Six Half Days (On-line Training) 

Session  1 Topic 

9-10:45AM Introduction, Rhino interface 

10:45-11AM Break 

11AM-12:45PM Rhino interface, panning & zooming 

Session  2 Topic 

9-10:45AM Creating geometry 

10:45-11AM Break 

11AM-12:45PM Creating geometry 

Session 3 Topic 

9-10:45AM Editing 

10:45-11AM Break 

11AM-12:45PM Editing 
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Session  4 Topic 

9-10:45AM Editing 

10:45-11AM Break 

11AM-12:45PM Control point editing, modeling with solids 

Session  5 Topic 

9-10:45AM Surfacing 

10:45-11AM Break 

11AM-12:45PM Surfacing 

Session  6 Topic 

9-10:45AM Modeling practice 

10:45-11AM Break 

11AM-12:45PM Import/export, rendering, dimensioning, printing, customization 

Overview - What is Rhino? 

Rhinoceros is 3D modeling software that can be used in a variety of ways and for very different purposes. It is 

primarily a surface modeling tool, but has many related functions as well. Many users use only a small portion of 

what Rhino has to offer, while others need and use a lot more; it depends on what the individual user is trying to 

accomplish with the application. Even very experienced users can find new and useful tools of which they were 

previously unaware. In this introduction, a broad overview of various elements that you will encounter while using 

Rhino to get your work done is provided. 

Object types 

What does surface modeler mean?  

Rhino has tools to create and edit several different types of objects, of which surfaces are one.  A surface in Rhino 

refers to an infinitely thin, infinitely flexible, mathematically defined digital membrane. 

Surface 

Surfaces are represented on screen by 

either some outline curves plus some 

interior curves, called isocurves, or by a 

shaded picture which makes a surface 

appear to have some substance and to 

show light and shading. How surfaces are 

painted on the screen is dependent on 

the display mode in the viewport, and 

does not affect the surface in any way. 

The important thing to remember about 

surfaces is that they are defined with 

great precision at every point by complex 

math formulas, they are not 

approximations. 

 

A surface, shown in wireframe 

 

…and shaded views. 
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Polysurface 

Rhino also has objects which consist of two or more surfaces joined together. 

This is possible when the edge of one surface is located very close to the edge 

(within tolerance set in the file) of another surface. We call joined surfaces 

polysurfaces. Since there are some restrictions on editing polysurfaces, 

Rhino makes it very easy to extract the individual surfaces from polysurfaces 

and join them back together. 

 

A polysurface in shaded view. 

Solid 

We have already said that surfaces are infinitely thin; they have zero 

thickness.  

However, any physical object will have some thickness—not zero.  

If you need your objects to have thickness, or volume, there are two ways 

to accomplish this. The first is to make sure the surface closes on itself and 

has no openings anywhere. Spheres and ellipsoids are examples of this type 

of surface. 

 

A Sphere and Ellipsoid object.  

 

The second method is to join enough single surfaces 

together to enclose a space, again, with no openings, not 

even very small ones. A box is an example of this type of 

object. We call these objects solid, but it is important to 

remember that there is nothing inside them- they are 

volumes in space enclosed by the infinitely thin surfaces. 

If you remove one side of a box, and look inside you will 

see the backsides of the five surfaces. 

  

Closed (solid) and open Polysurface. 
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Lightweight Extrusion Objects 

Another object type that is related to a polysurface and a solid is 

the lightweight extrusion object. Lightweight extrusion objects 

use less memory, mesh faster, and save smaller than the 

traditional polysurfaces. 

In models containing large numbers of extrusions represented by 

traditional polysurfaces, performance can be sluggish due to the 

relatively high demand on resources. If the same objects made 

in Rhino as lightweight extrusion objects, are more responsive 

and leave plenty of memory available. 

In Rhino 5 commands like Box, Cylinder, Pipe, and ExtrudeCrv 

create lightweight extrusion objects by default 
Lightweight extrusion objects 

Curve 

Another object type that is related to a surface is a curve. In Rhino 

terminology, the word curve includes lines, polylines (think of these as series 

of straight line segments strung together end to end and joined), arcs, 

ellipses, circles, or free-form curves that are generally smooth. Polycurves 

are curves made up of two or more curves joined end to end. Separate 

polycurves into curves by using the Explode command. 

You can use Curves as inputs for creating and editing surfaces. For example, 

you can trim a surface or polysurface with a curve, but they may be useful in 

themselves as well, as in making a 2D drawing of a 3D model, or as reference 

or construction geometry. You can derive and extract from surfaces. For 

example, all surfaces have edges, and it is possible to extract an edge curve if 

needed. You can also extract surface isocurves. 

 

Curves 

Polygon Mesh 

Rhino also creates, edits, and otherwise uses polygon meshes. 

Polygon meshes are sometimes used to depict the same type of objects as 

surfaces but there are important differences. Polygon meshes consist of a 

number, sometimes a very large number, of points in space connected by 

straight lines. These straight lines form closed loops of three or four sides, 

that is, polygons.  

One important thing to know about polygon meshes is that the 3D data only 

exists for these points, or mesh vertices; the space between these points is 

not considered. Dense meshes are more accurate than very loose ones, but 

not as accurate as surfaces. Although meshes are important in 3D modeling, 

initially we will not discuss them. 

For instance, if you look at a surface in a shaded viewport, what you see is 

actually a polygon mesh derived from the surface for the purposes of 

making a nice image on screen. Typically, you will export mesh data for 

rapid-prototyped parts. Deriving accurate meshes from surface models is 

important. Rhino has a number of tools to help accomplish this. 

  

A Sphere surface and mesh sphere 

object. 
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2 The Rhino for Windows Interface 
Before learning individual tools, we will be acquainted with the Rhino interface. The following exercises examine 

the interface elements used in Rhino: the Rhino window, viewports, menus, toolbars, panels and dialog boxes.  

There are many ways to access the commands in Rhino—the keyboard, menus, and toolbars. We will focus on the 

menus in this class. 

To open Rhino: 

���� Double-click the Rhino icon from the Windows desktop. 

The Rhino Screen 

Rhino divides its several areas that supply information or prompt you for input.  

Screen Area Description 

Menu Bar Access commands, options, and help. 

Command area Lists prompts, commands you enter, and information displayed by the command. 

Command 
history window 

Displays 500 lines of the most recently used commands. Activate this window with F2. 

Tabbed 
toolbars 

Groups are containers with one or more toolbars, with a tab at the top for each toolbar. Floating a toolbar 
makes single-toolbar group. 

Sidebars  Access shortcuts to commands and options. Updates when selecting tabbed toolbar.  

Graphics area Displays the open model. Several viewports can be displayed. The default viewport layout displays four 
viewports (Top, Front, Right, and Perspective). 

Viewports Displays different views of the model within the graphics area. Viewports can show a grid, grid axes and world 
axes icon. 

Status bar Displays the coordinates of the pointer, the units and current layer of the model, toggles and other options. 

Panels Rhino controls like layers, properties, materials, lights, display mode and more are displayed in panels with 
tabs.  

Osnap bar Access running object snap settings 
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The Rhino Screen 

 
Rhino Main Screen Configuration  
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Menus 

You can find most of the Rhino commands in the menus. 

Toolbars 

Rhino toolbars contain buttons that provide shortcuts 

to commands. You can float a toolbar anywhere on the 

screen, or dock it at the edge of the graphics area. 

Rhino starts up with the Standard toolbar group 

docked above the graphics area and the Main toolbar 

as the sidebar on the left. 

 
Rhino View menu 

Tooltips 

Tooltips tell what each button does. Move your pointer over a button without clicking it. A 

small yellow tag with the name of the command appears. In Rhino, many buttons can 

execute two commands. The tooltips indicate which buttons have dual functions. 

For example, to start a Polyline, click the Left Mouse Button (LMB), to start the Line 

Segments command click the Right Mouse Button (RMB). 

 

Cascading toolbars  

A button on a toolbar may include other command buttons in a cascading toolbar. Usually 

the cascading toolbar contains variations on the base command. After you select a button 

on the cascading toolbar, the toolbar disappears.  

Buttons with cascading toolbars are marked with a small black triangle in the lower right 

corner. To open the cascading toolbar, hover over the black triangle and LMB click when 

the large blue triangle with the tooltip [Cascade “xxx”] appears.  

For example, the Lines toolbar is linked to the Main sidebar. After the cascading toolbar is 

open, you can pick any of the buttons on the toolbar to start a command. 
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Graphics Area 

The Rhino graphics area includes the viewports. You can customize the viewports and their position to suit your 

preferences. The position of viewports is adjustable. 

Viewports 

Viewports are windows in the graphics area that show you views of your model. To move and resize viewports, 

drag the viewport title or borders. You can create new viewports, rename viewports, and use predefined viewport 

configurations.  

Each viewport has its own construction plane and grid that the cursor normally moves on and a projection mode. 

To toggle between a small viewport and one that fills the graphics area, double-click the viewport title. 

 
Rearranged Rhino screen. Command line at the bottom, single maximized viewport, toolbars  

docked in different locations, and tabbed panels docked on the right. 
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Viewport tabs 

You can display the viewport titles in tabs if you prefer. The highlighted tab designates the active viewport. Tabs 

make it easy to switch between viewports when using maximized or floating viewports. 

 
The tabs are located below the graphics area. 

Command Area 

The command area displays commands and command prompts. You can dock the command line at the top or the 

bottom of the screen or it can float anywhere. The command window shows two lines by default. To open a 

window that displays the command history, press F2. You can select and copy the text in the Command History 

window to the Windows clipboard. 

The Mouse  

In a Rhino viewport, the left mouse button selects objects and picks locations. The right mouse button has several 

functions including panning and zooming, popping up a context-sensitive menu, and acting the same as pressing 

the Enter key. Use the left mouse button to select objects in the model, commands or options on the menus, and 

buttons in the toolbars. Use the right mouse button to complete a command, to move between stages of 

commands, and to repeat the previous command. Use the right mouse button to initiate commands from some 

toolbar buttons. 

Drag with the right mouse button to pan and rotate in viewports. Use the mouse wheel or hold down the Ctrl key 

and drag with the right mouse button to zoom in and out in a viewport. You must press and hold the right mouse 

button down to activate this feature.  
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Entering Commands 

Use the command line to type commands, pick command options, type coordinates, type distances, angles, or 

radii, type shortcuts, and view command prompts. 

To enter information typed at the command line, press Enter, Spacebar, or right mouse button over a viewport. 

Note: Enter and Spacebar perform the same function. 

Shortcuts and Aliases 

Shortcuts are customizable key combinations. You can program the function keys and Ctrl key combinations to 

perform Rhino commands.  

Command aliases run individual Rhino commands or scripts. You can type command aliases just like normal Rhino 

commands or use them to create abbreviations for often used commands or command scripts.  

Rhinoceros Level 2 training discusses Shortcuts and Aliases in detail. 

Clickable options 

To use command options, click the option on the command line or type the underlined letter of the option and 

press Enter. (The interior capitalization is meaningless.)  

 

Autocomplete command name 

Type the first letter of a command name to 

activate the autocomplete command list. As you 

type letters on the command line, the command 

name that includes those letters will 

autocomplete and display in a drop down menu. 

Press Enter to activate the command once the 

full command name appears or left click on the 

command in the list to start it. 
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When enabling the "Use fuzzy 

autocomplete" feature in Options 

and Appearance, the in-line 

autocomplete suggests the most 

used candidate. 

For example, LI most likely 

autocompletes to Line rather than 

something like LimitReferenceModel 

and the autocomplete menu 

contains best partial and inexact 

matches. 

When disabled, autocomplete 

uses the first letters of the 

command name in an 

alphabetical list. 

 
Options -> Appearance 

Repeating commands 

To repeat the last command, right-click in a viewport, press Enter, or press the spacebar. To repeat previous 

commands, right-click in the command line window and select from a list. 

Canceling commands 

To cancel a command, press Esc or enter a new command from a button or a menu. 
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Help 

Press F1  at any time to access Rhino Help. In addition to finding information about each command, Rhino 

help has conceptual information as well as many examples and graphics to help you complete your model. When 

you are confused or unsure about what to do, the first place you should look is the help file. You can also access 

help for a specific command by starting the command and press F1. 

In addition, the CommandHelp command displays the help topics in a dockable window and displays help for the 

current command. 

Most of the commands include short video clips that show how the command and the options work. 

 
If Auto-update is checked, the help for the current command displays. If Auto-update is unchecked, you can type 

the name of the command that you want displayed and press Enter to display the information. 
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View the Command Line History 

The command history window lists the 

last 500 command lines from the current 

Rhino session. Press F2 to view the 

command history. 

 

View Recent Commands 

Right-click the command line to view recently 

used commands. To repeat the command, select 

it from the popup menu. 

The number of commands listed is set in Rhino 

Options. The default limit is twenty commands. 

When you use your twenty-first command the 

first one drops off the list. 
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Panels 

Many Rhino controls are contained in tabbed panels. 

Open the panels from the 

Panels menu or from the 

tabbed Panels right-click 

menu. 

Panels that you will work 

with in Level 1 training 

are: 

• Display 

• Layers 

• Help 

• Named CPlanes 

• Notes 

• Properties 

• Web browser 

 
The Panels menu shows the docked panels on the 

right side of graphics windows. 

 
The tabbed panels right-click 

menu. 

Note: Positioning the mouse over the tabs allows the mouse wheel to scroll through the tabs. 
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Exercise 1—Rhino basics 

To get started: 

1 Download the Level 1 
Training models. 

2 Unzip the downloaded file 
into a Level 1 folder on your 
computer. 

After downloading the 

Level 1 Training.zip file to 

your computer, unzip files 

into a Level 1 folder 

located in Desktop or My 

Documents, or another 

location in which you have 

full rights. 

3 From the File menu, click 

Open.  

4 In the Open dialog box, 
navigate to the Level 1 
folder and Open the model 
Start.3dm. 

This model contains five 

objects: a cube, a cone, a 

cylinder, a sphere, and a 

rectangular plane. 

 
Two parallel viewports and one perspective viewport. 

5 From the View menu click 
Viewport Layout, and then 

click 4 Viewports.  

 

 
Three parallel viewports and one perspective viewport 

6 In the Status Bar, click Grid Snap to turn on the grid snap. 

Grid Snap may already be on in your system. Be careful that you do not turn it off instead of on. If Grid 

Snap is on, it will be bold and black in the status bar. If it is off, the word it will be gray. 
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Note: This is an important step. Grid Snap only lets your cursor move in certain intervals. In this model, the 

setting for Grid Snap is one-half of a grid line. Grid Snap helps you line up your objects as if you were 

building with LEGO blocks. 

7 Click the mouse in the Perspective viewport to make it active. 

The viewport title highlights when it is active. The active viewport is the viewport where all your commands 

and actions take place. 

8 Click the arrow icon to the right of the 
Perspective title or Right Mouse click on 
the title to open the drop down menu, and 

then click Shaded. 

The objects appear shaded. A shaded 

viewport lets you preview the shapes. The 

viewport will remain shaded until you 

change it back to a wireframe view.  

You can change any viewport to shaded 

mode. Later we will discuss the other 

viewport display options. 

 

 
The viewport shows a Shaded display. 

9 From the Render menu click Render.  

Rendering the model opens a separate render 

window. The model displays in render colors 

previously assigned to the objects. You can also 

set lights and a background color. You will learn 

about doing this later.  

You cannot manipulate the view in the render 

display window but you can save image to a 

file. 

10 Close the render window. 

 
Render 

11 In the Perspective 
viewport, click and drag 

with your right mouse 

button held down to 

rotate the view. 

The plane helps you stay 

oriented. If the objects 

disappear, you are looking at 

the bottom of the plane. 

 
Rotate the view in shaded display. 

 
X-Ray shaded display. 
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12 Click the arrow icon to the 
right of the Perspective 

viewport title, and then 

click X-ray. 

13 Click the arrow icon to the 
right of the Perspective 

viewport title, and then 

click Ghosted. 

14 Click the arrow icon to the 

right of the Perspective 

viewport title, and then 

click Rendered.  
Ghosted shade display. 

 
Rendered display 

 

15 Click the arrow icon to the right of the Perspective viewport title, 

and then click Technical, Artistic, and Pen. 

Technical mode displays lines as though the drawing were a 2-D, 

flat drawing on paper.  

This mode uses real-time silhouettes and intersections, creases, 

borders, blended shaded and rendered display. Objects behind 

other objects appear occluded. 

 

 
Technical display 

Artistic mode displays 

lines as though the 

drawing were a 2-D, 

flat, pencil drawing on 

textured paper.  

Pen mode displays 

lines as though the 

drawing were a 2-D, 

flat, pen drawing on 

paper. 

  
Artistic display Pen display 
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16 Change to Wireframe 
mode. 

17 To rotate your view, 
drag from the bottom of 

the view toward the top. 

You are now under the 

objects looking up. 

18 Change to Shaded 
mode. 

The plane obscures 

the objects. In shaded 

mode, the plane helps 

you see when your 

viewpoint is below the 

objects. 

 
This view looks at the objects from the 

bottom in wireframe mode. 

 
This view looks at the objects from the 

bottom in shaded mode. 

To get back to your original view: 

���� Press the Home key to undo your view changes. 

If you are “lost in space” in the perspective view: 

���� From the View menu click Viewport Layout, and then click 4 Viewports twice. 

This takes you back to the default viewport settings. 

Navigating Around the Model 

You have used the right mouse button to rotate in the Perspective viewport. You can hold Shift and drag with the 

right mouse button to pan. Dragging the right mouse button to move around does not interrupt any commands in 

progress.  

To pan in a viewport: 

1 In the Perspective 
viewport, hold the Shift 

and drag with the right 

mouse button to pan the 

view. 

2 Pan the view in the 
parallel viewports by 

dragging with the right 

mouse button. 

The Top, Front, and 

Right viewports use a 

parallel projection 

In the parallel 

viewports, it is not 

necessary to press the 

Shift key. 

 
Pan the viewport using Shift and the 

right mouse button. 

 
Pan the viewport in a parallel view with 

the right mouse button. 
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Zooming in and out 

Sometimes you want to get closer to your objects or move back so you can see more. This is zooming. As with 

many things in Rhino, there are several ways to do this. The easiest way is to turn the mouse wheel to zoom in 

and out. If you do not have a wheel mouse, hold down the Ctrl key and drag up and down in a viewport with the 

right mouse button.  

To zoom in and out: 

1 In the Perspective viewport, roll the wheel on your mouse 
forward to zoom in, roll it backward to zoom out.  

The camera zooms at cursor position. 

2 In the Perspective viewport, hold the Ctrl key, click and hold the 
right mouse button, and drag the mouse up and down.  

Drag up to zoom in. 

Drag down to zoom out. 

 
Zoom the viewport using the Ctrl key and 

the right mouse button. 

Zooming extents 

The Zoom Extents command, displays a viewport so the objects fill up the viewport as much as possible. You can 

use this command to make everything visible.  

To zoom extents in a viewport: 

���� From the View menu click Zoom, and then click Zoom Extents. 

If you get lost, it is often handy to zoom extents in all your viewports at once, so there is a command to do 

just that. 

To zoom extents in all viewports: 

���� From the View menu click Zoom, and then click Zoom Extents All. 

Move Objects 

If Gumball is bold face in the Status bar, click to turn Gumball off. We will discuss Gumball later in this training. 

Dragging follows the construction plane of the current viewport. 

Now drag the objects around. You can drag in any viewport. In this model, the Grid Snap setting is one-half of a 

grid line. Using this snap, you should be able to line objects up with each other. 

To move objects: 

1 Click the cone and drag it. 

The selected cone highlights. 

 

 
The selected cone highlights. 
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2 Drag the cone in the Perspective viewport until it lines up with the 
cylinder. 

It will be inside the cylinder. 

The cone moves on the base represented by the grid. This base is 

a construction plane. Each viewport has its own construction 

plane. When you start Rhino, the Perspective viewport has the 

same construction plane as the Top viewport. You will learn more 

about using construction planes later. 

 
Drag the cone to move it. 

3 In the Front viewport, drag the cone to the top of the cylinder. 

Watch what happens in the Perspective viewport. 

Watch the other viewports to place your objects. 

 
Move the cone in the Front viewport. 

4 Click in the Perspective viewport. 

5 Change the viewport to a Rendered Display. 

 
Rendered Display with Shadows. 

Copy Objects 

To create more objects, copy the shapes.  

To open the same model again: 

1 From the File menu, click Open. 

2 Do not save the changes. 

3 In the Open dialog box, select Start.3dm. 
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To copy objects: 

1 Click the box to select it. 

2 From the Transform menu, click Copy. 

3 Click somewhere in the Top viewport. 

It usually helps to click a spot that relates to the object like the 

middle or near a corner. 

Select and copy the box. 

4 Click where you want the 
first copy. Zoom in closer 

if you like.  

5 Click other places to 
make more copies of the 

box. 

6 When you have enough 
copies, press Enter.  

 

 

Try on Your Own 

���� Make copies of more objects and move them around. See if you 

can build something. 

 

 

Changing the view of your model 

When you add detail to your models, you will need to see different parts of your model with different 

magnifications. You can use the view commands, the mouse, and the keyboard to change the view in a viewport. 

Each view corresponds to the view through a camera lens. The invisible target of the camera is located in the 

middle of the viewport. 

Viewports  

With Rhino, you can open an unlimited number of viewports. Each viewport has its own projection, view, 

construction plane, and grid. If a command is active, a viewport becomes active when you move the mouse over 

it. If a command is not active, you must click in the viewport to activate it.  
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Most viewport controls can be accessed through the viewport popup menu.  

To open the popup menu, right click the viewport title. Or Click the small triangle on the viewport title. 

 

Parallel vs. Perspective Projection  

Unlike other modelers, Rhino lets you work in both parallel and perspective views.  

To toggle a viewport between parallel and perspective view: 

1 Right-click the viewport title, click Viewport Properties.  

2 In the Viewport Properties dialog box, for Projection click Parallel or Perspective, and then click OK.  

Panning and Zooming  

The simplest way to change the view is to hold down the Shift key and drag the mouse with right mouse button 

held down. This pans the view. To zoom in and out, hold down the Ctrl key and drag up and down or use the 

mouse wheel. 

You can also use the keyboard to navigate: 

 Perspective Projection Parallel Projection 

Key Action  Action + Ctrl Action 

Left Arrow Rotate left Pan left Pan left 

Right Arrow Rotate right Pan right Pan right 

Up Arrow Rotate up Pan up Pan up 

Down Arrow Rotate down Pan down Pan down 

Page Up Zoom in  Zoom in 

Page Down Zoom out  Zoom out 

Home Undo View Change  Undo View Change 

End Redo View Change  Redo View Change 

You can change your view in the middle of a command to see precisely where you want to select an object or 

select a point. 

There are additional Zoom controls that will be discussed in other exercises. 

Reset Your View  

If you get lost, four view techniques can help you get back to a starting place. 

To undo and redo view changes: 

���� Click in a viewport, press your Home or End key on your keyboard to undo and redo view changes. 

To set your view so you are looking straight down on the construction plane: 

���� From the View menu click Set View, and then click Plan. 
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To bring all your objects into view: 

���� From the View menu click Zoom, and then click Zoom Extents. 

To bring all your objects into view in all viewports: 

From the View menu click Zoom, and then click Zoom Extents All. 

Exercise 2—Display options 

���� Open the model Camera.3dm.  

You will use this to practice 

changing views. You will create 

views from six directions and an 

oblique perspective view. 

 

 

To change the number of viewports: 

1 Make the Top viewport active. 

2 From the View menu click Viewport 
Layout, and then click Split 

Horizontal. 

3 Make the Front viewport active. 

4 From the View menu click Viewport 
Layout, and then click Split 
Vertical. 

5 Repeat this step for the Right 
Viewport. 

6 Right click on the Top viewport title 
at the top, click Set View, and then 
click Bottom. 

 

 
Three viewports are split down the middle either horizontally or 

vertically. 
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To change the shape of viewports: 

1 Move your cursor to the edge of a viewport until you see the resizing  or  cursor, hold the left mouse 

button down, and drag the bar. If two viewports share the edge, both resize. 

2 Move your cursor to the corner of a viewport until you see the resizing  cursor, hold the left mouse, and 

drag the intersection in any direction. If several viewports touch at that corner, all resize. 

To synchronize the viewports: 

1 Adjust the size or shape of the 
viewports. 

2 Make one of the Front viewports 
active. 

3 From the View menu click Zoom, 
and then click Zoom Extents. 

4 Right click on the Front viewport 
title, click Set Camera, and then 
click Synchronize Views. 

5 Change the viewport displays to one 
of the shaded viewport settings. 

6 Right click on the Front viewport title 
on the left, click Set View, then click 
Left. 

7 Right click on the Right viewport title 

on the right, click Set View, then 
click Back.  

All the parallel views are sized to the same scale as the active  

viewport and aligned with each other. 

To zoom to a window:  

1 From the View menu click Zoom, 
and then click Zoom Window. 

2 Click and drag a window around a 
portion of the model. 

  

To zoom a selected object:  

1 Select the shutter release. 

2 From the View menu click Zoom, and 
then click Zoom Selected. 

The view zooms to the selected 

object. 
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To rotate the view: 

1 In a perspective viewport, drag with right mouse button. 

2 In a parallel viewport, from the View menu, click Rotate or use Ctrl +Shift and drag with the right mouse 

button. 

To maximize and restore a viewport: 

1 Double-click the viewport title to maximize it. 

2 Double-click the title of the maximized viewport to restore it to its smaller size and reveal the other viewports. 
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PART TWO 
Creating and Editing Geometry 
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3 Creating Geometry 

Drawing lines 

The Line, Lines, and Polyline commands draw straight lines. The Line command draws a single line segment. The 

Lines command draws multiple end-to-end line segments. The Polyline command draws a series of straight or arc 

joined segments (a single linear curve with multiple segments). 

Option Description 

Close Closes the shape by drawing a segment from the last point picked to the first point picked. This ends the 
command. 

Undo Deletes the last point picked. 
 

Exercise 3—Drawing lines 

1 From the File menu click New. Do not save changes. 

2 In the Template File dialog box, double click Small Object - Millimeters.3dm. 

3 From the File menu click Save As. 

4 In the Save dialog box, type Lines, and then click Save. 

To draw line segments: 

1 From the Curve menu click Line, and then click Line Segments to begin 
the Lines command. 

2 Pick a point in a viewport. 

3 Pick another point in a viewport. 

A line segment appears between the two points. 

4 Continue to pick points. 

Additional segments appear.  

5 Press Enter to end the command. 

The segments meet at a common point, but are not joined. 

 

To use the Close option: 

1 Repeat the Lines command. 

2 Pick a Start point and 3 or 4 more points. 

3 Click Close on the command line. 

This is one of the clickable options discussed in the previous chapter. 

The last line segment will end at the original start. 
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To draw a polyline: 

1 Use the Undo command to undo the segments you just created. 

2 From the Curve menu click Polyline, and then click Polyline to begin the 
Polyline command. 

3 Pick a Start point and 3 or 4 more points. 

4 Press Enter when done. 

This makes an open polyline. A polyline is made of line segments that 

are joined together. It is one object.  

To use the Undo option: 

1 Repeat the Polyline command. 

2 Pick a Start point and 3 or 4 more points. 

3 Click Undo on the command line.  

Notice that your cursor moves back to the previous point and one 

segment of the polyline is removed. 

4 Continue to pick points.  

5 Click Close to end the command. 

This makes a closed polyline. 

 

To draw a single line segment: 

1 From the Curve menu click Line, and then click Single Line to begin the 
Line command. 

2 Pick a Start point. 

3 Pick an End point. 

The command ends after one segment is drawn. 

 

To use the Bothsides option:  

1 From the Curve menu click Line, and then click Single Line to begin the 
Line command. 

2 Click Bothsides on the command line. 

3 Pick a Middle point. 

4 Pick an End point. 

A segment is drawn with equal length on both sides of the middle point. 

 

Drawing free-form curves 

The InterpCrv and Curve commands draw free-form curves. The InterpCrv command draws a curve through the 

points you pick. The Curve command uses control points to create a curve. 

Option Description 
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Close Closes the shape by drawing from the last point picked to the first point picked. This ends the command. 

EndTangent After choosing a point on another curve, the next segment will be tangent to the point you picked and end 
the command. 

Undo Deletes the last point picked. 

Degree You can set the degree of the curve. 

Knots Determines how the interpolated curve is parameterized. 

When you draw an interpolated curve, the points you pick are converted into knot values on the curve. 
The parameterization means how the intervals between knots are chosen. 

Sharp When you make a closed curve, it will come to a point instead of making a smooth closure as it normally 
does. 

Exercise 4—Drawing interpolated curves 

1 From the Curve menu click Free-form, and then click Interpolate 
Points. 

2 Pick a Start point. 

3 Continue picking points. 

Notice that with this command the curve goes through each point that 

you pick. 

4 Press Enter to end the command. 

This makes an open curve.   

Exercise 5—Drawing curves from control points  

1 From the Curve menu click Free-form, and then click Control Points. 

2 Pick a Start point. 

3 Continue picking points. 

Notice that most of the points you pick are off the curve as control 

points. 

 

4 Click Close to make a closed curve. 

 

 

Modeling aids 

Modeling aids are modes that you can toggle on or off by pressing shortcut keys, a function key, typing a single 

letter command, or clicking a button.  
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Click the Grid Snap, Ortho, Planar, Gumball, SmartTrack or Record History panes on the status bar to 
toggle these modeling aids on and off. 

Grid Snap 

This modeling aid constrains the marker to snap on grid intersections.  

You can also toggle Grid Snap on and off by pressing F9 or typing the letter S and pressing Enter. 

Pressing F7 hides or shows a reference grid in the current viewport of the graphics screen at the construction plane. 

Ortho 

This modeling aid constrains the marker movement to the points at a specified angle from the last point created. 

The default angle is 90 degrees. 

You can also toggle Ortho on and off by pressing F8 or pressing and holding the Shift key down.  

Osnap 

Object snaps constrain the marker to an exact location on an object such as the end of a line or the center of a 

circle. 

SmartTrack 

This modeling aid uses temporary reference lines and points that are drawn in the Rhino viewport using implicit 

relationships among various 3-D points, other geometry in space, and the coordinate axes' directions. 

Planar 

This is a modeling aid similar to Ortho. This helps you model planar objects by constraining the input to be on a 

plane parallel to the construction plane that passes through the last point that you picked. 

You can also toggle Planar on and off by typing the letter P and pressing Enter. 

Gumball 

Displays a display widget, on a selected object, facilitating move, scale, and rotate transformations around the 

gumball origin. 

Record History 

Records history and updates history-aware objects. With History recording and Update turned on, a lofted surface, 

for example, can be changed by editing the input curves. 

In general, it is best to leave the Record option set to No and use the Record History status bar pane to selectively 

record history. Recording history uses computer resources and makes saved files larger. 

Filter 

This modeling aid restricts any selection mode to specified object types. Objects types that can be restricted are: 

Annotations, Blocks, Control points, Curves, Lights, Meshes, Point clouds, Points, Polysurfaces, Surfaces, Hatches, 

and others. 

Exercise 6—Drawing lines and curves using mode functions 

1 Toggle Grid Snap on and draw some lines. 

In this model the marker snaps to each grid intersection. This is because in the template file we’re using the 

SnapSize and the Grid-MinorLineSpacing is set to the same value (1). 

2 Toggle Grid Snap off, toggle Ortho on and draw some lines and curves. 

You can only input points that are at 90 degree intervals from the last point. Using Grid Snap and Ortho toggles 

you can draw with precision. We will discuss other ways to get precision in a later session. 

Saving your work 

Save your work periodically during a session to keep it from being accidentally deleted.  

To save your model: 

���� From the File menu click Save. 

Or, click one of the other options. You will have an opportunity to save your work. 
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It is good practice to save your model in stages under different names, using the Save As command. This 

lets you go back to an earlier version of your model for modifications if necessary. 

Command Description 

Save Saves your model and keeps it open. 

SaveSmall Save your model without render or analysis meshes and preview image to minimize file 
size. 

IncrementalSave  Save sequentially numbered versions of your model. 

SaveAs Saves your model to a specified file name, location, and format.  

SaveAsTemplate Save as a template. 

Revert Discards changes and reverts to the previously saved document. 

Layers  

Rhino layers work like CAD layering systems. By creating objects on different layers, you can edit and view related 

portions of a model separately or as a composite. You can create as many layers as you like. 

You can display all layers simultaneously or turn 

any of them off. You can lock layers so they are 

displayed but cannot be selected. Each layer has a 

color. You can assign a name to each layer (for 

example, Base, Body, Top) to organize the model 

or you can use preset layer names (Default, 

Layer 01, Layer 02, Layer 03).  

The Layers panel manages layers. Use it to set up 

layers for your model. The Layers panel can be 

floating or docked with the other tabbed panels 

like Properties, Command Help, Lights, Notes, and 

more. 
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Exercise 7—Layers  

To create a new layer: 

1 From the Edit menu click Layers, and then click Edit Layers. 

2 In the Layers panel, click the New icon. 

3 The new layer, Layer 06, appears in the list. Type Lines and 
press Tab. 

Use the Tab key to quickly add layers. 

4 The new layer, Layer 06, appears again. Type Curves and 
press Tab. 

5 The new layer, Layer 06, appears. Type Solids and press 
Enter. 

 

 
The Default layer is created 

automatically when you start a new 

model with no template. If you use a 

standard Rhino template, a few 

additional layers are also created. 

To assign a color to a layer:  

1 Click the square Color patch on the Lines row in the list. 

2 In the Select Color dialog box, click Red from the list. 

 The right half of the sample rectangle turns red. 

Hue, Sat, Val are the hue, saturation and value components of 

the color.  

R, G, and B are the red, green and blue components of the 

color. 

3 Click OK. 

4 In the Layers panel, the new color appears in the color patch 
on the Lines row of the layer list. 

5 Repeat steps 1–3 to make the Curves layer Blue. 

6 Click OK to close the dialog box, 

 

 

To make a layer current: 

1 In the Status Bar, click the Layer pane. 

 

The Status Bar-Layer pane displays the current layer (Default). 
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2 In the Layer popup, click Lines. 

The current layer is displayed in the Layer pane. 

3 Draw some lines. 

The lines are on the Lines layer and they are colored red. 

4 To make a different layer current, click the Layer pane again. 

5 Click Curves. 

6 Draw some curves. 

They are on the Curves layer and are colored blue. 

7 Draw more lines and curves on each layer. 

 

Clicking the name or the  

checkbox sets the current  

layer. 

Note: If objects are highlighted, and a layer is selected from the Status bar, the highlighted objects will be 

changed to the selected layer and the current layer does not change. 

To lock a layer: 

1 In the Status Bar, click the Layer pane, click Solids to make the Solids layer current. 

2 In the Layer popup, click the Lock icon on the row for the Lines layer. 

Locking a layer turns it into a reference only layer. You can see and snap to objects on 

locked layers. You cannot select any objects on locked layers. You cannot make a locked 

layer current without unlocking it.  

 

To turn a layer off: 

1 In the Status Bar, click the Layer pane. 

2 In the Layer popup, click the On/Off icon (light bulb) in the row for the Curves layer. 

Turning a layer off makes all objects on it invisible. 

 

To select a single object: 

���� Move your pointer arrow over the object and left-click. 

The object turns yellow, which is the default highlight color. 

To select more than one object: 

1 Move your pointer arrow over the first object and left-click. 

2 While holding the Shift key down, move your pointer over another object and left click. 

To hide an object:  

1 Select an object. 

2 From the Edit menu click Visibility, and then click Hide. 

The object becomes invisible. 

To show hidden objects:  

���� From the Edit menu click Visibility, and then click Show. 

The Show command redisplays all hidden objects. 
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To lock an object:   

1 Select an object. 

2 From the Edit menu click Visibility, and then click Lock. 

The object becomes shaded gray. You can see the locked object, you can snap to it, but you cannot select it. 

To unlock locked objects:  

���� From the Edit menu click Visibility, and then click Unlock. 

The Unlock command unlocks all locked objects.  

To change an object from one layer to another:   

1 Select an object. 

2 From the Edit menu click Layers, and then click Change Object Layer. 

3 In the Layer for object dialog box, select the new layer for the object, and 
click OK. 

 

Selecting objects 

Delete removes selected objects from the model. Use Delete to practice selecting objects. 

Exercise 8—Practice using selection options 

1 Open the model Delete.3dm.  

2 Select the square and the circle. 

3 From the Edit menu click Delete or press the Delete key. 

The objects disappear. 
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To select objects for deletion: 

1 Select one of the lines on the hexagon in 

the Top viewport. 

Because there are several curves 

superimposed on each other, the 

selection menu appears, allowing you to 

select one of the curves. 

2 Select the top curve from the list.  

3 From the Edit menu click Delete. 

Observe one disappear in the 

Perspective viewport. 

 

 

4 In the Top viewport, use a crossing 
box to select the surface and the 

polyline in the top right part of the 

drawing. 

A crossing box is used when 

selecting in an open area and then 

dragging the window from right to 

left. 

Both objects are selected.  

5 From the Edit menu click Delete.  

  

6 Make a window to select the polyline 
and the cylinder in the lower right 

part of the drawing. 

Only those objects that are 

completely inside the window are 

selected. 

7 Hold the Ctrl key down and click on 
the cylinder to remove it from the 

selection set. 

8 From the Edit menu click Delete. 

  

9 Continue deleting objects in the drawing.  

Practice using different selection methods to select and deselect objects. Use crossing and window.  

The Shift key while selecting will let you add to your selection set.  

The Ctrl key while selecting will let you to remove objects from your selection set. 

To undo and redo deletions: 

1 From the Edit menu click Undo. 

Each time you click, Undo takes you back one command. 
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2 From the Edit menu click Redo. 

Each time you click, the previous Undo is reinstated. 

3 Undo all the deletions you made in the previous exercise. 

Dedicated selection commands 

In addition to the selection options we just practiced, there are several other useful tools for selecting objects. In 

the next exercise we will use some of these tools. 

Command Button Menu Label Description 

SelAll 

 

All Objects 
(Ctrl+A) 

Select all objects. 

SelNone 

 

None (Esc) Deselect all objects. Note: SelNone does not run inside a command to clear pre-
selected objects. 

Invert 

 

Invert Deselects all selected objects and selects all visible objects that were not 
previously selected. 

SelPrev 

 

Previous Selection Re-selects the previous selection set. 

SelLast 

 

Last Created 
Objects 

Selects the last changed objects. 

SelPt 

 

Points Select all point objects. 

SelCrv 

 

Curves Select all curves. 

SelPolyline 

 

Polylines Select all polylines.  

SelSrf 

 

Surfaces Select all surfaces. 

SelPolysrf 

 

Polysurfaces Select all polysurfaces. 

To access select tools from the Select Toolbar: 

1 From the Tools menu, click Toolbar 
Layout.  

2 Select Default under Files. 

3 Choose Select as the toolbar to show. 

The Select toolbar appears. 
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To select objects using select tools: 

1 From the Edit menu click Select Objects, and then click Curves.  

All the curves are selected. 

2 From the Edit menu click Select Objects, and then click Invert.  

Everything but the previously selected curves is selected. 

3 From the Edit menu click Select Objects, and then click None.  

Everything is unselected. 

4 From the Edit menu click Select Objects, and then click Polylines.  

All of the polylines are selected. 

5 From the Edit menu click Select Objects, and then click Surfaces.  

The single surface is added to the selection set. 

6 From the Edit menu click Select Objects, and then click Polysurfaces.  

The polysurfaces are added to the selection set. 

7 From the Edit menu click Select Objects, and then click None.  

8 Draw a few lines and curves. 

9 From the Edit menu click Select Objects, and then click Last Created Objects.  

The last object you created is selected. 

Filter Selection  

A filter restricts any selection mode to specified object types. Objects types that can be restricted are: 

Annotations, Blocks, Control points, Curves, Lights, Meshes, Point clouds, Points, Polysurfaces, Surfaces, Hatches, 

and Others. 

1 From the Status bar, click on Filter. The 
selection Filter dialog will appear.  

2 Right-click Curves and all other selection 

options are unchecked. 

  

3 Use a crossing box to select the entire 

the drawing. 

Only the curves are selected.  

4 Press Esc to deselect. 
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5 Right-click Surfaces and all other selection options are unchecked. 

 

 

6 Use a crossing box to select the entire 
the drawing. 

Only the surfaces are selected. 

7 Press Esc to deselect. 

  

8 Right-click Polysurfaces and all other selection options are unchecked. 

 

 

9 Use a crossing box to select the entire 
the drawing. 

Only the Polysurface objects are 

selected. 

10 Press Esc to deselect. 

  

11 Reset all filters to on. 
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4 Precision modeling 
So far you have been drawing imprecise lines. Now you will try drawing lines at specific places. To do this you will 

use coordinates.  

Whenever you draw a curve, or create a solid primitive, Rhino asks you for a series of points. You can tell that 

Rhino is asking for point input two ways: the command prompt has a prompt like Start of line, Start of polyline, 

Start of curve, or Next point and the arrow-shaped cursor turns into a cross-shaped  cursor.  

You can enter a point two ways: pick a point in a viewport with the mouse, or type coordinates at the command 

line.  

You will select the units and tolerance of the model before you begin. You can do this in the Options dialog under 

the Units page or by picking a template that has units and Tolerance already set. 

You can change the tolerance after you start, but objects that are edited before the change still have the old 

tolerance value.   

Coordinate entry 

Rhino uses a fixed Cartesian coordinate system called the world coordinate system (WCS), based on three axes 

(the x-, y-, and z-axes) that define locations in three-dimensional space. 

Each viewport has a construction plane that defines coordinates for that viewport. We will work in the Top and 

Perspective viewports where the two coordinate systems are the same.   

Absolute coordinates 

The first forms of coordinates you will use are called absolute coordinates. Absolute coordinates are exact 

locations relative to the x-, y-, and z-axes.  

Exercise 9Setting up a model  

1 From the File menu click New. 

2 Click Small Object - Millimeters.3dm, and then click Open. 

3 From the File menu click Save As. Name the model BOXES. 

Use the BOXES.3dm model to learn how to draw with absolute coordinates.  

Exercise 10—Entering absolute coordinates 

1 Double-click the viewport title to maximize the Top viewport. 

2 From the Curve menu click Polyline, and then click Polyline. 

 

3 To Start type 0 and press Enter. 

If you are going to start at the origin of the sheet (0,0,0) you 

can simply type 0 as a shortcut. 

4 For the Next point type 5,0 and press Enter. 

5 For the Next point type 5,5 and press Enter. 

6 For the Next point type 0,5 and press Enter. 

7 Click Close to close the polyline. 

0,5 5,5

5,00,0  
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Relative coordinates 

Absolute coordinates can be slow and cumbersome, but they do work. Most of the time, relative coordinates are 

easier to use. 

Every time you select a point, Rhino saves that point as the last 

point.  

Relative coordinates are based on the last point entered, instead of 

on the origin (0,0,0) of the construction plane.  

Precede the x,y,z coordinates with a single R (upper or lower case) to 

enter relative coordinates. Use the @ symbol instead of an R to start 

relative coordinates if you prefer. 

Next Point

Last Point

Change in Y

Change in X  

Exercise 11—Entering relative coordinates 

1 From the Curve menu click Polyline, and then click Polyline. 

2 To Start type 8,0 and press Enter. 

These are absolute coordinates. 

3 For the Next point type R5,5 and press Enter. 

These are relative coordinates. 

4 For the Next point type R-5,0 and press Enter. 

5 Click Close to close the polyline. 

5
.0

0

R5,5

8,0

R-5,0

5.00  

Polar coordinates 

Polar coordinates specify a point that is a distance and direction away from 0,0 in the current construction plane.  

Vector directions in Rhino start with Zero degrees at 3 o'clock on a standard clock. They change in an anti-

clockwise direction as illustrated below.  

For example, if you want a point four 

units away from the construction 

plane origin, at a 45° angle 

counterclockwise from the 

construction plane x-axis, type 4<45, 

and press Enter.  

Relative polar coordinates are 

preceded by R or @; absolute polar 

coordinates are not.  

 

Next Point

Last Point

Angle
Distance

 

Instead of using x, y, and z coordinates, 

enter relative polar coordinates like 

this: Rdistance<angle. 

120

300

27
0

210

150
9
0

60

30

0

330

24
0

180
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Exercise 12—Entering polar coordinates 

1 From the Curve menu click Polyline, and then click Polyline. 

2 To Start type 0,8 and press Enter. 

3 For the Next point type R5<0 and press Enter. 

4 For the Next point type R5<90 and press Enter. 

5 For the Next point type R5<180 and press Enter. 

6 Click Close to close the polyline. 

R5<180

0,8 R5<0

R5<90

 

Distance and angle constraint entry 

Using distance constraint entry, you can specify a point by typing a distance and pressing Enter. Then as you 

move your cursor in any direction, the distance from the last point will be constrained. This is a good way to 

specify a line length quickly. 

Using angle constraint entry, you can specify an angle by typing < followed by a value and pressing Enter. The 

next point is constrained to lines at multiples of the angle relative to the x-axis you specified. 

Using the Shift key to toggle Ortho on and off: 

When Ortho is off, hold the Shift key down to toggle it on. This method is an efficient way to draw perpendicular 

lines. In the following example, draw a line five units long using distance constraints. 

Exercise 13—Distance constraint entry 

1 From the Curve menu click Polyline, and then click Polyline. 

2 To Start type 8,8 and press Enter. 

3 For the Next point type 5 and press Enter. 

4 Hold the Shift key down and pick a point to the right. 

Ortho constrains the marker to 0 degrees.  

5 For the Next point type 5 and press Enter. 
Distance Constraint

 

6 Hold the Shift key down and pick a point up. 

Ortho constrains the cursor to 90 degrees 

7 For the Next point type 5 and press Enter. 

8 Hold the Shift key down and pick a point to the left. 

Ortho constrains the cursor to 180 degrees. 

9 Click Close to close the polyline. 

Exercise 14—Distance and angle constraint entry 

1 From the Curve menu click Polyline, and then click Polyline. 

2 To Start type 16,5 and press Enter. 

3 For the Next point type 5 and press Enter, then type <45 and press 
Enter. 

As you drag your cursor around, the marker snaps to a distance of 5 

and an angle of 45 degrees. 

 

Angle Constraint
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4 Pick a point down and to the right.   

The angle constraint sets the angle. 

5 For the Next point type 5 and press Enter, then type <45 and press Enter. 

6 Pick a point up and to the right. 

The angle constraint sets the angle. 

7 For the Next point type 5 and press Enter, then type <45 and press Enter. 

8 Pick a point up and to the left. 

The angle constraint sets the angle. 

9 Click Close to close the polyline. 

10 Save your model. You will use this model for another exercise. 

Exercise 15—Practice using distance and angle constraint entry 

1 Start a new model, use the Small Objects - Millimeters.3dm template. Save as Arrow. 

Since the object is symmetrical, you will only draw the lower half of the model. 

 

2.00

2.00 1.00

1.00
2.00

6.0011.008.00

START MODEL AT -11,0

 

Draw the arrow with a polyline, using a combination of absolute coordinates (x,y), relative coordinates 

(Rx,y), polar coordinates (Rdistance<angle), and distance constraint.  

The following is an example of the command line input that you might use: 

Absolute x,y 

2 From the Curve menu click Polyline, then click Polyline. 

3 For the Start of Polyline type -11,0. 

Relative x,y 

4 For the Next point, type r-2,-2. 

Distance constraint 

5 For the Next point, type 8 and press Enter, turn Ortho on and then pick to the right. 

Relative x,y 

6 For the Next point, type r1,1. 

Relative polar 
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7 For the Next point, type r11<0. 

Distance constraint 

8 For the Next point, type 1 and press Enter, turn Ortho on and then 

pick down. 

9 For the Next point, type r6,2. 

10 For the Next point, press Enter to end the command. 

11 Save your model. 

 

To make a copy of the polyline: 

1 Select the polyline. 

2 From the Transform menu click Copy.  

3 For the Point to copy from, pick a point near the polyline. 

4 For the Point to copy to, type 6 and press Enter, turn Ortho on and 
pick above the selected polyline. 

5 Press Enter to end the command. 

 

To make a mirror image of the polyline: 

1 Select the original polyline. 

2 From the Transform menu click Mirror.  

3 For the Start of mirror plane, type 0 and press Enter. 

4 For the End of mirror plane, turn Ortho on and then pick to the right. 

 

To make it 3-D: 

1 Right-click on the Perspective title and set the display mode to Shaded. 

2 Select the original polyline and the mirror copy. 

3 From the Solid menu and click Extrude Planar Curve, click Straight. 

4 For the Extrusion distance, type 1 and press Enter. 

 
Your arrow is now a  

three-dimensional model. 
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To make it 3-D (alternate): 

1 Select the copy of the polyline. 

2 On the Status bar, click Osnap. 

3 On the Osnap toolbar check End. 

4 From the Surface menu click Revolve.  

5 For the Start of revolve axis, select the end of the polyline. 

6 For the End of revolve axis, select the other end of the polyline along 
the centerline. 

7 Press Enter to use the default Start angle. 

8 Press Enter to use the default Revolution angle. 

 
Your arrow is now a  

three-dimensional model. 

To deform the shape: 

1 Select the 3-D arrow.  

2 From the Transform menu click Bend. 

 

 

3 For the Start of spine, click 
the end point on the left end of 

the arrow. 

4 For the End of Spine, click the 
end point on the right end of 

arrow. 

  

5 For the Point to bend through, drag the cursor down and pick a 
point. 
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Exercise 16—Practice using distance and angle constraints 

1 Start a new model using the Small Objects – 

Millimeters.3dm template. Save as V-Block. 

2 Double-click the viewport title in the Front viewport to 
maximize it. 

 Create the following model in the front construction 

plane. 

3 Draw the object below using a combination of absolute 
coordinates (x,y), relative coordinates (rx,y), and 

relative polar coordinates (rdistance<angle). 

4 Start your model at 0 in the Front viewport.  

Try to create the model using a single polyline in a 

clockwise direction. 

5 Double-click the viewport title of the Front viewport to 
restore your views. 

 

16.0

8.0

8.0

40.0

40.0

8.0

8.0

8.0

120°

45° 36.77

12.0

40.0

 

6 Select the polyline. 

7 From the Solid menu click Extrude Planar Curve , and then click 

Straight. 

8 For the Extrusion Distance type 150 and press Enter. 

You can view the model as a three-dimensional object in the Perspective 

viewport. 

9 Save your model. 

 

Object Snaps 

Object Snaps are tools for specifying points on existing objects. Use osnaps for precision modeling and to get 

accurate data. Object snaps are often referred to as osnaps. In Rhino, reliable modeling and easy editing depends 

on objects actually meeting at specified points. Objects snaps give you precision you cannot get using the 

“eyeball” method 

To open the Osnap toolbar 

���� Click the Osnap pane in the status bar.  

This toolbar controls persistent object snaps. 

 

The display of the Osnap toolbar is controlled with the Osnap pane in the Status bar.  

Click on it to toggle the display on and off. 

 

Use persistent objects snaps to maintain an object snap through choosing several points without having to 

reactivate the object snap. 
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When an object snap is active, moving the cursor near an eligible point on an object causes the marker to jump to 

that point and a tooltip to appear. 

Left click on a check box to turn on the object snap.  

Right click on a check box to turn on the object snap and clear all other osnaps.  

You can place the toolbar anywhere on your desktop.  

Command Button Description 

End 

 

End snaps to the end of a curve, surface edge corner or polyline segment end. 

Near 

 

Near snaps to the nearest point on an existing curve or surface edge. 

Point 

 

Point snaps to a control point or point object. 

Mid 

 

Midpoint snaps to the midpoint of a curve or surface edge. 

Cen 

 

Center snaps to the center point of a curve. This works best with circles and arcs.  

Int 

 

Intersection snaps to the intersection of two curves. 

Perp 

 

Perpendicular To snaps to the point on a curve that makes a perpendicular to the last selected point. 
It doesn't work on the first point that a command prompts you to pick. 

Tan 

 

Tangent To snaps to the point on a curve that makes a tangent to the last selected point. It doesn't 
work on the first point that a command prompts you to pick. 

Quad 

 

Quad snaps to the quadrant point. The quadrant point is the maximum or minimum direction on a 
curve in the x or y construction plane direction. 

Knot 

 

Knot snaps to knot points on curves or surface edges. 

Project 

 

Projects the snap point to the construction plane. 

Vertex 
 

Mesh vertex is the location where the edges of the mesh faces meet. 

Disable 

 

Temporarily turns off persistent object snaps, retaining settings 

Exercise 17—Using object snaps 

In this model we will practice using most of the osnaps listed on the toolbar. 

1 Open the model Osnap.3dm. 

2 Toggle Grid Snap and Ortho off. 

Using End and Midpoint object snaps: 

1 Click the Osnap pane on the status bar. 

You can leave the Osnap toolbar displayed. 

 
Osnap bar with the End and Mid osnaps turned on. 

2 Check End and Mid. 

You can check and clear individual object snaps to make modeling with precision easy. 
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3 From the Curve menu click Polyline, 
and then click Polyline. 

4 For the Start of Polyline, move your 
cursor close to the end of the line at 

the lower left corner of the first 

square and pick when the marker 

snaps to the end of the line. 

The line starts exactly at that 

corner.   

 

  

5 For the Next point, move your cursor close to the midpoint of the vertical line at the right side of the square 
on the right, pick when the marker snaps to the midpoint. 

The marker snaps to the midpoint of the line that the cursor touches, making the new line cross to the exact 

midpoint of that side. 

6 For the Next point, move your cursor close to the end of the line at the 
upper left corner of the first square, pick when the marker snaps to the 

end of the line. 

The marker snaps to the end of the line.  

7 Press Enter to end the command. 

 

Using Near and Perpendicular to object snaps: 

1 In the Osnap toolbar check Near and 
Perp, clear End and Mid. 

2 From the Curve menu click Line, and 

then click Single Line. 

3 For the Start of line, pick on the 
lower edge of the circle at the top 

right. 

The marker snaps to the point on 

the circle nearest to where the 

cursor is positioned. 

4 For the End of line, pick the top 
horizontal edge of the second square 

when the Perp tooltip appears.  

  

The marker snaps to a point making a perpendicular to the previous point. 
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Using Intersection and Tangent to object snaps: 

1 In the Osnap toolbar check Int and 

Tan; clear Near and Perp. 

2 From the Curve menu click Line, and 
then click Single Line. 

3 For the Start of line, pick the 
intersection where the diagonal line 

crosses the vertical line on the first 

square. 

The marker snaps to the intersection 

between the two lines. 

  

4 For the End of line, pick the top, left edge of the circle on the right. 

The marker snaps to a point tangent to the circle. 

Using Center of object snap: 

1 In the Osnap toolbar check Cen, clear 
Int and Tan. 

2 From the Curve menu click Line, and 
then click Single Line. 

3 For the Start of line, pick on the 
edge of a circle. 

The marker snaps to the center of 

the circle. 

4 For the End of line, pick on the edge 
of the other circle. 

The marker snaps to the center of 

the circle. 
  

Using Quadrant of object snap: 

1 In the Osnap toolbar check Quad, 
clear Cen. 

2 From the Curve menu click Polyline, 
and then click Polyline. 

3 For the Start of Polyline, pick a 

point on the top edge of the first 

circle. 

The marker snaps to the quadrant 

point of the circle. 

4 For the Next point, pick the left edge 
of the circle. 

The marker snaps to the quadrant 

point of the circle. 
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5 For the Next point, pick the bottom edge of the circle. 

6 For the Next point, pick the right edge of the circle. 

7 Click Close to finish. 

8 Use the SaveAs command to save the model. Name it Analyze. We will 
use it for a later exercise. 

 

Additional modeling aids 

As well as allowing the user to work in a completely unconstrained free-form manner Rhino has a number of 

modeling aids and constraints that help with precision modeling. This section outlines these aids and constraints. 

SmartTrack 

SmartTrack creates a set of temporary reference lines and points that work in conjunction with Rhino’s object 

snaps. Using SmartTrack obviates the need to create dummy reference lines and points. SmartTrack works on 

both 2-D and 3-D objects. It can be used in conjunction with the Project and Planar constraints described later in 

this section. 

Exercise 18—SmartTrack 

To use the SmartTrack tool: 

1 Open the model Constraints.3dm and maximize the Top Viewport. 

2 Make sure that the following object snaps are turned on: End, Near, Point, Mid, Cen and Int. 

3 Turn on SmartTrack on the Status Bar. 

4 From the Curve menu click Point Object, then 
click Single Point. 

5 Hover the cursor over the lower left corner of 
the green rectangle, the End snap will be 

displayed and a white marker point becomes 

visible. 

6 Repeat this process on the bottom left hand 

corner of the gold rectangle. 

  

7 Now move the cursor towards the apparent 

intersection point of these two corners. Two 

temporary construction lines are displayed. 

The point is positioned on the intersection of 

these two construction lines. 

8 Click to place the Point Object. 

SmartTrack will work with any of the available 

object snaps. Experiment with some 

alternatives.  
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Tab Constraint 

The Tab constraint allows the user to fix a direction to a reference point and thereby constrain cursor movement. 

The following example shows a simplistic use of the Tab constraint. 

Exercise 19—Tab Constraint 

To use the Tab Constraint: 

1 We will work with the Constraints.3dm file as 
previous and again maximize Top view.  

2 Turn off SmartTrack. 

3 From the Curve menu click Line, then click 
Single Line. 

4 For the Start of Line, snap to the End of the 
bottom left hand corner of the gold rectangle. 

5 For the End of Line, hover the mouse over the 
bottom left hand corner of the green rectangle, 

when the End snap appears press the Tab key.   

Note that the line now becomes white and the 

direction is constrained. 

6 For the End of Line, drag your mouse to the 
desired location and click. 

The Tab constraint will work in conjunction 

with all object snaps and all tools that require 

a directional input, for example Move, Copy, 

and Rotate. 

  

Project constraint 

By default 2-D geometry is created on the active construction plane. Object snaps override this behavior and 

snapping to objects that are not on the construction plane will cause the geometry to be non-planar. The Project 

constraint ignores objects snaps and pushes all the geometry onto the active construction plane. 

Exercise 20—Project Constraint 

To use the Project Constraint: 

1 We will again work with the Constraints.3dm 
file as previous. 

2 Make sure that the Ortho constraint is On. 

3 Turn Layer 01 off and turn Layer 02 on. 

The surfaces on Layer 02 are located at 

different elevations. 

4 From the View menu, click Zoom, then click 
Zoom Extents. 

5 Double-click on the Top viewport title to restore 
the 4 View layout. 

  

6 Working in Top viewport, draw a Polyline around the perimeter of the three rectangles.   

In the Perspective view, notice how the how the planar nature of the polyline is overridden by the object 

snaps. 
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7 Delete the Polyline. 

8 Turn on the Project constraint on the Osnap 
toolbar. 

9 Again, working in Top viewport, draw a Polyline 
around the perimeter of the three rectangles. 

Look in the Perspective viewport as you draw 

the polyline and note how the object snaps for 

the endpoints of the green and blue rectangles 

are projected to the construction plane. 

  

The Project constraint forces all the segments of the polyline onto the construction plane. The resulting 

polyline is planar. 

10 Delete the Polyline. 

Planar constraint 

The Planar constraint limits successive picked locations to the same construction plane elevation as the previous 

location. For example a command such as Polyline can be started off the construction plane and the Planar 

constraint will override Rhino’s default behavior of snapping back to the construction plane.  

Exercise 21—Planar Constraint 

To use the Planar Constraint: 

We will first look at what happens with the Planar constraint Off. Then, we will turn the Planar constraint On to see 

what changes. 

1 We will again work with the Constraints.3dm 
file as previous.  

2 Turn off the Ortho and Planar constraints, and 
Project on the Osnap toolbar. 

3 Start the Polyline command. 

4 Working in the Top Viewport, start the Polyline 
at the lower left corner of the Green rectangle. 

5 Add some more segments without snapping to 
any of the objects. 

Look at the Perspective viewport and notice 

how the polyline pulls back onto the 

construction plane after the initial point. 

  

6 To override this behavior and create a planar 
curve delete the Polyline and turn on the Planar 
constraint. 

7 Draw the Polyline again.  

Note how it now remains planar. 

8 Delete the Polyline. 
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To create a planar curve above the active construction plane: 

First we will draw a polyline without the Project constraint activated. Then we will use the planar constraint in 

conjunction with the Project constraint to see what changes. 

1 Turn the Planar constraint On. 

2 In the Top viewport, draw a new Polyline starting again at one of the corners 
of the Green rectangle.  

3 Create some additional points this time snapping to some of the Blue and Gold 
rectangle corner points. 

Look at the Perspective view and note how the object snaps override the 

Planar constraint. 

4 Delete the Polyline. 

  

5 In the Perspective viewport, draw a new 
Polyline starting again at one of the corners of 

the Green rectangle.  

6 After making the first point, turn the Project 
constraint On. 

7 Create some additional points, snapping to 
some of the Blue and Gold rectangle corner 

points. 

Note that the points stay planar to the first 

point, even though you are snapping to 

points that are at different elevations. 
  

Viewports and construction planes 

In the following exercise, we will practice using Osnaps while learning more about Viewports and Construction 

planes.  

Exercise 22—Intro to construction planes 

���� Open the model Cplanes.3dm. 
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Viewports 

Viewports are windows in the Rhino graphics area that show you a view of your model. To move and resize 

viewports, drag the viewport title or borders. You can create new viewports, rename viewports, and use 

predefined viewport configurations. To activate a viewport click anywhere in the viewport and the title highlights. 

If you are in a command sequence, you simply have to move your cursor into a viewport to activate it. 

Construction planes 

The construction plane is the guide used for modeling Rhino objects. Points you pick are always on the 

construction plane unless you use coordinate input, elevator mode, or object snaps. 

Each construction plane has its own axes, a grid, and 

an orientation relative to the world coordinate system. 

The grid is a plane of perpendicular lines lying on the 

construction plane. On default grids, every fifth line is 

slightly thicker.  

The red line represents the construction plane x-axis. 

The green line represents the construction plane y-axis. 

The red and green lines meet at the construction plane 

origin. 

The icon in the left hand corner always shows world 

coordinates, which are different from the construction 

plane axes.  

Default construction planes are provided with the 

default viewports. 
 

• The Top construction plane x- and y-axes align with the world x- and y-axes. 

• The Right construction plane (x- and y-axes) align with the world y- and z-axes.  

• The Front construction plane (x- and y-axes) align with the world x- and z-axes.  

• The Perspective viewport uses the Top construction plane. 
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You can set construction planes by: 

• Typing Cplane 

• From the View Menu 

• Right click on the viewport title 

• Pick the Arrow on the viewport title. 

There are many options to the Cplane 

command. In this exercise, you will work 

with: 

• Origin 

• 3 Point 

• To Object 

• Named Cplanes 

 

To change a Cplane using the 3 Point option: 

1 From the View menu click Set Cplane, and then click 3 Points. 

2 For the Cplane origin, snap to the lower left corner of the surface labeled 
as 1. 

 

3 For the X axis direction, snap to the lower right corner of the surface 
labeled as 1. 
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4 For the Cplane orientation, snap to 
the upper left corner of the surface 

labeled as 1. 

Now the Cplane is set 

  

5 From the Solid menu click Cylinder. 

6 For the Base of cylinder and Radius pick points anywhere on the new 
cplane. 

7 Drag and click to get the End of cylinder. 

 

To save the new Cplane: 

1 From the View menu click Set Cplane, and then click Named Cplanes. 

2 A Panel will open with Named Cplanes controls. 

3 Click the Save as button in the toolbar area. 

4 Enter a name or use the default name Cplane 01, click OK. 

You have a named Cplane that can be restored at any time.  

 

5 Repeat setting and saving named 
Cplanes for surfaces labeled 2 and 3. 

 
 

To set a Cplane to an object: 

1 From the View menu click Set Cplane, and then click To Object. 

2 Select the surface labeled as 4. 

The Cplane is set to the surface. The origin of the new Cplane is the 

center of the underlying untrimmed surface. 

3 Using Named Cplane, name this cplane Cplane 04. 
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To change the origin of a Cplane: 

1 From the View menu click Set Cplane, and then click Origin. 

2 For the Cplane origin, snap to the upper left corner of the surface 
labeled 4. 

 

3 Set a Cplane by Object for the surface labeled 5. 

4 Set a new Cplane Origin for the surface labeled 5. 

5 Using Named Cplane, name this cplane, Cplane 05. 

 

Exercise 23—Viewports and construction planes 

���� Open the model Chair.3dm. 

Next, we will turn on layers that illustrate how the default construction planes relate to each other. Each layer 

contains an image for a chair. Later in this exercise we will create our own chair.  

���� Turn the following layers on: 

• CP-Top 

• CP-Front 

• CP-Right 

Each of the layers contains an image of a 

view of a tubular chair. 

Notice that all the Chair images intersect at 

the origin of the model (0,0,0). 

When you draw on any viewport the 

geometry will be located on the 

construction plane, unless you use Osnaps, 

Planar mode, or Elevator mode. 
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Exercise 24—Modeling in 3-D space 

Chair: Technical Method (Recommended) 

Rhino makes it easy to draw in 3-D space. You can draw 

on a different construction plane by simply moving your 

cursor into a different viewport.  

Using the technical drawing on the right and the precision 

drawing and coordinate input to create the chair curves. 

When you have completed the curves, go to section 

“Finishing the chair.” 

 

 

Chair: Elevator Mode Method (Alternate) 

Another method for modeling in 3-D space is modeling using elevator mode.  

In the following exercise we will draw in different viewports and use elevator mode to move some points in 3-D 

space. 

Elevator mode lets you pick points that are off the construction plane. Elevator mode requires two point picks to 

completely define the point. The first specifies the base point. The second specifies how far the final point is above 

or below the base point. 

After the base point is specified, the marker is constrained to a tracking line perpendicular to the construction 

plane that passes through the base point. 

Pick a second point to specify the coordinate of the desired point. You can pick a point with the mouse, or type a 

single number to specify the height above the construction plane. Positive numbers are above the construction 

plane; negative numbers are below. 

You will use Snap, Ortho and Elevator mode to draw in different viewports. 

 



4  P R E C I S I O N  M O D E L I N G  

68 Robert McNeel & Associates  

1 Toggle Planar on and Grid Snap on. 
Toggle Ortho on as needed. 

2 Turn on the Point osnap. 

3 From the Curve menu click Polyline, 
and then click Polyline. 

4 Move your cursor into the Front 
viewport. 

5 To start click at the lower left side of 
the tubular chair image. 

6 Use coordinate input or the image to 

draw the first part of the chair frame. 

7 After you complete the profile lines, 
move your cursor to the Right 
viewport to draw a horizontal line. 

 

Front View 

 

Right View 

8 Move your cursor to the Front 
viewport until it snaps to the point at 

the lower end of the diagonal line. 

Don’t click at this time. 

9 While the cursor is locked onto the 
point, hold down the Ctrl key, and 

pick (Left mouse click). 

(Holding the Ctrl key while clicking 

with the left mouse button activates 

elevator mode.) 

10 Release the Ctrl key. Move your 
cursor to the Perspective viewport 

and drag the point until it snaps to 

the previous point, and pick (Left 

mouse click). 

 

 

Front View 

 

Perspective View 
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11 Move your cursor to the 
Perspective view. Continue drawing 

the rest of the chair frame using the 

same technique.  

Snap to the next point in the Front 

viewport, activate elevator mode, 

then move your mouse to the 

Perspective viewport to position the 

point. 

 

Perspective View 

 

Perspective View 

12 For the last segment you can click 
Close on the command line or snap 
to the start point and click. 

 

Perspective View 

 

Perspective View 
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Finishing the chair 

After creating the chair curve either with the technical modeling method or by using the elevator mode, you now 

need to construct the chair surfaces. It will help to first create a custom cplane aligned to the back of the chair.  

To make a custom construction plane: 

We now want to draw along the chair back, so we will change the construction plane. 

1 On the Status Bar, click Osnap, and 
check End. 

2 Change to the Perspective viewport 
and turn on the Grid, if necessary, 

by pressing F7. 

3 From the View menu click Set 

CPlane, and then click 3 Points.  

4 For the CPlane origin, pick vertex 

(1). 

5 For X axis direction, pick vertex (2). 

6 For the CPlane orientation, pick 
vertex (3). 

The construction plane is aligned 

with the back of the chair. 

  

To create a named construction plane 

1 From the View menu click Set CPlane, and click Named CPlanes.  

2 In the Named CPlanes panel, click Save. 

3 In the Save CPlanes dialog, type ChairBack, then click OK. 

You have a custom cplane that can be restored as needed. This custom cplane is saved to the file. 
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To create a named view: 

1 From the View menu click Set View, 

click Plan.  

The view changes. You are looking 

straight down on the new 

construction plane.  

2 From the View menu click Set View, 

click Named Views.  

3 In the Named Views panel, click 
SaveAs. 

4 In the Save Viewport As Named 
View dialog, type ChairBack, then 
click OK. 

This creates a custom view that can 

be restored as needed. 

5 Change back to the Perspective view. 

6 From the View menu click Set View, 
then click Perspective. 

7 Draw some lines on the new 
construction plane. 

  

To make it solid: 

1 Change to the Frame layer. 

2 Select the chair frame. 

3 From the Solid menu, click Pipe.  

4 For the Start and End Radius, type 3 and press Enter. 

The chair has a solid frame. 

5 Save the model. 
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To Fillet the corners: 

1 Undo the Pipe. 

2 Select the chair frame. 

3 From the Curve menu click Fillet 
corners. 

4 Click Radius and type 10 and press 
Enter. 

The fillet will be applied to all the 

chair corners. 

  

To make the seat surface: 

1 Select the curve you just filleted. From 
the Edit menu click Explode. 

2 From the Surface menu click Edge 

Curves. 

3 Select the two side edges of the back 
of the chair, then press Enter.  

A back surface is created. 

  

4 Repeat this procedure for additional 
seat surfaces. 

  

 

  

5 Select all the seat surfaces. From the 
Edit menu click Join. 

The seat will be joined into one 

polysurface.  Next trim out the 

opening in the back. 
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6 Select the rectangular curve you 
created earlier.  

7 From the Edit menu click Trim. 

8 Click on the part the surface inside the 
rectangle to trim the chair back. 

  

9 Highlight the seat surfaces. Using the 
Layer pane in the Status bar, select 

the Seat layer. 

  

10 Turn off the Seat layer. 

 

11 Select the curves for the frame. 

12 From the Edit menu click Join.  

13 Use the Pipe command to make the 

new curves into a tubular frame. 

14 Turn Seat layer back on. 

  

15 Render your model. 

 

  

Completed rendering of chair. 
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On your own: 

���� Try some variations and add some features. 

Analysis commands 

Rhino provides analysis tools for finding lengths, angles, areas, distances, and the volume and centroid of solids. 

Additional commands let you analyze curve curvature, determine continuity between curves, and find unjoined 

edges. 

Command Description 

Distance Displays the distance between two points. 

Length Displays the length of a curve object or surface edge. 

Angle Displays the angle between two lines. 

Radius Measures the radius of curvature of a curve, circle, or arc at the point where you pick the 
curve and displays it on the command line. 

EvaluatePt The Cartesian coordinates of the point, in both world and construction plane coordinates are 
displayed on the command line in x,y,z format. 

Distance 

Measures the distance between two picked points. 

To find the distance between two points: 

1 Open the model Analyze.3dm that you saved from an earlier exercise. 

If you didn’t get a chance to save the model, open the model Analyze-

01.3dm instead. 

2 From the Analyze menu click Distance.  

3 Pick the intersection where a diagonal line intersects a vertical line. 

4 Pick the intersection where the other diagonal line intersects the same 
vertical line.  

Use object snaps. 

5 Press F2 to display the information. 

Cplane angles and deltas:  xy = 90 elevation = 0   

dx = 0 dy = 3.077 dz = 0 

World angles and deltas: xy = 90 elevation = 0   

dx = 0 dy = 3.077 dz = 0 

Distance = 3.077 millimeters 
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Length 

Displays the length of a selected line. 

To find the length of a line: 

1 From the Analyze menu click Length.  

2 Select the line between the centers of the circles. 

Length = 8.000 millimeters 

 

To measure the angle between two lines: 

1 From the Analyze menu click Angle.  

 

2 Select a point that defines the vertex 
of an angle line. 

3 Select a point that defines the end of 
an angle line. 

Use object snaps as appropriate. 

4 Select a point that defines the vertex 
of the second angle line. 

  

5 Select a point that defines the end of the second angle line. 

The angle displays on the command line in the following format: Angle = 21.7711 

Radius 

Displays the radius of a circle, arc, or curve segment. 

To measure the radius of a circle: 

1 From the Analyze menu click Radius.  

2 Select one of the circles. 

This also measures the radius of curvature of a curve at a point. 

The radius displays on the command line in the following format:  

Radius = 2.5 
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Point evaluation 

Displays the coordinates of a picked location. 

To display the coordinates of a point: 

1 From the Analyze menu click Point.  

2 Snap to the end point of the tangent line. 

 The x,y,z point is displayed for the world coordinate plane and the current 

construction plane. 

 Point in world coordinates = 8.203,11.488,0.000 

 CPlane coordinates = 8.203,11.488,0.000  

 

Drawing with precision 

Circles 

You can create circles using a center point and radius, center point and a diameter, two points on the diameter, 

three points on the circumference, and tangent points to two coplanar curves and a radius.  

Button Command Description 

 

Circle Draw a circle using the center and radius. 

 

Circle 3Point Draw a circle through three points on its circumference 

 

Circle Diameter Draw a circle using two diameter points. 

 

Circle Tangent, 
Tangent, Radius 

Draw a circle tangent to two curves with a given radius. 

 

Circle Tangent to 3 
Curves 

Draw a circle tangent to three curves. 

 

Circle AroundCurve Draw a circle perpendicular to a curve at the chosen point. 

 

Deformable Draws an approximation of a circle with a defined number of control points.. 

 

Vertical Draw a circle perpendicular to the construction plane. 
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Exercise 25—Drawing circles 

���� Open the model Circles.3dm. 

2P

TTR

Ø4.00

R2.00

1
5

.0
0

7
.5

0

20.00

10.00

R4.00

 

To draw a center, radius circle: 

1 From the Curve menu click Circle, and then click Center, Radius. 

2 For the Center of circle snap to the intersection of the centerlines. 

3 For the Radius type 4 and press Enter. 

A circle is created around the centerline intersection. 

 

To divide a curve by the number of segments: 

For the next part of this exercise, we need to find some specific points to locate two of the circles. We will use the 

Divide command to create the points. 

1 From the Curve menu click Point Object, then click Divide Curve by, 
and then click Number of segments. 

2 Select the bottom line as the curve to divide, press Enter. 

3 For the Number of segments type 4 and press Enter. 

The line is marked off into four segments with a point at the end of each 

segment. 
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To draw a diameter circle: 

1 Turn On the Point osnap. 

2 From the Curve menu click Circle, 

and then click 2 Points.  

3 For the Start of diameter pick snap 
to the second point from the left end 

of the line you divided. 

4 For the End of diameter type 4 and 
press Enter, then turn Ortho on and 

pick in the straight up direction. 
  

A circle is created with the two points you picked as the diameter, and the diameter was constrained to a 

value of 4. 

5 Repeat these steps for the second diameter circle. 

To draw a tangent, tangent, radius circle:  

1 From the Curve menu click Circle, 
and then click Tangent, Tangent, 
Radius. 

2 For the First tangent curve, select 
the top line. 

3 For the Second tangent curve, 

select the left line. 

4 For the Radius, type 2 and press 
Enter. 

A circle is created that is tangent to 

the two lines you selected with a 

radius of 2. 

  

5 Repeat these steps for the second TTR circle. 
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To make it 3-D: 

1 Select the lines that form the rectangle. 

2 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

3 For the Extrusion Distance, type 2 and press Enter.  

The rectangle generates a box. 

 

4 Select the four smaller circles. 

5 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

6 For the Extrusion Distance type, -6 and press Enter. 

The circles generate cylinders. 

 

7 Select the large circle in the center. 

8 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

9 For the Extrusion Distance ,type 4 and press Enter. 

The circle generates a cylinder. 
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Exercise 26—Using circle-related object snaps 

1 Open the model Link.3dm. 

2 Complete the model as shown. 

 

 

3 Draw the three large circles first. 

Snap to the centerline intersections to place 

the circles. 

4 Draw the small holes next. 

Use object snaps to snap to the centers of the 

large circles 

  

To draw the tangent lines: 

1 From the Curve menu click Line, and then 

click Tangent to 2 Curves.   

2 For the First tangent point pick on the edge 
of one of the circles near where you want the 

tangent line to attach. 

3 For the Second tangent point pick on the 
edge of another circle. Rhino will find the 

tangent points for you. 

4 Continue to use this command to complete 

the model. 
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Arcs 

You can create arcs using various points on the arc and construction geometry. 

You can continue an existing curve with an arc to an existing curve, to a point or by an angle. 

Button Command Description 

  

Arc Draw an arc from the center, start, and angle. 

 

  

Arc : Start, End, Point on Arc Draw an arc from three points. 

  

Arc: Start, End, Direction Draw an arc from start point, end point, and the direction from the 

start point. The direction can be entered after the start point is 
entered or after the end point is entered. 

  

Arc: Tangent, Tangent, Radius Creates an arc from tangents and radius. 

 

Arc: Start End Radius Creates an arc from start point, end point, and radius. 

 

Convert Output=arcs Converts a curve to arc segments that are joined together. 

Arc options 

Option Description 

Deformable Creates an arc shaped NURBS curve 

Extension Extend a curve with an arc. 

Exercise 27—Practice drawing arcs (1) 

� Open the model 

Arc1.3dm. 

 

R3.00

R6.00

Extend Curve: 
By Arc to a Point

Extend Curve:
By Arc

Arc: Start, End, Radius

Arc: Center, Start, End

Arc: Start, End, Direction

4
.0

0

7.002.00

R2.00

Ø2.00

R2.00

R2.00

Arc: TTR

 

To draw a center, start, end or angle arc: 

1 From the Curve menu click Arc, and then click Center, Start, Angle. 

 

2 For the Center of arc snap to the center of the circle at the lower left. 

3 For the Start of arc snap to the end of the line. 

4 For the End point or angle snap to the end of the other line. 
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To draw a start, end, direction arc:  

1 From the Curve menu click Arc, and then click Start, End, Direction. 

2 For the Start of arc snap to the upper end of the vertical line. 

3 For an End of arc snap to the adjacent end of the horizontal line at the 
top. 

4 For the Direction at start, toggle Ortho on and drag in the straight up 
direction and pick. 

 

5 Make another Direction Arc at the upper right. 

6 For the Start of arc, snap to the right end of the horizontal line. 

7 For an End of arc type R2,-2 and press Enter. 

8 For the Direction at start, toggle Ortho on and drag in the straight down 
direction and pick.. 

 

To add more arc segments using extension option: 

1 From the Curve menu click Arc, and then click Center, Start, Angle. 

 

2 Click Extension on the command line. 

3 For the Select near curve end pick near the end of the arc you just made. 

4 For the End of arc, type 4 and press Enter. 

5 With Ortho on pick a point below the first point. 

The arc will be tangent to the curve you chose. 
 

To add more arc segments using the extension option: 

1 From the Curve menu click Arc, and then click Center, Start, Angle. 

2 Click Extension on the command line.  

3 For the Select near curve end pick near the end of the arc you just made. 

4 For the End of arc, snap to the end of the horizontal line. 
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To draw a tangent, tangent, radius arc: 

1 From the Curve menu click Arc, and then click Tangent, Tangent, 

Radius.  

2 For the First tangent curve pick the lower right side of the top circle. 

3 For the Radius type 3 and press Enter. 

4 For the Second tangent curve pick the upper right side of the lower 
circle. 

5 Move your cursor and pick when the correct arc is displayed. 
 

6 From the Curve menu click Arc, and then click Tangent, Tangent, 
Radius. 

7 For the First tangent curve pick the upper left side of the top circle. 

8 For the Radius type 6 and press Enter. 

9 For the Second tangent curve pick the lower left side of the lower 
circle. 

10 Move your cursor and pick when the correct arc is displayed. 

 

To make it solid: 

First you will have to trim the two small circles, then you can extrude the remaining curves. 

1 Select the two arcs you just 

completed. 

2 From the Edit menu click Trim. 

3 For the objects to trim pick on the 
inner edge of each small circle.  

You will be left with a slot. 

4 Use the Circle command to draw the 
circle concentric to the arc on the 

right.   

5 Select all the curves. 

6 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

7 For the Extrusion distance type 1 and press Enter.  

The curves have been extruded and capped. 
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Exercise 28—Practice drawing arcs (2) 

It might be helpful to start this model by drawing centerlines first and then lock them or put them on a locked 

layer. Use the Line command to construct the centerlines. When you have the centerlines drawn, you can use 

their intersection points to draw your arcs and circles. 

1 Start a new model, use the Small 
Objects - Inches.3dm template. 
Save as Arc2. 
 

2 Create this model using object snaps 

and the Line, Circle, and Arc 
commands. 

 

 

To make it solid: 

1 Select the curves. 

2 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

3 For the Extrusion distance type 1 and press Enter.  

The curves have been extruded and capped. 

 

 

Ellipses and polygons 

You can draw ellipses from the center or by the ends. You can draw polygons from a center point or an edge. You 

can draw a rectangle from diagonal corners or by choosing three points. 

Ellipses 

Button Command Description 

Th
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Ellipse Draw an ellipse by specifying the center point and axis ends. 

Th
e 
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d 
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e 
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ot 

 

Ellipse Diameter Draw an ellipse by specifying the axis ends. 

Th
e 
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Ellipse FromFoci Draw the ellipse from the focus points. 

Th
e 
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Ellipse AroundCurve Draw an ellipse whose axes are perpendicular to a curve. 
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Polygons 

Button Command Description 

Th
e 
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Polygon Creates a polygon from its center and radius. 

Th
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ca
nn
ot 

 

Polygon Edge Draw a polygon by specifying the ends of one edge. 
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Polygon Star Draw a polygonal star. 

Polygon options 

Option Description 

NumSides Specify the number of sides for the polygon. 

Circumscribed Draw a polygon that is circumscribed about a radius. The default is to draw a polygon that is inscribed in a 
specified radius. 

Rectangles 

Button Command Description 

  

Rectangle Draw a rectangle using opposite corners. 

  

Rectangle Center Draw a rectangle from center and a corner. 

 

Rectangle 3Point Draw a rectangle through three points. 

Th
e 
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Rectangle Vertical Draw a rectangle that is perpendicular to the construction plane. 
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e 
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Rectangle Rounded Create a rectangle with rounded corners (arc or conic). 

Exercise 29—Practice drawing ellipses and polygons 

� Start a new model, use the Small Objects - Millimeters.3dm template. Save as Toy. 

89 104

14

8

5

19

18

20

R1.5 for all
polygons
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To draw a rectangle from diagonal corners: 

1 From the Curve menu click Rectangle, and then click Corner to 

Corner.  

2 For the First Corner, type -10,-5 and press Enter. 

3 For the Length, type 20 and press Enter. 

4 For the Width, type 10 and press Enter. 

 

Draw rectangles from a center point with a length and width, and rounded corners:  

1 From the Curve menu click Rectangle, and then click Center, Corner. 

 

2 Type R, and press Enter to give the rectangle rounded corners. 

3 For the Center of rectangle, type 0 and press Enter. 

4 For the Length, type 19 and press Enter. 

5 For the Width, type 9 and press Enter. 

6 For the Radius, type 1, and press Enter. 

If you are creating a rounded rectangle, you can choose to select a 

point in the corner to set its curvature instead of typing a radius value. 

 

To change the type of corner, click Corner on the command line to toggle from circular rounded corners to 

conic rounded corners. 

7 Repeat these steps for a second rounded rectangle with a length of 18 and a width of 8 with .5 radius corners. 

To draw an ellipse from its center and axis ends:  

1 From the Curve menu click Ellipse, and then click From Center.  

2 For the Ellipse center, type 0 and press Enter. 

3 For the End of first axis, type 4, and press Enter. 

4 Toggle Ortho on and pick to the right. 

5 For the End of second axis, type 2.5, and press Enter. 

6 Pick a point. 
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To draw a polygon from its center and radius: 

1 From the Curve menu click Polygon, and then click Center, Radius. 

 

2 Click NumSides on the command line, type 3 and press Enter to change 
the number of sides for the polygon. 

3 For the Center, type -7,-2 and press Enter to locate the center point for 
the polygon. 

4 For the Corner, type 1.5, and press Enter. 

5 Pick a point to orient the polygon. 

6 Continue drawing the rest of the polygons. Use the same radius for each 
one. 

 

To make the rounded rectangles solid:  

1 Select the larger and the smaller 

rounded rectangle. 

2 From the Solid menu click Extrude 
Planar Curve, and then click 

Straight.  

3 Drag both down to set the thickness 
and click or type a value for the 

thickness. Use a negative number to 

extrude down. 

The two rounded rectangles are 

coplanar or in the same plane. 

Because of this the smaller rounded 

rectangle is removed from the 

larger one, and the difference is 

extruded. 

 

 

 

 

To make the rectangle solid: 

1 Select the rectangle. 

2 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

3 Set the Bothsides option to No. 

4 Drag it up to set the thickness and click. 
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To make the ellipse solid: 

1 Select the ellipse. 

2 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

3 Set the Bothsides option to Yes. 

4 Pick to set the thickness. 

Make sure the thickness is enough to protrude through both sides of the 

rectangular solid. 

 

To cut the ellipse solid from the rectangle: 

1 Select the solid rectangle. 

2 From the Solid menu click Difference. 

3 Select the solid ellipse, and press Enter. 

 

 

To extrude the polygons: 

1 Select the polygons. 

2 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

3 Pick to set the thickness.  

Make sure the thickness is enough to protrude through both sides of the 

rectangular solid. 

 

To cut holes with the solid polygons: 

1 Select the rectangular solid. 

2 From the Solid menu click Difference. 

3 On the command line click DeleteInput. 

Make sure it is set to: DeleteInput=No. 

4 For the second set of surfaces or polysurfaces, select the solid polygons 

and press Enter. 

Holes will be cut, but the objects will remain. 
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Free-form curves 

The use of free-form curves allows more flexibility to create complex shapes.  

Button Command Description 

  

Curve Curve by control points draws a curve from specified control points. Control 
points mostly do not lie on the curve, but they determine its shape. 

  

InterpCrv Interpolated curve creates a curve going through specified interpolate points. 
These points lie on the curve and determine its shape. 

 

Conic Draws a conic curve, which is part of an ellipse, parabola, or hyperbola. 

 

Option Description 

Undo Allows you to back up one point. 

Close Makes a closed curve. 

Autoclose Move the cursor close to the start point of the curve, and pick. 

The curve will close automatically. Press Alt to suspend autoclose. 

Sharp If Yes, when you make a closed curve, it will have a kink at the start/end point instead of 
making a smooth (periodic) closure. 

Degree Allows you to set the degree of the curve. 

PersistentClose Closes the curve as soon as there are two points placed. You can continue to pick points. 
The curve updates the shape while remaining closed. 

Exercise 30—Practice drawing curves (1) 

1 Open the model Curve.3dm. 

In this exercise, you will learn how to make a curve by control points, an interpolated curve, and a conic curve 

to compare the differences between the three methods. 

A common method for creating free-form curves is to draw lines that are accurately measured. Use these lines 

as guidelines. Another method for creating free-form curves is to use a background image made from a sketch 

or a photograph. In this exercise the guidelines have been created for one of the exercises and an image has 

been included for the other exercise. 

2 In the Osnap toolbar, check End and Near, clear all others. 

If you click End with your right mouse, it will clear all the others. 

3 Toggle Ortho and Grid Snap off. 

To draw a curve by control points: 

Control points define the curvature of the curve, but the points are usually not on the curve. 

1 From the Curve menu click Free-form, and then click Control Points.  

 

2 For the Start of Curve, snap to the end point of the polyline guideline. 

3 For the Next point, snap on the polyline guideline using the Near object 
snap. 

4 Continue to snap to the guideline until you get to the end. 

5 Press Enter. 

A free-form curve is drawn. The control points, while on the guideline, 

were not on the curve itself except at the two ends.  
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To draw a curve interpolate through points:  

1 Change to the Interpolated Curve layer. 

2 From the Curve menu click Free-form, and then click Interpolate 

Points.   

3 For the Start of Curve, snap to the intersection of the centerline and the 
image using the Near object snap. 

4 For the Next point, continue to pick points along the edge of the image 
until you get to the other end, then use the Near object snap to snap to 

the intersection of the centerline and the image. 

5 Press Enter. 

A free-form curve is created from specified interpolate points. These 

points lie on the curve and determine its curvature. 

 

To draw a conic curve: 

1 Change to the Conic layer. 

2 From the Curve menu click Conic.   

3 For the Start of conic, snap to the point (1) at the lower left. 

4 For the End of conic, snap to the point (2) above and to the right from 
the previous point.  

5 For the Apex, snap to the point (3) in between the previous points. 

6 For the Curvature point or rho, pick a point for the desired curvature.  

To make the curve into a surface:  

1 Select the control point curve. 

2 From the Surface menu click 

Revolve.   

3 For the Start of revolve axis, snap 
either end of the curve. 

4 For the End of revolve axis, snap to 

the other end of the curve.  

5 For the Start angle, click FullCircle.   

6 Repeat steps 2-5 for the interpolated 
curve. 

  



4  P R E C I S I O N  M O D E L I N G  

Robert McNeel & Associates  91  

Helix and Spiral 

Button Command Description 

 

Helix Draw a helix. User can specify a radius, the number of turns, the length and 
direction of the axis. 

 

Spiral Draw a spiral. User can specify two radii, the number of turns, the length and 
direction of the axis. 

 

Option Description 

Vertical The helix or spiral axis will be perpendicular to the construction plane in the active viewport. 

AroundCurve Select a curve for the helix or spiral to wind around to create "phone cord" shapes. This option 
supports History. 

Flat Allows you to draw a planar spiral. 

Mode Determines whether the number of turns or the distance between turns is used to create the 
helix or spiral 

Turns Allows you to set the number of turns along the axis. 

Pitch Allows you to set the distance between turns along the axis. 

ReverseTwist Allows you to reverse the twist direction of the helix or spiral. 

Exercise 31—Practice drawing curves (2) 

1 Open the model Helix-Spiral.3dm. 

2 In the Osnap toolbar, check End and Point, clear all others. 

If you click End with your right mouse, it will clear all the others. 

3 Toggle Ortho and Grid Snap off. 

To draw a helix 

1 Change to the Helix layer. 

2 From the Curve menu click Helix.   

3 For the Start of axis, snap to the end of the vertical line (1) in the Perspective 
viewport.  

4 For the End of axis, snap to the end of the vertical line (2) in the Perspective 
viewport. 

5 Click Mode on the command line until it is set to Mode=Turns. 

6 Click Turns on the command line. 

7 For the Number of turns, type 10 and press Enter. 

 

8 Pick the point (3) to the right of the axis line. 

A helix with 10 turns and a radius of 20 is created. 
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To draw a spiral: 

1 Change to the Spiral layer.  

2 From the Curve menu click Spiral.  

3 For the Start of axis, snap to the end of the other vertical line (1) in the 
Perspective viewport. 

4 For the End of axis, snap to the other end of the same line (2). 

5 Click Mode on the command line until it is set to Mode=Pitch. 

6 Click Pitch on the command line. 

7 For the Pitch, type 15 and press Enter. 

8 Click ReverseTwist on the command line until it is set to Reverse 

Twist=Yes. 

 

9 Snap the point (3) for the Radius of the base of the spiral. 

10 Snap to the other point (4) for the Ending radius. 

A spiral is created with a reverse twist and the distance between each turn is 15. 

To draw a helix around a curve: 

1 Change to the HelixAlongCurve layer.  

2 From the Curve menu click Helix.  

3 Click AroundCurve. 

4 Select the free-form curve. 

5 Click Mode=Turns. 

6 Click Turns 

7 Type 25 and press Enter. 

8 Click ReverseTwist=No. 

9 For the Radius type 5 and press Enter. 

 

10 Pick a point for the Start point. 

A helix is created around the curve. Undo this helix. 

To draw a helix around a curve with History: 

1 In the Status bar, click RecordHistory pane.  

2 From the Curve menu click Helix.  

3 Click AroundCurve. 

4 Select the free-form curve. 

5 Click Mode=Turns. 

6 Click Turns 

7 Type 25 and press Enter. 

8 Click ReverseTwist=No. 
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9 For the Radius type 5 and press Enter. 

10 Pick a point for the Start point. 

A helix is created around the curve. 

11 Highlight the free-form curve. Type PointsOn (F10). 

12 Pick a few control points and pull the curve into a new shape. 

 
 

 

 

13 Helix will update automatically to the new shape for the free-from curve. 

 

 

Exercise 32—Drawing free-form curves 

The use of free-form curves allows more flexibility to create complex shapes. In the following exercise we will 

draw the guidelines and free-form curves for a toy screwdriver.  

1 Start a new model, use the Small Objects - Millimeters.3dm 
template. Save as Screwdriver. 

2 Create Construction and Curve layers.  

Make them different colors. 

 

 

To create the construction lines: 

1 Change to the Construction layer. 

2 Draw a Polyline, in the Top viewport, using these dimensions for the guideline. 

18
10

6

11

42 25

3

2050

8

 
A good starting point for the Polyline would be -70,0. 
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To create the curve by control points: 

1 Change to the Curve layer. 

2 Use the Curve command to draw the shape for the toy screwdriver.  

3 Save your model. 

THREE OR MORE POINTS IN A 
ROW (ORTHO) WILL ALLOW 
YOU TO MAKE A PORTION OF 
THE CONTROL POINT CURVE 
STRAIGHT

CURVE FROM 
CONTROL POINTS

TWO POINTS IN 
A ROW (ORTHO) 
WILL GIVE YOU 
A TANGENT AT 
THE ENDPOINT

 

To make it solid: 

1 Toggle Grid Snap and Ortho on. 

2 Select the curve. 

3 From the Surface menu and click 

Revolve.  

4 For the Start of revolve axis, snap 

to the end of the curve. 

5 For the End of revolve axis, snap to 
the other end of the curve. 

6 For the Start angle, click FullCircle. 

  

Your model is now a three-

dimensional surface. 

 

Add details on your own: 

Since we haven’t discussed many of the commands that you need to complete this model, use Command Help for 

assistance. Following is a list of procedures for one method to finish the model. 

1 In the Top view draw a Single Line 
that will be used to slice the flat part 

from the screwdriver blade. 

2 Select the line. 

3 From the Solid menu, click Solid 
Editing Tools, and then click 
Wirecut. 
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4 For the Select objects to cut, 
choose the screwdriver, and then 

press Enter. 

5 For the First cut depth point. Press 
Enter to cut through object, press 
Enter. 

6 For the Part to cut away, choose 
the part you want to remove, and 

then press Enter. 
  

7 Mirror the line and repeat steps 3-6 
to complete the other side of the 

blade. 

  

8 Draw a Curve along the top of the 
handle to be used for cutting grooves.  

If you do this in the Front viewport, 

you will eliminate any problems that 

might arise from having one of the 

slots along the seam of the surface. 

9 Use the Pipe command to make a 
surface on the curve. 

  

10 Use the ArrayPolar command to 
make copies of the pipe around the 

handle.  

  

11 Use the BooleanDifference 
command to remove the pipes from 

the handle. 

12 Try using the Render command to 
make a rendering of the finished 

screwdriver. 
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5 Editing Geometry 
Once you create objects, you can move and edit them to produce complex and detailed variations.  

Fillet  

Fillet connects two lines, arcs, circles, or curves extending or trimming them to touch or to join with a circular arc.  

Rules to follow when filleting curves: 

• The curves must be coplanar. 

• The created fillet is determined by picking on the curve portion to keep. 

• The radius cannot be so large that it runs past the end of the curve. 

Option Description 

Radius Sets the fillet radius. A radius of 0 extends or trims the curves to a corner, but does not create a fillet. 

Join Yes, joins the fillet to the curves.  
No, does not join the fillet to the curves. 

Trim Yes, trims the curves to the fillet arc.  
No, does not trim the curves. 

Exercise 33—Fillet 

� Open the model Fillet.3dm. 

 

To connect lines that intersect: 

1 From the Curve menu click Connect Curves. 

  

2 Select an outer vertical line. 

3 Select an adjacent horizontal line. 

The ends of the lines are trimmed to a 

corner. 
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4 Press Enter to repeat the command. 

5 Connect the other corners, as shown. 

Remember to pick on the part of the line that 

you want to keep. 

  

To join the connected objects: 

1 Select lines you just connected. 

2 From the Edit menu click Join.   

The objects are joined together. Curves join only if they touch. 

To fillet lines using an arc: 

1 From the Curve menu click Fillet Curves. 

2 Type 2 and press Enter to change the radius. 

This is another method to change the radius. 

3 Click Join to change the Join option to Yes. 

This option joins the curves as they are filleted. 

4 Select an outer vertical line. 

5 Select an adjacent horizontal line. 

The ends of the lines are trimmed to a radius. 

6 Press Enter to repeat the command. 

7 Fillet the other corners as shown. 

 

8 Press Enter to repeat the command. 

9 Type 1 and press Enter. 

This radius will be used for the smaller object. 

10 Select an inner vertical line. 

11 Select an adjacent horizontal line. 

12 Fillet the other corners as shown. 
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To fillet circles: 

1 From the Curve menu click Fillet Curves. 

2 Type 3 and press Enter. 

3 Select the right edge of a circle. 

4 Select the right edge of the other circle. 

  

 

 

5 Repeat the command for the left side of the circles. 

6 Select the two fillets you just created. 

7 From the Edit menu click Trim. 

8 For the objects to trim pick on the inner edge of each circle.  

 

 

To fillet and join arcs and lines: 

1 From the Curve menu click Fillet Curves.  
Set Join=Yes and Trim=Yes. 

2 Select the line in the lower left part of the 
viewport. 

Make sure you pick on the left half of the 

line. 

3 Select the adjacent arc right above the 

selected line. 

4 Repeat this procedure for the two arcs below 
the line and the arc you just filleted.   
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To fillet the corners of a closed polyline: 

1 Select the closed polyline. 

2 From the Curve menu click Fillet Corners. 

 

3 For the Fillet radius, type 2 and press 
Enter. 

All corners are filleted at once. 

  

Blend  

Blending is another method to connect lines, arcs, or curves. There are three blend commands that work on 

curves, BlendCrv (default), Blend (Quick Blend) and ArcBlend.  

BlendCrv allows you to adjust the continuity with the input curves and has adjustable endpoints. 

Selection 
Option 

Description 

Curves Restricts the selection to curves. 

Edges Restricts selection to surface edges. 

Option Description 

Continuity  Continuity describes the relationship between curves and surfaces. Types of continuity: Position (G0), 
Tangent (G1), and Curvature (G2), G3, and G4 

Flip 1 & Flip 2 Reverses direction of specified curve. 

Trim Trims the input curves to the resulting curve. 

Join Joins the resulting curves. 

CurvatureGraph Displays the curvature graph for the blended curve. 
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ArcBlend consists of two arcs with adjustable endpoints and bulge. 

Option Description 

AlternateSolution Offers the longer solution when more than one arc fills the requirements. 

RadiusDifference Makes it possible to draw an S-shaped blend where the difference of the two radii is specified. 

If the difference is positive the first radius will be bigger than second, and if negative the first radius will be 
smaller.  

Trim Trims the input curves to the resulting curve. 

Join Joins the resulting curves. 

Blend (Quick Blend) creates a between two curves maintaining continuity with the input curves. It is similar to 

the adjustable blend curve without any adjustments.  

Option Description 

Perpendicular When Continuity=Tangent or Curvature, allows you to blend a curve to a surface edge perpendicular to the 
surface with continuity. 

AtAngle When Continuity=Tangent or Curvature, orients the direction of the blend curve other than perpendicular to 
the edge. 

Continuity Continuity describes the relationship between curves and surfaces. Types of continuity: Position (G0), 
Tangent (G1), and Curvature (G2). 

To blend two curves with Quick Blend: 

1 From the Curve menu, Blend Curves, then 

click Quick Curve Blend.  

2 Select the curves to blend near the ends that 

you want to connect. 

The arcs are connected with a smooth curve. 

The default continuity is Curvature. 

3 Undo to remove the blend. 

  

To blend two curves with ArcBlend: 

1 From the Curve menu, Blend Curves, then 

click Arc Blend.  

2 Select the curves to blend near the ends that 
you want to connect. 

The two input curves are connected with two 

arcs. 

3 Undo to remove the blend. 
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To blend two curves with Adjustable curve blend: 

1 From the Curve menu, Blend Curves, then click Adjustable Curve Blend. 

 

 

2 Select the upper right curve near the left end, 
then select the lower left curve near the right 

end to blend the curves. 

You will see a preview of the default blend 

with control points displayed and a dialog. 

3 Check the Join and the Trim option. 

 

 

4 For the Select control point to adjust, select the point (1) and drag it 

further up the curve and click. 

 

5 For the Select control point to adjust, select 
the point to the right of (2), drag it closer to (2) 

and click. 

6 After making your adjustments, pick the OK 
button to make the blend. 
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To make a lofted surface with closed curves: 

The curves in this model are at two different elevations. You are going to connect the curves at different 

elevations with a surface. 

1 Change to the Surfaces layer. 

2 Select the two squares in the upper left part of the Top viewport. 

3 Change to the Perspective viewport. 

4 From the Surface menu click Loft.  

The two squares show a seam direction arrow. 

They should point the same direction. 

If the seams don’t line up at corresponding 

points on the two curves, drag the seam point 

until it does. 

  

5 Press Enter. 

6 In the Loft Options dialog box, click OK. 

A surface is generated between the two closed 

polylines. 

7 Repeat the procedure for the rounded squares. 

8 In the Loft Options dialog box, click OK. 

 

  

To make a lofted surface with open curves: 

1 Repeat the Loft command for the three open 
curves. 

2 In the Loft Options dialog box, change the 
Style to Loose, click Preview. 
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3 Change the Style to Straight sections, click Preview. 

 

 

4 Change the Style to Normal, click Preview. 

5 For the Cross-section curve options, change 
to Rebuild with, change the number of control 
points to 12, click Preview. 

6 Change to Refit within, click Preview. 

7 Change back to Do not simplify, click OK. 

  

Chamfer  

Chamfer connects two curves by extending or trimming them to intersect or to join with a beveled line. Chamfer 

works on convergent or intersecting curves.  

Option Description 

Distances The first chamfer distance specifies the distance from the chamfer end on the first curve to the point where 

the two curves would intersect. The second chamfer distance specifies the distance of the chamfer end on 
the second curve to the intersection point. 

A chamfer distance of 0 trims or extends that curve to the intersection point. If the chamfer distance is 
non-zero, a chamfer line is created that far from the intersection, and the curve is extended to the chamfer 
line. If you enter 0 for both distances, the curves are trimmed or extended to their intersection, but no 
chamfer line is created. 

Exercise 34—Chamfer 

���� Open the model Chamfer.3dm. 

To chamfer lines: 

1 From the Curve menu click Chamfer 

Curves . 

2 For the Select first curve to 
chamfer, type 1,1 and press Enter, 
to set the distances. 

3 Set Join=Yes. 

4 Select one of the inner vertical lines. 

5 Select an adjacent horizontal line. 

6 Continue creating chamfers on all of 

the corners. 
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7 Press Enter to repeat the command. 

8 For the Select first curve to 

chamfer, type 3,2 and press Enter. 

9 Select one of the outer horizontal 
lines. 

10 Select an adjacent vertical line. 

The first value is the distance from 

the intersection of the two curves 

on first curve selected, the second 

value is the distance from the 

intersection of the two curves on 

the second line selected. 

  

To turn the curves into surfaces: 

1 Change to the Surfaces layer. 

2 From the Edit menu click Select 
Objects, and then click Curves. 

3 From the Surface menu click Loft. 

4 Adjust the seam line if necessary, press 
Enter. 

5 In the Loft Options dialog box, 

click OK. 

A surface is generated between the two 

chamfered rectangles. 

6 Save your model.  
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Exercise 35—Practice with Fillet and Chamfer 

1 Open the model Filletex.3dm. 

 

2 Use Fillet and Chamfer to edit the 
drawing as shown. 

All fillets and rounds use a radius of 

0.5 units. 

 

To make it solid: 

1 From the Edit menu click Select Objects, and then click Curves. 

2 From the Solid menu click Extrude Planar Curve, and then click 

Straight. 

3 For the Extrusion distance, type 1 and press Enter. 
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To fillet the top edge of the solid: 

1 From the Solid menu click Fillet Edge, and then click Fillet Edge. 

2 Change the CurrentRadius to 0.25. 

3 Select the edges around the top of the solid, press Enter. 

 

Move 

Use Move to move objects without changing orientation or size.  

Option Description 

Vertical Moves the selected objects vertical to the current construction plane. 

Exercise 36—Move 

1 Open the model Move.3dm. 

2 Turn off both Ortho and Grid Snap so you can move objects freely. 

3 Turn Cen object snap on. 

 

 

To move using object snaps for placement: 

1 Select the small circle at the bottom 
left side of the Top viewport. 

2 From the Transform menu click 

Move.  

3 For the Point to move from, snap to 
the center of the small circle. 

4 For the Point to move to, snap to 

the center of the arc at the lower left 

of the object. 
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To move using absolute coordinates: 

1 From the Edit menu click Select 

Objects, and then click Curves. 

2 From the Transform menu click 
Move. 

3 For the Point to  move from, snap 
to the end of the line at the lower 

part of the object. 

4 For the Point to move to, type 0,0 

and press Enter.   

The end of the line is exactly at point 0,0 in the Top viewport. 

To move using relative coordinates: 

1 Select the large slotted circle in the middle of the object. 

You will move the slotted circle relative to the part. 

2 From the Transform menu click Move. 

3 Pick any point in the Top viewport. 

It is usually better if you pick near the object you are going to move. 

4 For the Point to move to, type r0,-.25 and press Enter. 

The circle moved down .25 units. 
 

Copy 

Copy duplicates selected objects and places them in a new location. The command can repeat to create more than 

one copy in the same command sequence. 

Option Description 

Vertical Copies the selected objects vertical to the current construction plane. 

InPlace Duplicates the object at the current location. 

Exercise 37—Copy 

To copy using object snaps for placement: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu click Copy.  

3 For the Point to copy from, snap to the center of the small circle. 

4 For the Point to copy to, snap to the center of the arc at the upper 
left of the object. 

5 Pick to place the object, and press Enter. 
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To make multiple copies: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu click Copy. 

3 For the Point to copy from, snap to the center of the small circle. 

4 For the Point to copy to, begin picking points on the screen. 

Each time you pick, a circle will be copied to that location. 

5 Press Enter to end the command. 

6 Undo the multiple copies. 

 

Undo and Redo 

If you make a mistake or do not like the results of a command, use Undo. If you decide you want those undone 

results back after all, use Redo command. Redo restores the last thing undone. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  

Left-click or Ctrl+Z Undo Cancels the effects of the last command. 

 

Right-click or Ctrl+Y Redo Restores the effects of undo.  

The number of undos kept in memory can be set in Rhino Options on the General page. 

If a command has an Undo option, type U to enter it, or click Undo on the command prompt. 

You cannot use the Undo command after you exit the modeling session or open a different model. 

Rotate 

Use Rotate to move objects in a circular motion around a base point. For precise rotation, enter a number of 

degrees to rotate. Positive numbers rotate counterclockwise; negative numbers rotate clockwise. 

Option Description 

Copy Duplicates the object as it is rotated 

Exercise 38—Rotate  

1 Select the large slotted circle in the middle of 
the object. 

2 From the Transform menu click Rotate.  

3 For the Center of rotation, snap to the center 
of the slotted circle. 

4 For the Angle, type -28 and press Enter. 
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Group 

Grouping objects allows all members of the group to be selected as one. You can then apply commands to the 

entire group. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  

Left-click or 
Ctrl+G 

Group Makes a group from selected objects. 

 

Left-click or 

Ctrl+Shift+
G 

Ungroup Removes grouping. 

 

Left-click AddToGroup To add objects to a group. 

 

Left-click RemoveFromGroup To remove objects from a group. 

 

Left-click SetGroupName To name groups 

Exercise 39—Grouping  

To group selected objects: 

1 Select the two circles that you placed. 

2 From the Edit menu click Groups, and then click Group.  

 

To add objects to a group: 

1 Select the polyline on the left, the original 
circle, and the slotted circle in the center. 

2 On the command line type AddToGroup 

or pick the AddToGroup icon  from 

the Grouping toolbar, press Enter. 

3 For the Select Group, select one of the 
circles in the previous group. 

The objects are part of the group.   
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To remove an object from a group: 

1 On the command line type RemoveFromGroup or pick the 

RemoveFromGroup icon   from the Grouping toolbar. 

2 For the Select objects to remove from group, select the slotted circle, 
press Enter. 

The slotted circle is removed from the group. 

 

Mirror 

Mirror creates a copy of the objects flipped over a specified axis on the construction plane. 

Exercise 40—Mirror 

1 Select the group. 

2 From the Transform menu click Mirror. 

 

3 For the Start of Mirror plane type 0,0 

or snap to the end of the line at the lower 

right of the part. 

4 Toggle Ortho on and pick directly above 
the previous point. 

Since you mirrored a group, in addition 

to having a mirror image copy, you also 

have two groups. 

  

Join 

Join unites curves that meet at a common end, making a single curve. Join can unite curves that do not touch, if 

you select them after the command has started. As you select non-touching curves, a dialog box asks if you want 

to fill the gap. 

Exercise 41—Join 

1 Select the two polylines. 

2 From the Edit menu click Join.   
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Scale 

Scale changes the size of existing objects without changing their shape. This command scales three-dimensional 

objects equally along all three axes. There are also 2-dimensional, one-dimensional, and non-uniform scale 

commands. 

Option Description 

Copy Preserves the object as it creates a new scaled one. 

Scale factor Inputs a value for scale factor. Less than one reduces the size, more than one increases the size. 

Exercise 42—Scaling objects 

1 From the Edit menu click Select Objects, and then click Curves. 

2 From the Transform menu click Scale, and then click Scale 2-D . 

3 For the Origin point, type 0 and press Enter. 

4 For the Scale factor, type .75 and press Enter. 

The whole part scaled to 75 percent of its original size. 

 

To Scale2-D using the reference point option: 

1 Select the slotted circle. 

2 From the Transform menu click Scale, and 
then click Scale 2-D. 

3 For the Origin point, snap to the center of the 
slotted circle. 

4 For the First reference point, snap to the 
quadrant of the slotted circle. 

The radius of the slotted circle is the reference 

for the scale factor. 
  

5 For the Second reference point, type 1.375 and press Enter. 

The slotted circle now has a larger radius of 1.375.  
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To make it solid: 

1 From the Edit menu click Select Objects, and then click Curves. 

2 From the Solid menu click Extrude Planar Curves, and then click 
Straight. 

3 For the Extrusion distance, type 1 and press Enter. 

 

To scale in 3-D: 

1 From the Edit menu click Select Objects, and then click Polysurfaces. 

2 From the Transform menu click Scale, and then click Scale 3-D .  

3 For the Origin point type 0 and press Enter. 

4 For the Scale factor type 1.5 and press Enter. 

The solid is larger in every dimension. 

 

To scale in one dimension: 

1 From the Edit menu click Select 
Objects, and then click Polysurfaces. 

2 From the Transform menu click Scale, 

and then click Scale 1-D . 

3 For the Origin point, type 0 and press 
Enter. 

4 For the First reference point, snap to 
the Perpendicular point at the top of the 

part.  

  

5 For the Second reference point, type .5 and press Enter. 

The object is half as thick. 

Editing with the gumball 

Gumball displays a widget on a selected object which is used to facilitate the direct editing. The gumball provides 

move, scale, and rotate transformations around the gumball origin. 

Click the Gumball pane in the status bar. 

 

Gumball actions: 

• Drag gumball arrows to Move the object. 

• Drag scale handles (squares) to Scale the object in one direction. 

• Drag arcs to rotate the object. 

• Tap the Alt key after starting to drag to toggle copy mode. 
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• Click a control handle to enter a numeric value. 

• Hold the Shift key during Scale to force 3-D scale. 

 

Gumball Controls 

1. Axis plane indicator 

2. Free move origin 

3. Menu ball 

Move arrows, 

4. Move X,  

5. Move Y  

6. Move Z  

Rotation arcs  

7. Rotate X  

8. Rotate Y  

9. Rotate Z  

Scale handles  

10. Scale X 

11. Scale Y 

12. Scale Z 

 

 

Exercise 43—Gumball basics  

To move geometry with the Gumball: 

In this exercise we will drag gumball arrows to Move an object. There are 3 arrows: x (red), y (green) and z 

(blue). 

1 Open the model Gumball.3dm. 

 

2 Highlight the cone in the Top 
viewport. 

3 Drag the red arrow to move the 
object in the positive x or negative x 
direction. 

4 Drag the green arrow to move the 
object in the positive y or negative y 

direction. 
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5 Highlight the cone in the Front viewport. 

6 Drag the blue arrow to move the object in the positive z or negative z 
direction. 

7 Undo enough times to get back to the original model. 

 

8 Highlight the cone in the Front 
viewport. 

9 Click x Move Arrow (red) to enter 

numeric value of 1.  

Cone moves a distance of 1 units to 

the right. 

 

  

10 Repeat for y Move Arrow and z 
Move Arrow. 

  

To copy objects with Gumball: 

In this exercise you will drag objects with the gumball and tap the Alt key after starting to drag to toggle copy 

mode. 

1 Highlight the cone in the Top 
viewport. 

2 Drag the red arrow to move the 
object in the positive x or negative x 

direction. 

3 While still dragging, tap the Alt key.  

A plus appear to the right of the red 

arrow.  

When you release the mouse button, 

a copy of the object is created. 
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4 Highlight the two cones in the Top 
viewport. 

5 Drag the green arrow to move the 

objects in the positive y direction. 

6 While still dragging, tap the Alt key. 

A plus appear to the right of the 

green arrow. 

When you release the mouse button, 

a copy of the object is created. 

7 Undo enough times to get back to the 

original model. 

  

To rotate objects with Gumball: 

Drag arcs to rotate the object. 

1 Highlight the cone in the Top viewport. 

2 Press and drag along blue arc to rotate cone. 

 

3 Make the Right viewport active. 

4 Press and drag along green arc to rotate cone. 

5 Undo enough times to get back to the original model. 

 

Scaling with Gumball 

• Drag scale handles (squares) to Scale the object in one direction. 

• Click a scale control handles (squares) to enter numeric value. 

• Hold the Shift key during Scale to force 3-D scale. 

To scale objects with Gumball: 

1 Highlight the cone in the Top 
viewport. 

2 Drag the red scale handle (square) 
to scale the object.  

Release the mouse button to 

complete the scale. 
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3 Highlight a cone in the Front viewport. 

4 Drag  the blue scale handle 
(square) down to scale the object 

larger in height.  

Release the mouse button to 

complete the scale. 

  

 

5 Try clicking a scale control handle 
(square) and enter numeric value or 

scale factor like .75. 

 

  

6 Highlight the cone in the Front 

viewport. 

7 While holding down the Shift key, 
drag the red scale handle (square) to 

scale the object uniformly in the x, y, 

and z direction. Let go to complete the 

scale. 

8 Undo enough times to get back to the 
original model. 

  

Relocating Gumball Widget 

The gumball provides move, scale, and rotate transformations around the gumball origin. 

1 Highlight the cone in the Front 
viewport. 

2 Left click on the Gumball menu 
marker (circle). 

3 Click Relocate Gumball. 
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4 With the End point osnap, pick on 
the top of the cone and press Enter. 

The Gumball origin is now located at 

top of cone. All editing is in 

reference to the new origin. 

 

  

 

5 Click on the Blue arc. 

A text box will appear. You can type 

a rotation angle into this box to 

rotate an object an exact angle. 

6 Type 90 and press Enter. 

The cone is rotated exactly 90 

degrees in a counter clockwise 

direction. 

  

Exercise 44—Practice with Gumball 

Gumball Exercise: 

1 In the Layer panel, do the following: 
Make Default the current layer. 

Turn off the Cone layer. 

Turn on the parent Puzzle layer.  

Note: The Puzzle layer contains sublayers. 

Turning on or off the parent Puzzle layer, 

affects the sublayers visibility, too. 

 

 

2 From the View menu, select Zoom and Zoom Extents All (Alt+Ctrl+E) to see the puzzle pieces. 
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3 From the Status bar, turn Ortho and Grid 
Snap on. Next right click Grid Snap and click 
Settings.  

4 For the Snap Spacing, type a value of 0.05. 

5 Click OK. 

Hint: Grid Snap, Ortho, and Gumball should all 

be on in the Status bar. 

 

 

To reposition the puzzle pieces: 

1 Highlight the red puzzle Piece 1 in 
the Front viewport. 

2 Left click on the Gumball menu 

marker (circle). 

3 Click Relocate Gumball. 

4 With the End point osnap, pick lower 
left corner of the piece. 

  

5 Press and drag along blue arc to 
rotate pieces to 90 degrees. 

  

To rotate and move the other Puzzle Pieces: 

Repeat these steps for puzzle Pieces 3, 5, 6. 

1 Move with Gumball  

2 Relocate Gumball origin. 

3 Rotate with Gumball 

Use the appropriate viewport for rotation. 

Hint: Rotate Piece 3 in the Front viewport, rotate Piece 5 and 6 in the Right viewport. 
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Puzzle Piece 3 

    

Puzzle Piece 5 

    

Puzzle Piece 6 

    

4 Now use Gumball to move the final Piece 4 into position on the top of the box using the Axis plane 
indicator. 

Drag by the plane icon to constrain movement to that plane. 
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Trim 

Trim cuts and deletes portions of an object to make it end precisely at its intersection with another object. 

Exercise 45—Trim 

In this exercise, we will to pre-select the cutting objects. 

To trim curves: 

1 Open the model Trim-Split.3dm. 

2 Toggle Gumball Off. 

3 Zoom Window  around the grid in the 

lower left corner of the Top viewport. 

4 Pre-select the cutting objects by selecting 
the two outside vertical lines in the grid. 

5 From the Edit menu click Trim.  

6 Select each of the horizontal lines at their 
left and right ends. 

The lines are trimmed to the cutting edges. 

7 Press Enter. 

  

To trim surfaces: 

1 Zoom Window around a sphere and surface 

in the Perspective viewport. 

2 Select the surface that intersects the sphere 
in the Perspective viewport as the cutting 

object. 

3 From the Edit menu click Trim. 

 

  

4 For the Object to trim, pick the right side of the sphere. 

The sphere is trimmed at the surface. 

5 Press Enter. 
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Split 

Split divides objects into parts using other objects as cutters. The Split command breaks the object where it 

intersects the cutting object but does not delete anything. 

Exercise 46—Split  

In this exercise, we will to pre-select the object or objects we are going to split. 

To split a curve: 

1 Zoom Window around the closed curve in 
the lower right corner of the Top viewport.  

2 Select the closed curve. 

3 From the Edit menu click Split.  

4 Select the lines and press Enter. 

The curve is separated into four curves 

precisely where the lines intersect it. 

  

To split a surface: 

1 From the View menu click Zoom, and then 
click Zoom Extents All. 

2 Select the surface that intersects the sphere. 

3 From the Edit menu click Split. 

4 Select the sphere, and press Enter. 

  

The sphere is separated into two pieces precisely where the surface 

intersects it. 
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Extend 

Extend lengthens an object to make it end precisely at its intersection with another object or you can lengthen an 

object when there is no intersection. 

Exercise 47—Extend 

1 Open the model Extend.3dm. 

2 From the Curve menu click Extend Curve, and then click Extend Curve.   

3 For the Select boundary objects, select the line at the left and the curve at the 
right. 

4 For the Select curve to extend, click Type=Natural on the command line. 

5 Change to Type=Line. 

 

6 Select both ends of the top line and the left end of 
two curves. 

The curve and line extend to touch the boundary. 

The extension is a straight segment. 

  

7 For the Select curve to extend, click Type=Line on 
the command line. 

8 Change to Type=Arc. 

9 Select the right end of the middle curve. 

The curve extends with a tangent arc to touch the 

boundary. 

  

10 For the Select curve to extend, click Type=Arc on 

the command line. 

11 Change to Type=Smooth. 

12 Select the right side of the bottom curve. 

The curve extends with a curvature (G2) continuous 

extension to touch the boundary.  

13 Press Enter to end the command. 
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To extend with a set extension length: 

1 From the Curve menu click Extend Curve, and then 

click Extend Curve. 

2 For the Select boundary objects or enter 
extension length. Press Enter for dynamic 
extend, type 4 and press Enter. 

3 Select the upper end of the curve on the right. 

The curve extends exactly 4 units. 

4 Press Enter to end the command. 
  

To extend a curve dynamically: 

1 From the Curve menu click Extend Curve, and then 
click Extend Curve. 

2 For the Select boundary objects or enter 
extension length. Press Enter for dynamic 
extend, press Enter for a dynamic extension. 

3 Select the lower end of the curve on the right. 

The curve continues with the cursor. 

  

4 Click to end the extension. 

5 Press Enter to end the command. 

 

 

To extend to a surface: 

1 From the Curve menu click Extend 
Curve, and then click Extend Curve. 

2 For the boundary objects, select 
the cylinder on the left and the 

surface on the right. 

3 Press Enter. 
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4 Change the type to Type=Arc. 

5 Select both ends of the line and the curve. 

The curves extend to the surface of the cylinder and to the surface. 

 

 

Offset 

Offset creates an object parallel or concentric to another object. Use Offset to create specialized copies, such as 

parallel lines, concentric circles, and concentric arcs, through specified points or at pre-set distances. 

Exercise 48—Offset 

1 Open the model Offset.3dm. 

2 Maximize the Top viewport. 

3 Select the line. 

4 From the Curve menu click Offset, then click 

Offset Curve.  

5 For the Side to offset, pick on the upper right 

side of the line. 

A parallel line is created. 
  

To offset with the through point option: 

1 Turn on the End osnap. 

2 Select the circle.  

3 From the Curve menu click Offset, then 
click Offset Curve. 

4 For the Side to offset, click 
Throughpoint on the command line. 

5 For the Throughpoint, snap to the lower 
right end of the line you offset. 

A concentric circle is created that goes 

through the endpoint of the line. 
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To offset a polyline with sharp corners: 

1 Select the polyline. 

2 From the Curve menu click Offset, then click Offset Curve. 

3 Type 1 and press Enter to change the offset distance. 

4 For the Side to offset, pick inside the polyline. 

The polyline is offset with sharp corners. 

 

To offset a polyline with round corners: 

1 Select the polyline. 

2 From the Curve menu click Offset, then click Offset Curve. 

3 Click Corner=Sharp on the command line. 

4 Change the type to Corner=Round. 

5 Pick outside the polyline.  

The polyline is offset, but the corners are rounded with arcs. 

Other corner options include Smooth and Chamfer. Smooth makes a 
tangent curve that is smoother than an arc at each vertex, while Chamfer 

makes a bevel at each vertex.  

To offset a curve on bothsides: 

1 Select the free-form curve.  

2 From the Curve menu click Offset, then click Offset Curve. 

3 Click Bothsides on the command line. 

4 For Side to offset, pick on either side of the curve.  

Free-form curves are created on both sides of the selected curve. 

5 Repeat this process on the arc. 

Concentric arcs are created on both sides of the selected arc. 
 

To offset a curve on bothsides with caps: 

1 Select the arc.  

2 From the Curve menu click Offset, then click Offset Curve. 

3 Click Cap on the command line, and then click Round. 

4 Click Bothsides on the command line. 

5 For Side to offset, pick on either side of the curve.  

Concentric arcs are created on both sides of the selected arc with a rounded end 

piece connecting the offset curves. 
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To offset a surface: 

1 Select one of the open surfaces.  

2 From the Surface menu click Offset Surface.  

3 Place your cursor over the surface and click your left mouse button to change 
the offset direction. 

 

 

4 Press Enter. 

The surface is offset in the direction of the arrows. 

 

To offset a surface to a solid: 

1 Select the other open surface. 

2 From the Surface menu click Offset Surface. 

3 Click on the surface to change the normal direction if necessary. 

4 Choose the Solid option. 

5 Press Enter to create the offset surface and the surfaces needed to make the 
solid. 

 

To offset a polysurface:  

Offsetting polysurfaces may not give the desired results. In this example we will demonstrate some of the 

problems. 
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1 Select the cylinder. 

2 From the Surface menu click Offset 

Surface. 

The normals on a closed polysurface 

will always point to the outside. 

3 Pick Distance and type 1.  

4 Pick Corners=Round. Press Enter. 

Each surface of the polysurface is 

offset as a separate surface, then 

extended or filleted, and joined 

together as a solid.   

5 Undo. Repeat and pick 
Corners=Sharp. 

What you have in both cases is a solid 

inside of a solid. 

Hint: Use the What command to confirm 
that offset polysurface is a closed 

solid. 

 

 

 

To Shell a polysurface: 

1 Undo. 

2 Select the Cylinder. 

3 Type Shell on the command line. 

4 For Select faces to remove pick the 
top of the cylinder and press Enter. 

The surface is removed and the 

remainder is offset inward, using the 

outer parts of the removed surface 

to join the inner and outer parts. 
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Array 

Use the Array commands to make multiple copies of selected objects. Array Rectangular makes rows and columns 

of objects. Array Polar copies objects in a circle around a center point 

Exercise 49—Polar Array 

To create a polar array: 

1 Open the model Array.3dm. 

2 Select the small circle in the Top viewport. 

3 From the Transform menu click Array, and 

then click Polar.  

4 For the Center of polar array, snap to the 
center of the large circle. 

5 For the Number of items, type 10 and press 

Enter. 

6 For the Angle to fill, check to see if it is set to 
360, press Enter. 

  

The small circle is arrayed around the larger one. 

7 Save your model. 

You must include the original and the copies as the number in the array. 

To make the shape for the column: 

1 Window select the circles. 

2 From the Curve menu click Curve Edit Tools, 

then click Curve Boolean. 

3 For the Regions to keep, click inside the 
large curve. 

The inside of the circle, excluding the smaller 

circles is shaded. 

4 On the command line, click DeleteInput, click 
All, and press Enter. 

  

To make the column: 

1 Select the new polycurve. 

2 From the Solid menu click Extrude Planar Curve, then click Straight. 

3 For the Extrusion distance, type 14, press Enter. 
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To make a partial polar array: 

1 Turn on the Base layer. 

2 Select the column base, the column, and the column cap. 

3 From the Edit menu click Groups, then click Group. 

The three parts are grouped into one. 

4 Select the group. 

5 From the Transform menu click Array, and then click Polar. 

6 For the Center of polar array, type 0, press Enter. 

7 For the Number of items, type 6 and press Enter. 
 

8 For the Angle to fill, type -180, press Enter. 

Six columns are arrayed to fill 180 degrees in the negative direction. 

 

To create a rectangular array: 

1 Select the same column group as the last exercise. 

2 From the Transform menu click Array, then click Rectangular.  

3 For the Number in X direction, type 4, press Enter. 

4 For the Number in Y direction, type 4, press Enter. 

5 For the Number in Z direction, type 1, press Enter. 

6 For the X spacing, type 12 and press Enter. 

7 For the Y spacing, type 12 and press Enter. 

The columns are visible.  

 

8 At this stage you can change the number in each direction or the 
spacing.  

If you need to make a change, click the option in the command line 

and then make the adjustment. 

 

 

9 Press Enter to accept. 

10 Turn on all the layers to see the result. 

 

 

Exercise 50—Practice 

1 Start a new model, use the Small Objects - Inches.3dm template. Save as Gasket1. 
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2 Use Circle, Arc, Trim, Fillet, and Join to create the part shown. 

 

3 Use Extrude Planar Curve > Straight on the Solid menu to create the 3-D part.  
The extrusion thickness is .125. 

Exercise 51—Practice 

1 Start a new model, use the Small Objects - Inches.3dm template. Save as Cam. 

 

2 Use Circle, Arc, Line, Trim, Join, and PolarArray to draw the part shown. 
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3 Use Extrude Planar Curve > Straight on the Solid menu to create the 3-D part.  
The extrusion thickness is 0.5. 

Exercise 52—Practice 

1 Start a new model, use the Small Objects - Inches.3dm template. Save as Link. 

 

2 Use Line, Arc, Trim, Offset, Join, Fillet and Circle to draw the part shown. 

 

3 Use Extrude Planar Curve > Straight on the Solid menu to create the 3-D part. The extrusion thickness is 
0.5. 
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6 Point editing 
You can display the control points or the edit points of an object so that you can adjust the shape of an object, 

rather than manipulating the whole object at once. That is called control point editing. 

You can use point editing on meshes, curves, and surfaces, but not on polysurfaces or solids. 

Rhino’s curves are represented internally with non-uniform rational B-splines (NURBS). Three things determine 

the shape of a NURBS curve: 

• A list of points called control points 

• Degree 

• A list of numbers called knots 

If you change any of these things, it changes the shape of the curve. 

About control points, edit points, and knots 

• Control points do not have to be on the curve.  

• Edit points are always on the curve. 

• Rhino lets you edit curves and surfaces by moving control points and edit points. 

• Knots are parameters (that is, numbers, not points). 

• Adding knots to a curve or surface lets you control the movement of the object during control-point 

editing. 

Exercise 53—Control point editing 

In this exercise we are going to experiment with moving control points. Understanding how curves and lines react 

when control points are moved is very important to understanding NURBS modeling. 

To edit control points: 

1 Open the model Control Point.3dm. 

 There are pairs of curves with different 

degrees in the model. 

2 Turn Ortho and Grid Snap on. 

3 From the Edit menu click Select Objects, and 

then click Curves. 

4 From the Edit menu click Control Points, and 

then click Control Points On (F10).  

  

5 In the Front viewport select the middle row of 
points. 

6 Drag the points vertically, 8 units. 

Notice that the degree 1 curves (polylines) 

come to a point at each moved control point 

and the control points are exactly on the 

curve.  

The degree 3 and 5 curves are smooth. The 

degree 3 curves have more curvature than 

the degree 5 curves    

Individual points have more influence on a small area of the curve with degree 3 curves, while points have 

greater influence over a wider span of the curve with degree 5 curves. 
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To check the differences: 

1 Turn off the control points by pressing the 

F11 key or use the Esc key. 

2 Turn the Plane layer on. 

3 Select the curves and the plane. 

4 From the Curve menu click Curve from 
objects, then click Intersection. 

Lines are shown on the surface showing the 

intersections. 

   

5 Note the difference between the degree 3 and 5 curves.  

The higher the degree, the greater the influence over the span of a 

curve, when you edit control points. 

As you can see by the illustration, editing one point out of 11, on the 

degree 5 curve, influenced most of the curve. The degree 3 curve has a 

sharper curvature, because the influence of one point takes place over a 

shorter span.  

6 Undo twice, until you get back to seeing just the curves.  

The intersections will disappear, and the Plane layer is off.  

To continue editing control points: 

1 In the Front viewport select the two rows of 
points that are three points on either side of 

the center. 

2 Drag the points vertically, 5 units. 

3 Turn off the control points by pressing the F11 
key or use the Esc key. 

When a curve or polyline bends sharply at a 

point, like this, it is called a kink.  

If you create a surface from a curve that has 

a kink, it will have a seam at the kink.  

To make a lofted surface: 

1 Select the curves. 

2 From the Surface menu click Loft. 

3 In the Loft options dialog box, click OK. 

Because the degree 1 curves were included in the loft, a polysurface is created 

with a seam at each kink. 

4 Select the surface. 

5 Turn on the control points. 

The points do not turn on and the following message is displayed on the 

command line: Cannot turn on points for polysurfaces. 

6 Undo the loft. 
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To change the polylines into curves without kinks: 

1 Select both polylines. 

2 From the Edit menu click Rebuild.   

3 In the Rebuild dialog box change the point 
count to 11 and the degree to 3, and click OK. 

A degree 3 curve cannot have kinks. The 

curve smoothens and changes shape. 

  

To loft a surface over the curves: 

1 Select all of the curves. 

2 From the Surface menu click Loft. 

3 In the Loft Options dialog box, click OK. 

A single surface appears over the curves. 

The surface can be edited with control 

points. 

4 Select the surface. 

5 Turn on the control points. 

Note that there are more control points than 

what you started with. Rhino adds control 

points to make the surface conform the 

original curves. 

  

 

To rebuild a surface: 

1 Turn off the control points. 

2 Select the surface. 

3 From the Edit menu click Rebuild.  

4 In the Rebuild Surface dialog, change the 
point count to 8 in U direction and 13 in 
the V direction. Change the degree to 3 for 
both U and V. Check Delete input. 

The surface is smoother with fewer control 

points.   
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Nudge Controls 

Another method to move control points and other geometry in a more subtle way is to use the Nudge keys. The 

nudge keys are the arrow keys on the keyboard activated with the Alt, Alt+Ctrl, and Alt+Shift keys. 

To change the nudge settings: 

1 From the Tools menu click 
Options. 

2 In the Options dialog box, on 
the Modeling Aids page, note 

the Nudge settings.  

Any of these values can be 

changed. 

 

 

To use Nudge keys to move control points: 

1 Select one or two control points in the Front 
viewport. 

2 Hold the Alt key down and press an Arrow key. 

Notice that it moves (nudges) the point a 

small amount. 

3 Hold the Alt and the Ctrl key down and press 
another Arrow key. 

The movement is much smaller. 

4 Hold the Alt and the Shift key down and press 

another Arrow key. 

The movement is magnified. 

  

5 Hold the Alt and press the Page Up or Page Down key to nudge in the Cplane Z direction. 
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To use Set X, Y, Z coordinates to adjust points: 

1 Select all the points in one row along the top of the surface. 

2 From the Transform menu click Set X, Y, Z coordinates.  

3 In the Set Points dialog box, check Set Z, and uncheck Set X and Set Y. 

 

4 In the Right viewport move the points and 
click. 

The control points are aligned in the World Z 

direction.  

5 Repeat this on some of the other rows of 
points. 

  

To use Gumball to move Control Points:  

You can use the Gumball to move, rotate and 

scale Control Points, in a very similar way as you 

were able to transform objects. Let’s look at 

moving the Control Points with the Gumball. 

1 Select the surface. 

2 From the Edit menu select Control Points 
and Control Points On (F10). 

  

3 Turn on Gumball and select the points in one row along the top of the 

surface. 
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4 In the Front viewport, pick to the upper left 
of the screen. 

5 Next, drag the cursor to the lower right and 
pick. A selection window will appear and 

select all the points within the window. 

The points along the top row are selected. 

  

6 In the Front viewport, pick the green 
Gumball arrow, drag up and pick. The 
points move up. 

7 In the Front viewport, pick the red Gumball 
arrow, drag to the right and pick. The points 
move to the right. Press Esc to unselect 

points. 

  

8 In the Front viewport, pick the green 

Gumball arrow, drag down and pick.  

The points move in the top rows move 

down. 

Note: Use the Gumball for Control Point editing 

whenever possible in the next few 

exercises.   

Exercise 54—Practice with curves and control point editing 

1 Start a new model, use the Small Objects - Millimeters.3dm template. Save 

as Glass. 

2 Use the Curve command to create a half cross-section of the glass. 

3 Use control point editing to adjust the curve until you get the desired shape. 

To make it 3-D: 

1 Select the curve you created.  

2 From the Surface menu click Revolve. 

3 For the Start of revolve axis, pick one end of the curve. 
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4 For the End of revolve axis, pick the other end of the curve. 

5 For the Start Angle, click Deformable=Yes. 

This changes the structure of the revolved surface to make it easier to deform 

without creating kinks. 

6 For the Start Angle, click FullCircle. 

7 Save your model.  

 

8 Experiment with adjusting the control points to see what happens.  

9 Save your model. 
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PART THREE 
3-D Modeling and Editing 
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7 Creating Deformable Shapes 
When building models in Rhino, you should first determine which methods should be used for each part of the 

project. There are two basic ways to model in Rhino—free-form and accurate. Some models require more 

attention to exact dimensions because they might have to be manufactured or parts may have to fit together. 

Sometimes it is the shape of the object, not the accuracy that is important. These techniques can be merged 

together to create accurate, free-form shapes. This tutorial focuses only on the free-form, squishy aspect. The 

exact size and placement of the objects is not critical. The overall form is the main objective. 

The Rubber Ducky 

This exercise shows: 

• Simple surface creation 

• Surface rebuilding 

• Control point editing 

• Curve creation ( drawing, projecting ) 

• Splitting surfaces with curves and surfaces 

• Blending between two surfaces 

• Lighting and rendering 

When you model the rubber ducky, you will use similar modeling techniques for the head and the body. You will 

create spheres that will be deformed to make the shapes.  

If you need to know more about control points and surfaces, search the Rhino Help index for “control points.” 

Exercise 55—Creating a rubber duck 

1 Start a new model use the Small Objects - Millimeters.3dm template. Save as 

Duck. 

2 You can use layers to separate your parts, but for this model, it is not 
necessary. 

For more information about layers, look up “layer” in the Rhino Help index. 

 

Create the body and head shapes 

The body and head of the ducky are created by modifying two spheres. The size and placement of the spheres 

does not need to be exact. 

To create the basic shapes: 

1 From the Solid menu click Sphere, and then click Center, Radius.  

2 Pick a point in the Front viewport. 

3 Pick another point in the same viewport to create a sphere. 

4 Repeat this procedure for the second sphere. 
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To make the spheres deformable:  

1 Select both spheres. 

2 From the Edit menu click Rebuild.  

3 In the Rebuild Surface dialog box, change the 
Point Count to 8 for both U and V.  

4 Change the Degree to 3 for both U and V. 

5 Check Delete Input, clear Current Layer, and 
click OK.  

 

 

The spheres are now deformable. Having 

more control points allows more control over 

smaller parts of the surface. A degree-three 

surface will have a smoother shape when 

deformed. 

 

To modify the body shape: 

1 Select the large sphere. 

2 From the Edit menu click Control Points, and 

then click Control Points On.  

3 In the Front viewport select the control points 
near the bottom of the sphere. 

To window select, drag a box left to right 

around the control points. 

4 From the Transform menu click Set X, Y, Z 

coordinates.  

5 In the Set Points dialog box check Set Z, and 
Align to World as illustrated above. 

6 Drag the selected control points up, snap to one 
of the upper most selected points. 

This aligns all of the selected control points to 

the same world z-value (vertical in Front 

viewport), flattening the surface. 
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To scale the sphere shape: 

1 Turn off control points and select the body 
shape. 

2 From the Transform menu click Scale, and 

then click Scale1D.  

3 For the Origin point, pick a point near the 
center of the body sphere. 

4 For the First reference point, with Ortho on, 
pick a point to the right in the Front viewport. 

5 For the Second reference point, pick a point 
further to the right in the Front viewport. 

The body is shaped like an ellipsoid.  

  

To reshape the chest and tail 

1 Turn the control points on. 

2 Window select the control points at the top right 
of the body, and drag them to the right to bulge 

out the chest. 

 

  

3 Window select the control points at the upper 

left edge of the body, and drag them up to form 

the tail. 

Notice in the Top viewport that two control 

points are selected, though in the Front 

viewport, it looks like only one is selected. This 

is because the second control point is directly 

behind the one you can see in the Front 

viewport. 
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To add control for further shaping the tail: 

Before we start to edit the tail further, we will add an additional set of points to the tail portion of the body. 

1 From the Edit menu click 
Control Points, and 
then click Insert Knot. 

 

2 For the Surface for 
knot insertion, pick the 

body surface. 

A surface isocurve will 

be displayed. It will 

either be in the U or 

the V direction.  

3 Change the direction if 
necessary.  

4 For the Point on 
surface to add knot, 
pick a point midway 

between the tail and the 

center of the body. 

  

5 Press Enter to end the command. 

A new set of isocurves and a new row of points have been added to the body. 

6 Window select the control points at the 
upper part of the new isocurve, and drag 

them down to further form the tail and 

the body. 

7 You can adjust the control points further 

until you get the shape you want. 

 

  

8 Save your model. 
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To create the head: 

1 In the Front viewport select the small sphere. 

2 From the Edit menu click Control Points, and 
then click Control Points On. 

3 Select the control points on the right side and 
drag them to begin forming the bill. 

 

  

4 Window select the control points further back on 
the same isocurve and drag them forward to 

widen the bill. 

Remember to use a window to select the 

control points. There may be multiple control 

points in the same location in this view. 
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5 Window select control points at the top of the 
bill and drag them down as shown. 

6 Press Esc to turn control points off. 

 

 

 

 

Separate the bill from the head 

For the final rendering, the bill must be a different color from the body. To do this, they must be separate 

surfaces. You can split a single surface into multiple surfaces many ways. The following technique is just one. 

To split a surface with a curve: 

1 In the Front viewport create a curve that looks 
like the illustration on the right. 

2 Select the head. 

3 From the Edit menu click Split. 

4 For the Cutting object, pick the curve you just 
created. 

5 Press Enter. 

The bill and head are now separate surfaces. 

This will allow you to render the surfaces with 

different colors. 
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Create the duck’s neck 

The ducky needs a neck. You will first make an edge on the surface of the head and a corresponding edge on the 

surface of the body so you can create a blended surface between the two edges. 

To trim the head and the body: 

1 Draw a Line across the bottom of the head. 

2 Copy the line and adjust it so that it intersects 
the top of the body as illustrated on the right. 

It is important that the lines intersect the 

bottom of the head and the body completely. 

3 Select the lines. 

4 From the Edit menu click Trim.   

  

5 For the Object to 
trim, pick the bottom 

of the head and the 

top of the body. 

The bottom of the 

head and the top of 

the body is 

trimmed. 

6 Save your model. 

   

To create the blend surface between the head and body: 

1 From the Surface menu click Blend Surface.  

2 For the Segment for first edge, pick the edge curve at the bottom of the 
head. 

3 If the whole edge is not selected, click All on the command line.  

4 Press Enter to go to the next stage of the command. 

5 For the Segment for second edge, pick the edge curve at the top of the hole 
in the body. 

6 If the whole edge is not selected, click All on the command line. 

7 Press Enter to go to the next stage of the command. 

 

8 In the Adjust Surface Blend dialog box, check the 
Preview check box. 

The blend surface between the body and the head is 

displayed. 

9 Make any adjustments you desire by moving the 

slider bars in the dialog box, click OK when finished. 

If you click the lock icon at the left of the sliders the 

surface adjustments are symmetrical. 

10 Save your model. 
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To join the parts: 

1 Select the body the blend surface and the back of the head. 

2 From the Edit menu click Join.   

The three surfaces are joined into one. The bill is left separate for rendering 

purposes. 

 

To make an eye: 

For this part of the exercise we will make a curve and revolve it to get the surfaces for the eye. 

1 Toggle Ortho and Grid Snap on to help. 

2 From the Curve menu click Conic. 

3 In the Front or Right viewport make a conic 
curve as illustrated.  

Start of Conic (1), End of Conic (2), Apex (3), 

Curvature point. 

4 Use SmartTrack, with Point, End and Int 

osnaps on, to help place the two points as 

illustrated. 
  

These points will be used for placement of the eye on the head. 

5 From the Curve menu click Point Object, 
then click Multiple Points. 

6 For the Location of point object, hover over 

the end of the conic until the point activates, 

drag you cursor down and click to place the 

point. 

The point should be placed above the lower 

end of the conic. 

This will be the insertion point for eye.  

  

7 For the Location of point object, hover over the point you just made until the point activates, drag you 
cursor left and click when you reach the intersection point. 

This point is for scaling and rotating the eye. 
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To split the curve: 

1 Draw a line that intersects the conic 

2 Select the conic curve, 

3 From the Edit menu click Split. 

4 For the Cutting object, select the line. 

Splitting the curve allows you to assign a 

different color and material properties for the 

eye and the pupil. 

This step can be done at this stage or after 

you make the surface.   

To make the surface: 

1 Select both parts of the conic curve. 

2 From the Surface menu click Revolve. 

3 For the Start of revolve axis, snap to the 
point. 

4 For the End of revolve axis, snap to the end of 
the conic. 

5 For the Start Angle, click FullCircle. 

 

  

To assign display color and material color: 

1 Select the top of the eye. 

2 From the Edit menu click Object Properties. 

 

3 For the Display color, choose a contrasting 
color, like red.  

4 With surface still selected, in the Properties 
pane, select the Material page button  
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5 In Assign Materials by select Object.  

6 With Default Material selected, type the 
name of the new material to be used for the 

pupil of the eye, like Black.  

7 In the Basic Settings, select the Color 
swatch. The Select Color dialog appears. 
Pick Black and Ok. Also set the Gloss finish 
to 50%. 

8 Repeat these steps create a white material for 
the eye. 

 

 

9 From the Render menu click Render Preview to see the 
material color. 

 

To place the eye on the head: 

1 In the Top viewport select both parts of the eye. 

2 From the Edit menu click Groups and then click Group. 

The eye parts are grouped as one object. 

3 Select the group. 

4 From the Transform menu click Orient, then 
click On Surface. 

5 For Base point, snap to the point at the center 
of the eye. 

6 For Reference point for scaling and 
rotation, snap to the point at the edge of the 
eye. 

7 For Surface to Orient on, pick the head. 
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8 In the Orient on Surface dialog, for Scale 
check Prompt and Rigid, click OK. 

9 For the Point of surface to orient to, pick a 
point on the head. 

10 For the Scale factor, drag your mouse and pick 
to scale the eye. 

 

 

11 Mirror the eye to the other side of the head. 

  

Render a picture of the ducky 

Rendering creates a realistic picture of your model with colors you assign. These render colors are different from 

the layer colors you might be using, which control the display in wireframe and shaded mode. 

To render the ducky: 

1 Select the beak.  

2 From the Edit menu click Object Properties. 

3 In the Properties panel, on the Material page, click Basic and click the color swatch. 

4 In the Select Color dialog box, select a color for the beak, like orange. 

5 Select the body. 

6 From the Edit menu click Object Properties. 

7 In the Properties panel, on the Material page, check Basic and select a color for the body, like yellow. 

8 From the Render menu click Render.  
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To place lights: 

1 From the Render menu click Create 

Spotlight.  

2 Select a point in the middle of the model. 

 

  

3 Drag the radius until it is approximately three 
times as large as the model. 

4 Pick a point in the Top viewport while holding 
the Ctrl key down to activate elevator mode.  

In the Front viewport pick a point slightly 

above the object. 

5 From the Render menu click Render. 
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8 Modeling with Solids 
Several commands that enable you create and edit solid objects.  

Solids in Rhino are closed surfaces or polysurfaces that enclose a volume. Some of the solid primitives are closed 

single-surfaces carefully edge-matched, others are polysurfaces. 

Rhino’s polysurface objects are deformable by using the UDT (Uniform Deformation Technology) tools. You can 

also extract surfaces and deform the surfaces with control point editing like the last exercise.  

In this part of the class we will focus on making some solids, separating the parts, making changes and then 

joining the parts back together to make a solid. 

Button Command Description 

 

Box Draw a rectangular box from two diagonal corners and a height. 

 

 

Box 3Point Draw a box from two adjacent corners, a point on the edge across from them, and a height. 

  

Sphere Draw a sphere from a center point and a radius. 

  

Sphere 2Point Draw a sphere from the two ends of a diameter. 

  

Sphere 3Point Draw a sphere from three points on its surface. 

  

Cylinder  

 

Draw a solid cylinder from a center point, a radius, and a height. 

  

Tube Draw a solid tube from a center point, two radii, and a height. 

 

Cone  Draw a solid cone from a base point, a base radius, and a height. 

 

TCone  Draw a truncated cone that ends in a circular plane from a base point, two radii, and a height. 

  

Ellipsoid  

 

Draw an ellipsoid from a center point, and three axis endpoints. 

  

Torus  Draw a solid Torus from a center point, a radius for the center of the tube, and a tube radius.  

 

Pipe  

 

Draw a pipe around an existing curve. The pipe has a circular cross-section and optional caps 
at the ends.  

The Thick option lets you specify two radii at each end of the curve to create pipes with holes 
bored through the middle like tubing. 

 

TextObject Draw text as outline curves, surfaces, or solids. 

 

ExtrudeCrv Draw a solid by extruding a closed planar curve vertically.  

 
ExtrudeSrf  Creates a solid by extruding a surface vertically. 

 

 

Cap Creates planar surfaces to close planar holes in a surface or partial solid. 

 

BooleanUnion Boolean operation in Rhino to combine solids. 

 

BooleanDifference Boolean operation in Rhino to subtract surfaces and solids from one another. 

 

BooleanIntersection Boolean operation in Rhino to create the intersection of two surfaces or solids. 
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Model a bar with engraved text 

In the following exercise we will make a solid primitive, extract some surfaces, rebuild a surface and deform it, 

join the new surfaces into a solid, fillet the edges, add text to a surface, and do a Boolean operation on the solid. 

Exercise 56—Model a bar with text 

1 Start a new model using the Small Objects - Millimeters template.  

Save as Bar. 

2 From the Solid menu click Box,  and then click Corner to Corner, Height. 

3 For the First corner type 0,0 and press Enter. 

4 For the Length type 15 and press Enter. 

5 For the Width type 6 and press Enter. 

6 For the Height type 1 and press Enter.  

To edit a surface: 

1 From the Solid menu click Extract Surface.   

2 For the Surface to extract, select the top and both 
end surfaces, press Enter.  

3 Select the two ends and delete them. 

  

4 Select the top surface. 

5 From the Edit menu click Rebuild.   

6 In the Rebuild Surface dialog box, set the Point 
count to 4 and the Degree to 3 for both U and V, 
click OK. 

7 Press F10 to turn Control Points On.   
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8 In the Right viewport, window select the middle 
points.  

9 Drag the points up approximately one unit. 

10 Press F11 to turn Control Points Off. 

 

  

To make the bar solid: 

1 Select all of the surfaces. 

2 From the Edit menu click Join.  

The surfaces are joined making an open 

polysurface. 

3 Select the polysurface. 

4 From the Solid menu click Cap Planar Holes.  

Two end caps are created.   

To fillet the edges: 

1 From the Solid menu click Fillet Edge, and then click 

Fillet Edge.  

2 Set the Next Radius=1.0. 

3 For Select edges to fillet, pick the four vertical 
edges, press Enter. 

4 For Select fillet handle to edit, press Enter. 

  

5 Repeat the FilletEdge command. 

6 Set the Next Radius=0.2. 

7 For Select edges to fillet, window select the entire 
bar to get the horizontal edges, press Enter. 

8 For Select fillet handle to edit, press Enter. 
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To make a copy of the bar on a different layer: 

We need to make a copy of the finished bar for the next part of this exercise. On one of the copies we will engrave 

text, on the other we will emboss text. 

1 Select the finished bar. 

2 From the Edit menu click Layers, then Copy 

objects to layer.   

3 In the Select layer to copy objects dialog, pick 
Layer 01 and click OK. 

4 In the Layer panel, turn Layer 01 off. 

 

 

To make solid text: 

1 Change the layer to Layer 02. 

2 From the Solid menu click Text.   

3 In the Text Object dialog box, select a bold 
Font, like Arial Black. 
Under Create click Solids. 
Under Text size, set the Height to 3.00, 
the Solid thickness to 1.00, check Group 
objects, click OK. 

4 For the Insertion point position the text in 
the center of the bar in the Top viewport 

and click. 

5 In the Front or Right viewport, drag the text 
until it protrudes through the top surface. 

  

 

 

To engrave the text in the bar: 

1 Select the bar. 

2 From the Solid menu click Difference. 

3 For Select second set of surfaces or polysurfaces, set DeleteInput=Yes, 
select the text, press Enter.  

The text is engraved into the bar. However, it does not follow the curvature of 

the bar. Let’s look at how to make this text better follow a curved surface. 
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Offset solid text 

Occasionally you will want to create text that exactly follows the curvature of a base surface. One method is to  

split the top surface of the bar with the text curves and offset the surface into solid text objects. The solid text can 

be used to engrave (difference) or emboss (union) into the original surface or polysurface: 

To make a label: 

1 Turn Layer 01 on and turn the Default layer off. 

2 From the Solid menu click Extract Surface. 

3 Click Copy=Yes in command line. Select the top 

surface, press Enter.  

4 Select the lower part of the bar and Hide it. 

5 Make the Top viewport active. 

6 From the Solid menu click Text. 

  

7 In the Text Object dialog box, under Create, click Curves, and check Group 
Objects. Click OK. 

8 For the Insertion point position the text in the center of the bar in the Top 
viewport and click. 

 

To split the top surface of the bar with the text: 

1 In the Top or Perspective viewport select the text curves. 

2 From the Edit menu click Trim. 

3 Select the surface in 3 places: near outer edge, in center of O, and in center of R. 

Remember to trim out the center of letters like R and O. 

Since the Group objects box was checked when you created the text, you can 

pick all of the text by clicking on one element. 

The curves have split the surface. Each part of the text is a separate surface. 

4 Delete the original text curves. 
 

Hint: Selcrv will select just the curves. 

5 Select the text surfaces. 

6 From the Edit menu click Group, and then click Group. 

The text surfaces are now grouped for easier selection. 
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To create solid text: 

1 From the Edit menu click Select Objects, and then click Previous Selection. 

This selects the text surfaces again. 

2 From the Surface menu click Offset Surface. 

3 For the Offset distance, click Bothsides=Yes, Solid=Yes, and 
DeleteInput=Yes on the command line. 

4 For the Distance, type .1 and press Enter. 

 

5 In the Properties panel, on the Material page, for Assign material by choose 
object, click the color swatch and select another color for the text. 

6 Right click on the Perspective viewport title. 

7 Select Rendered from the popup menu. 

The letters render in a different color. 

 

 

8 Show the bar. 

9 Use the Gumball to Copy the bar and solid text. 

  

To make embossed text: 

1 Unlock the bottom part of the bar and Join it with top part. 

2 Select the bar and the text. 

3 From the Solid menu click Union.  

The text and the bar are joined into one closed polysurface with the text embossed on 

the surface. 
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To make engraved text: 

1 Select the bottom polysurface from the copy you made. 

2 From the Solid menu click Difference.  

3 For the Select surfaces or polysurfaces to subtract with DeleteInput=Yes , 
select the text and press Enter. 

The text and the bar are joined into one closed polysurface with the text 

engraved into the surface. 

 

 

 

Embossed Polysurface 

 

Engraved Polysurface 
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9 Creating surfaces 
A Rhino surface is similar to a piece of stretchy fabric. It can take on many different shapes.  

Surfaces are bounded by curves called edges. To visualize the surface shape Rhino displays a grid of isoparametric 

curves (isocurves) on the surface. 

Surfaces have an area, their shape can be changed by moving control points, and they can be meshed. 

Button Command Description 

 

SrfPt Creates a surface by picking three or four points in space for corners. 

 

EdgeSrf Creates a surface by selecting two, three, or four existing curves whose ends meet exactly. 

 

PlanarSrf Creates a surface from planar curves that enclose an area. 

 

Patch Creates a surface that approximates a set of curves and/or point objects. 

 

Revolve Revolves a curve around an axis to create a surface. 

 

Loft Creates a surface from shape curves; the normal, loose, and tight options make a surface 
with no creases as it passes over the shape curves.  

The StraightSections option creates a surface with creases at each shape curve and straight 
sections between the shapes curves. 

 

Sweep1 Creates a surface from shape curves that follow along a rail curve that defines one edge of 
the surface. 

 

Sweep2 Creates a surface from shape curves that follow along two rail curves that define two edges of 
the surface. 

 

FilletSrf Creates a fillet or round between two surfaces. 

 

BlendSrf Makes a smooth surface between two existing surfaces 

 

RailRevolve Revolves a shape curve holding one end along a rail curve. This command is very useful for 
putting a smooth end cap on an irregularly shaped surface. 

 

ExtrudeCrv Extrudes a curve perpendicular to the construction plane with option to taper the surface with 
a draft angle.  

 

ExtrudeCrvAlongCurve Extrudes a curve following along a second curve. 

 

ExtrudeCrvToPoint Extrudes a curve to a point. 

 

Plane Creates a rectangular planar surface parallel to the construction plane from two diagonal 
points. 

 

Plane 3Point Creates a rectangular planar surface from 3 points. 

 

Plane Vertical Creates a rectangular planar surface from 3 points that is vertical to the construction plane. 

Simple surfaces - Phone 

Exercise 57— Create simple surfaces 

In this exercise, you will model some simple surfaces. 

1 Start a new model, use the Small Objects - Millimeters.3dm template. Save as Surfaces. 

2 Turn on Grid Snap and Planar. 
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Planes 

1 From the Surface menu click Plane, and then click Corner to Corner.  

 

2 For the First corner of plane, pick a point. 

3 For the Other corner, pick another point to make a rectangular plane. 

 

To create a vertical plane: 

1 From the Surface menu click Plane, and then click Vertical.   

2 For the Start of edge, snap to the endpoint at the right side of the 
surface. 

3 For the End of edge, snap to the other endpoint at the right side of the 
surface. 

4 Drag your cursor up and pick. 

 

To create a plane from 3 points: 

1 From the Surface menu click Plane, 

and then click 3 Points.   

2 For the Start of edge, snap to the 
endpoint at the left of the first 

surface. 

3 For the End of edge, snap to the 
other endpoint at the left side of the 

first surface. 
  

4 For the Height, use SmartTrack to track a point from the top of the vertical plane. Drag the tracking point 

until the surface is tilted slightly and click. 

To create a plane from corner points:  

1 From the Surface menu click Corner 

Points.  

When you pick the points in the 

next four steps, pick them in a 

clockwise direction. 

2 For the First corner, snap to an 
endpoint at the edge of the first 

surface. 
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3 For the Second corner, snap to the endpoint at the edge of the second surface. 

4 For the Third corner, snap to an endpoint at the edge of the third surface. 

5 For the Fourth corner, snap to the other endpoint at the edge of the third surface. 

A surface will be created with corners at the points you selected. 

Surface from planar curves 

To create a surface from planar curves: 

1 Turn Planar mode on. 

2 Draw a curve that starts and ends at the top of the two vertical surfaces 
as shown below.  

Planar mode keeps this curve on the same plane as the surface corners.  

 

3 From the Surface menu click Planar 

Curves.   

4 Select the curve you just created. 

5 Select the top edge of the three 
surfaces and press Enter. 

A surface is created.  

  

Surface from edge curves 

To create a surface from edge curves: 

1 From the Surface menu click Edge 

Curves.   

2 Select the four surface edges. 

A surface is created. 

3 Select all the surfaces and from the 
Edit menu click Join. 

Result should be valid, closed 

polysurface.   

Hint: Use the What command to confirm that offset polysurface is valid, closed solid. 
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Extruding curves 

In this exercise, you will be creating a cordless phone using 

extrusions. To aid in organizing the model, surface and curve 

layers have been created. Make sure you change layers as you are 

making the extrusions.  

 

 

To extrude a curve: 

1 Open the model Extrude.3dm. 

2 Make the Top Surface layer current. 

3 Select the curve as shown. 

4 From the Surface menu click 
Extrude Curve, and then click 

Straight.   

5 For the Extrusion distance, 
type-3.5 and press Enter. 

If the object being extruded is a 

planar curve, the curve is extruded 

perpendicular to the plane of the 

curve. 

  

To extrude a curve along another curve:  

1 Select the curve (1) on the left of the first 

extruded surface. 

2 From the Surface menu click Extrude 

Curve, and then click Along Curve.   

3 Select the path curve (2) near its right 
end.  

The curve is extruded along the path of 

the secondary curve.   

If you don’t get the answer you expected, undo and try picking near the other end of the path curve. 
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To extrude a curve with a taper (draft angle): 

1 Select the curve on the right. 

2 From the Surface menu click Extrude 
Curve, and then click Tapered. 

3 For the Extrusion distance, click 
DraftAngle on the command line. 

4 For the Draft angle, type -3 and press 
Enter. 

   

5 For the Extrusion distance, type .375 and press Enter. 

The curve is extruded with a three-degree draft angle in the positive direction on the y-axis. 

To create a surface from planar curves: 

1 From the Surface menu click Planar 

Curves.  

2 Select the edge curves that bound the 

opening of the tapered extrusion at the 

top. 

3 Press Enter. 

A surface is created at the end. 
  

4 Select the four surfaces. 

5 From the Edit menu click Join. 

 

To make the extruded surfaces for the other half of the phone: 

Next, we will repeat the previous steps for the other half of the phone. 

1 Make the Bottom Surface layer 
current. 

2 Select the curve as shown. 

3 From the Surface menu, click 
Extrude Curve, and then click 
Straight. 

4 For the Extrusion distance, 
type -3.5 and press Enter. 

If the object being extruded is a 

planar curve, the curve is extruded 

perpendicular to the plane of the 

curve. 
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5 Select the curve (1) on the left of the 
first extruded surface. 

6 From the Surface menu, click 
Extrude Curve, and then click Along 
Curve. 

7 Select the path curve (2) near its 
right end. 

The curve is extruded along the 

path of the secondary curve.   

8 Select the curve on the right. 

9 From the Surface menu, click 
Extrude Curve, and then click 
Tapered. 

10 For the Extrusion distance, type 
-1.375 and press Enter. 

The curve is extruded with a three-

degree draft angle in the negative 

direction on the y-axis.   

11 From the Surface menu, click Planar 
Curves. 

12 Select the edge curves that bound the 
openings of the tapered extrusion at 

the top. 

13 Press Enter. 

A surface is created at the end. 

14 Select the four surfaces. 

15 From the Edit menu, click Join. 
  

To create an extruded surface on both sides of a curve: 

1 Turn on the Extrude Straight-
bothsides layer. 

2 Select the freeform curve as shown. 

3 From the Surface menu click 
Extrude Curve, and then click 
Straight. 

4 For the Extrusion distance, click 
Bothsides on the command line. 

  

5 For the Extrusion distance, drag the extrusion and pick. 

Make sure the surface extends past the other surfaces in both directions. The surface is extruded 

symmetrically from the curve.  
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Exercise 58—Basic techniques joining surfaces together 

To trim the surfaces: 

1 Select the joined Top and Bottom 
polysurfaces, and the surface you just 

extruded. 

2 From the Edit menu click Trim. 

3 For the Object to trim, pick the 
outer edge of each surface. 

  

To split the trimmed surface: 

1 Select the trimmed extruded surface. 

2 From the Edit menu click Split. 

3 For Select cutting objects, click Isocurve on the command line. 

4 Drag you cursor along the surface to determine which isocurve direction is 

selected. Click Toggle on the command line if it’s not the correct 
direction. 

5 For the Split point, snap to the intersection where all three surfaces 
intersect. 

 

Join 

Next you will join the split surface and the polysurface for the Top and the Bottom of the handset. The left hand 

(smaller) part of the split surface goes with the top of the phone handset, the larger part goes with the bottom 

part of the phone handset. 

To join the surfaces: 

1 Select the left (smaller) part of the split surface and the top polysurface 

2 From the Edit menu click Join. 

3 Select the larger part of the split surface and the bottom polysurface 

4 From the Edit menu click Join. 
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To round the edges of the polysurfaces: 

1 From the Solid menu, Fillet Edge, 

then Fillet Edge.   

Use a radius of .2 to round the edges. 

2 For the Select edges to fillet, select 
the edges around the top of the top 

polysurface and the two horizontal 

edges at the front, press Enter. 

  

3 For the Select fillet handle to edit, 
click Preview. 

4 Check to make sure the fillet is doing 
what you expect, press Enter. 

5 Repeat these steps for the Bottom 
polysurface. 

  

To create an extruded surface from a curve to a point: 

1 Turn on the Extrude to a Point layer. Turn off the Extrude Straight and 
Extrude Along Curve layers. 

2 Select the U-shaped curve on the Extruded to a point layer. 

3 From the Surface menu click Extrude Curve, and then  

click To Point.   

4 For the Point to extrude to, snap to the point object near the top 
surface. 

The curve is extruded to the point.  

5 From the Solid menu, click 
BooleanDifference command (Solid 

menu > Difference) to remove the 

surface from the top of the phone. 

If the result is not correct, flip the 

normals of the top polysurface or 

the extruded surface with the Dir 

command. The normals of the top 

polysurface and the extruded 

surface should point toward each 

other. 
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6 Select the circle. 

7 From the Surface menu click Extrude Curve, and then click To Point. 

8 For the Point to extrude to, snap to the point object inside the bottom 
surface. 

The curve is extruded to the point. 

 

9 Use the BooleanDifference 
command (Solid menu > Difference) 

to remove the surface from the top of 

the phone. 

The normals of the bottom 

polysurface and the extruded 

surface should point toward each 

other. 

10 Save your model as Phone. 
  

To create the buttons: 

1 Turn on the Curves for Buttons layer. 

2 In the Front view, window select the first column of buttons. 

Three curves are selected. 

3 From the Solid menu click Extrude Planar Curve, and then click 
Straight. 

4 For the Extrusion Distance, type -.2 and press Enter. 

 

5 Repeat these steps for the other 

columns of buttons. 

6 Use the FilletEdge command (Solid 

menu > Fillet Edge > Fillet Edge) with 

a radius of .05 to round the edges. 

 The button edges are rounded. 

7 Save your model. 
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Lofted surfaces - Canoe 

Exercise 59—Lofted surfaces 

1 Open the model Loft.3dm. 

2 Window select all of the curves. 

 

  

3 From the Surface menu click Loft.  

 

A surface is fitted over the curves. 

4 In the Loft Options dialog box, 
switch Style to Straight sections, 
and then click Preview. 

A surface is fitted through the 

curves, but the sections are 

straight between the curves.   

5 In the Loft Options dialog box, switch Style to Loose, and then click 
Preview. 

A surface is created that uses the same control points as the curves. The 

surface follows the curves more loosely. 

Use this option when you want the surface to conform to the control 

points of the input curves. 

6 In the Loft Options dialog box, switch Style to Normal, and then click 
OK. 

 

7 Mirror   the surface to create 

the other half. 

8 Join  the two halves. 
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To make a seat: 

1 Turn the Hull Curves layer off and 

turn the Seat Curves, and Seats 

layers on. 

2 Make the Seat Curves layer current. 

3 In the Front view, select the rounded 
rectangles. 

4 From the Curve menu click Curve 
From Objects, and then click 

Project.  
  

Project uses the current construction plane to determine the direction of projection. Make sure you select the 

curves and surface to project onto in the Front viewport. 

5 For the Surface to project onto, 
select the hull. 

The curves will be projected to both 

sides of the hull surface.  

6 Select one pair of curves on the 
surface. 

7 From the Surface menu click Loft. 

8 In the Loft Options dialog, click OK. 

9 Repeat this for the other seat. 
  

A surface is fitted over the curves that fit exactly with the shape of the hull. 

To create section curves from the surfaces: 

1 Select the hull. 

2 Change to the Sections layer. 

3 From the Curve menu click Curve 
From Objects, and then click 

Section.  

4 For the Start of section, in the Top 

viewport, pick a point to the left at 

the center of the hull.  
  

5 For the End of section, with Ortho on, drag a line to the right and pick. 

A curve is generated on the surface. Repeat this at various locations. 

6 Press Esc to deselect the section curves. 
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To create contour curves across the hull surfaces: 

1 Select the hull. 

2 Change to the Contours layer. 

3 From the Curve menu click Curve 
From Objects, and then click 

Contour.   

4 For the Contour base point, snap to 
the left end of the canoe. 

  

5 For the Direction perpendicular to contour planes, snap to the other 
end of the canoe. 

6 For the Distance between contours, type 12 and press Enter. 

A curve is generated every foot along the hull. 

7 Press Esc to deselect the contour curves. 

 

To create an edge curve from the surfaces: 

1 Change to the Top Rail layer. 

2 From the Curve menu click Curve 

From Objects, and then click 

Duplicate Edge.  
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3 Pick the top edge of the hull. 

4 Pick the other top edge and press 
Enter. 

Two curves are generated at the 

edges of the hull 

  

5 With the curves still highlighted, from 
the Edit menu click Join. 
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6 From the Curve menu click Offset, 
then click Offset Curve and enter an 

offset distance of 1. Also select the 
Bothsides option. 

7 Delete original curve, keeping inside 
and outside offset curves. 

Note: The model unit is inches. 
  

8 From the Curve menu click Fillet 
Curves. Set Fillet radius to 0 and 
Join=Yes. Select the two outside 
curves. Repeat for other end of 

canoe. 

  

To create surfaces from the curves: 

1 Select the curves you just made. 

2 From the Surface menu click Loft.   

3 In the Loft Options dialog box, set Style to Normal, and then click OK. 

4 Select the lofted surface. 

 

5 From the Surface menu click Offset 
Surface. Set the Distance to 1 and 
set the Solid=Yes and press Enter. 

  

A polysurface rim is created. 
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To make a solid canoe: 

1 Make the Hull layer current and turn 

off Top Rail layer. 

2 From the Surface menu click Loft  

3 Pick the top edge of the hull. 

4 Pick the other top edge and press 
Enter. 

Lofted surface is created. 

   

5 Join the new surface to the hull.  

A closed polysurface is created. You 

should see the Join command end 

when the new surface is selected. 

 

  

6 Use the What command to confirm that it is a valid closed polysurface. 

To shell the canoe: 

1 Type Shell command. 

2 For the Faces to remove from 
closed polysurface select the top 

surface.  

3 Click Thickness option in command 
line, and type or .5 and press Enter. 

The surface will shell to a thickness 

of 1/2 inch. 

  

4 Turn on the Top Rail layer. 

5 Assign materials to the hull and rim. 

6 Render the canoe. 
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Revolved surfaces – Vase 

Exercise 60—Revolved surfaces 

1 Open the model Revolve.3dm. 

2 Select the free-form curve 

3 From the Surface menu click Revolve.  

 

4 Select one end of the curve for the 
Start of revolve axis. 

  

 

5 Select the other end of the curve for the End of revolve axis. 

6 Press Enter to use the default Start Angle. 

7 Press Enter to use the default Revolution Angle. 

A surface is revolved around the axis line. 

Rail Revolve – Heart, star 

Rail Revolve lets you revolve around an axis and along a path curve. 

Exercise 61—Using a rail revolve 

To create a rail revolve: 

1 Open the model Rail Revolve.3dm. 

2 From the Surface menu click Rail Revolve.  

3 For the Profile Curve, select the conic shaped curve (1). 

4 For the Rail curve, select the heart shaped curve (2). 

5 For the Start of revolve axis, select one end of the vertical 
line. 

6 For the End of revolve axis, select the other end of the 

vertical line. 
  



9  C R E A T I N G  S U R F A C E S  

Robert McNeel & Associates  177  

A surface is revolved around the axis while it follows along the curve. The 

profile curve is scaled in one direction between the axis and the rail. 

 

7 Turn the Bowl layer on and other layers off. 

8 Repeat the previous steps to make a bowl. 
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Sweeps andcurve networks  

Exercise 62—Using 1-rail sweeps to create surfaces 

One cross-section: 

1 Open the model 1 Rail Sweep.3dm. 

2 Select the two curves on the left. 

3 From the Surface menu click Sweep 1 Rail. 

 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

Two cross-sections: 

1 Select the three curves in middle. 

2 From the Surface menu click Sweep 1 Rail. 

3 In the Sweep 1 Rail Options dialog, check 
Global shape blending. 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

Multiple cross-sections: 

1 Select the four curves on the right. 

2 From the Surface menu click Sweep 1 Rail. 

3 In the Sweep 1 Rail Options dialog, uncheck 

Global shape blending. 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

To create a 1-rail sweep to a point: 

1 Make Surface 02 layer group current 

and turn off Surface 01 layer group. 

2 From the Surface menu click Sweep 1 
Rail. 

3 For the Rail, select the open free-form 
curve. 

4 For the Select cross section curves, 
select the three closed curves, then 

click Point on the command line.  

5 For the Pick end point, snap to the End of the free-form curve. 

6 In the Sweep 1 Rail Options dialog, click OK. 
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To create a roadlike 1-rail sweep: 

1 Make Surface 03 layer group current 

and turn off Surface 02 layer group. 

2 Select the helix. 

3 From the Surface menu click Sweep 1 
Rail. 

4 For the Select cross section curves, 
select the closed curve and press 

Enter. 

5 For the Drag seam point to adjust, 
press Enter. 

 

6 Change the style to Roadlike Right, 
click Preview. 

7 Change the style to Roadlike Front, 
click Preview. 

8 Change the style to Roadlike Top, click 
Preview. If the preview looks correct, 
click OK. 

 

Rear-view mirror 

Exercise 63—Using two-rail sweeps to create surfaces 

���� Open the model 2 Rail Sweep.3dm. 

To create the base—Part 1: 

In the first part of this exercise, we will explore one of the Sweep2 

options. To illustrate the option we will use one cross-section. In the 

second part we will use the same rail curves with two cross-sections. 

Lastly, we will use two rails that converge to a single point. 

 

1 Change to the Base Surface layer. 

2 From the Surface menu click Sweep 2 Rails.   

3 Select the two rail curves (1). 

4 Select the cross-section curve (2). 

5 Press Enter twice. 

Since we only picked one cross-section, the surface doesn’t conform to the 

circle at the top of the sweep. 
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6 In the Sweep 2 Rail Options dialog, check 
Maintain height, click Preview. 

Notice that the cross-section maintains the 

same height throughout the sweep. 

7 In the Sweep 2 Rail Options dialog, click 
Cancel. 

  

To create the base—Part 2: 

1 Select the two rail curves (1). 

2 From the Surface menu click Sweep 2 Rails. 

3 Select both cross-section curves (2). 

4 Press Enter twice. 

5 In the Sweep 2 Rail Options dialog, click OK. 

A surface is created whose edges match the rail curves and the cross-

section curves. 

 

To create the housing: 

1 Turn the Housing Surface, Housing Curves, and 
Mirror layers on. 

2 Make the Housing Surface layer current. 

3 From the Surface menu click Sweep 2 Rails. 

4 Select the two rail curves (1). 

5 For the cross-section, select the outer edge of 
the cylinder, press Enter twice. 

6 In the Sweep 2 Rail Options dialog, click OK. 

A surface is created.   

To join the two parts: 

1 Select the base 
and the housing 

surfaces. 

2 From the Solid 

menu click 

Union. 

3 Use FilletEdge 
with a radius of 

.25 to round the 
intersecting 

edge.    
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Exercise 64—Using a network of curves to create surfaces 

1 Open the model Networksurf.3dm. 

2 From the Surface menu click Curve 
Network. 

3 For Select curves in network, pick 
the two edge curves and the cross-

section curves, and press Enter. 

  

4 In the Surface From Curve 
Network dialog box, change the 
edge matching to Curvature, click 
OK. 

A surface is created that has 

curvature continuity with the other 

two surfaces. 

Next let’s analyze the surface 

continuity of the joined surface. 
  

5 From the Analyze menu, click 
Surface, then click Zebra. 

View the stripes where they cross 

the seams. Notice that they seem to 

be seamless and smooth. 

6 From the Analyze menu, click 
Surface, then click Environment 
map. 

Try changing the image by clicking 

the dropdown menu in the EMap 

options dialog. 
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Exercise 65—Practice using one-rail sweeps  

In this exercise you use one rail sweeps to make an end table with free-form tapered legs. 

To create the legs: 

1 Open the model Table.3dm. 

2 From the Surface menu click Sweep 1 Rail. 

3 Select the path curve for the leg. 

4 Select the shape curve for both ends of the 
leg. 

  

 

5 Press Enter. 

6 Press Enter. 

7 In the Sweep 1 Rail Options dialog box, click OK. 

The table leg is created. Note the nice transition from one cross-section curve to the other. 

To create the brace: 

1 Change to the Braces layer. 

2 Repeat the previous process to create the 
brace.  
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To create the top and finish the table: 

1 Change to the Top layer. 

2 From the Surface menu click Sweep 1 Rail. 

3 For the Rail, select the ellipse. 

4 For the Cross-section, select shape curve. 

5 Press Enter. 

6 In the Sweep 1 Rail Options dialog box, 
click OK. 

The surface for the rim of top is created. 
  

7 Select all of the surfaces you created. 

8 From the Solid menu click Cap Planar Holes. 

Six caps were created. 

9 Use Mirror to copy the brace and the leg to 
finish the model. 

Mirror them around 0,0 in the Top viewport. 

  

Toy hammer 

Exercise 66—Creating a toy hammer  

In this exercise you will use most of the techniques that you’ve learned in the 

previous sessions.  

Some models require more attention to detail. This is an example of a model 

that requires precise modeling techniques. This exercise also requires a 

number of different surface creation techniques. The technical drawing is 

included to help you create a very precise model. 

 

1 Open the model Hammer.3dm.  

In addition the following layers have been created: Construction Lines, Curves, Handle, Tang, Head, Hole, 

Cutout, and Claw. Use the appropriate layer when constructing the model. 
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2 Draw outlines for the hammer in the Top viewport. 

Drawing outlines helps while drawing the curves. You can either draw lines, polylines, or rectangles to create 

the outlines. Use the dimensions on the technical drawing to get accurate outlines. 

Note:  There is a layer named Construction Lines in this model that has the construction lines drawn. It also has 

a sublayer with centerlines for the model. Turn on these layers to speed up the exercise, if necessary. 

To create the claw: 

When modeling the shape of the claw, you will use circles, arcs, and curves. You can trim the circles and arcs and 

then join them together to create a closed curve. You can rebuild the curve and adjust the control points to get a 

more sculptural shape. 

1 Change to the Curves layer 

2 Draw a curve defining the shape of the claw in the Top viewport. 

You can use a free-form curve or use a combination of arcs and circles 

that are trimmed and joined to create the curve. Following is a 

systematic approach to creating the curve for the claw part of the 

hammer using arcs and circles. 

Start by drawing two circles. 

3 Use the Circle command (Curve menu > Circle > Tangent to 3 curves) to 

create a circle at the lower end of the claw. 

Draw the circles tangent to the construction geometry 
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4 Use the Circle command (Curve menu > Circle > Tangent, Tangent, Radius) to 

create a circle at the upper end of the claw that is tangent to the upper right 

corner with a 4 mm radius. 

Draw the circles tangent to the construction geometry. 

 

5 Use the Arc command (Curve menu > Arc > 

Tangent, Tangent, Radius) to create arcs that 

are tangent to the two circles. 

  

6 Use the Trim command (Edit menu > Trim) to trim the inside part of the 

circles. 

7 Use the Join command (Edit menu > Join) to join the arc segments. 

 

8 Change to the Claw layer. 

9 Select the joined segments. 

10 Use the ExtrudeCrv command (Solid menu > Extrude Planar Curve >  

Straight) to extrude the curve on both sides of the construction plane. 
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To create the head: 

1 Change to the Curves layer. 

2 Use the Curve command (Curve menu > Free-form > Control Points) to create 

the curve for the cross-section of the head. 

Make sure the curve intersects the claw part. This makes joining the two 

pieces easier. 

 

3 Change to the Head layer. 

4 Use the Revolve command (Surface menu > 

Revolve) to revolve the curve. 

Use the midpoint of the construction line for 

the revolve axis. 

5 Save your model. 

  

To add the head to the claw part: 

1 Use the BooleanUnion command (Solid menu 

> Union) to join the head with the claw. 

If the result is not correct, flip the normal of 

the head surface with the Dir command. The 

normal of the head surface should be 

towards out. 

2 Use the FilletEdge command (Solid menu > 

Fillet Edge > Fillet Edge) fillet the intersection 

between the head and the claw. 

3 Save your model.   

To create slot for the claw part of the hammer: 

1 Use the Curve command (Curve menu > Free-

form > Control Points) to draw a curve for the 

slotted part of the claw. 

Make sure the curve is symmetrical.  

2 Use the Line command (Curve menu > Line > 

Single Line) to draw a line between the 

endpoints. 

3 Use the Join command (Edit menu > Join) to 

join the curve and the line. 
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4 Drag the closed curve closer to the claw. 

5 Use the Rotate command (Transform menu > 

Rotate) or the Gumball modeling aid to rotate 
the curve to align more closely with the curve 

of the claw. 

6 Change to the Claw layer. 

7 Use the ExtrudeCrv command (Solid menu > 

Extrude Planar Curve > Straight) to extrude 

the curve through the claw. 

  

8 Save your model. 

9 Use the BooleanDifference command (Solid 

menu > Difference) to subtract the slot from 

the claw. 

10 Use the FilletEdge command (Solid menu > 

Fillet Edge) to make the fillets around the top 

and bottom of the claw, and the slot. 

 

 

 

To create the shape curve for the tang and the handle: 

Create the shape curve for the tang in the Right viewport. This curve will also be used for the handle. 

1 Change to the Curves layer and turn on Ortho. 

2 Use the Curve command (Curve menu > Free-

form > Control Points) to draw a curve for the 

upper cross-section of the tang. 

Make sure the curve is symmetrical. 

  

3 Use the Mirror command (Transform menu > Mirror) to create the other 

curve. 

4 Use the Join command (Edit > Join) to join the curves. 

5 Save your model. 
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To create the tang: 

1 Use the InterpCrv command (Curve menu > Free-

form > Iterpolate Points) to draw one of the curves 

for the tang of the hammer. 

Make sure that it intersects the claw. 

2 Use the Mirror command (Transform menu > Mirror) 

to create the other curve. 

3 Change to the Tang layer. 

  

4 Use the Sweep2 command (Surface menu > Sweep 2 Rails) to make the surface. 

5 Use the Cap command (Solid menu > Cap Planar Holes) to make the tang a 

closed polysurface. 

6 Save your model. 

 

To finish the hammer head: 

1 Select the tang and the claw. 

2 Use the BooleanUnion command (Solid menu 

> Union) to join the tang with the claw and the 

head. 

3 Use the FilletEdge command (Solid menu > 

Fillet Edge) to make the fillets at the 

intersection between the tang and the claw. 

The edge has a round on it. 

4 Save your model. 
  

To create the handle: 

1 Change to the Curves layer. 

2 Use the Curve command (Curve 

menu > Free-form > Control Points) 

to draw a curve for the top edge of 

the handle. 

Make it start at the endpoint of the 

tang profile curve and end on the 

centerline. 

3 Use the Mirror command (Transform 

menu > Mirror) to make the other 

half. 
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4 Change to the Handle layer. 

5 Use the Sweep2 command (Surface 

menu > Sweep 2 Rails) to make the 

surface using the tang curve as the 

profile curve. 

A surface is created. 

6 Use the Cap command (Solid menu > 

Cap Planar Holes) to cap the open 

end. 

7 Save your model. 

  

To create the hole for the handle: 

1 Use the Circle command (Curve menu > 

Circle > Center, Radius) to make a circle 

25mm from the end of the handle. 

You may have to draw a construction 

line to help you position the circle. 

2 Use the ExtrudeCrv command (Solid 

menu > Extrude Planar Curve > 

Straight) to extrude the curve on both 

sides of the construction plane. 

Make sure the extrusion intersects both 

sides of the handle. 

3 Save your model. 

 

4 Use the BooleanDifference command (Solid menu > Difference) to 

subtract the hole from the handle. 

5 Use the FilletEdge command (Solid menu > Fillet Edge) to make the fillets 

at the edges of the hole. 

The edges have rounds on them. 

6 Save your model. 
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Squeeze bottle 

Some models require more attention to detail. This is an example of a model that requires precise modeling 

techniques. This exercise also requires a number of different surface creation techniques.  

Exercise 67—Creating a squeeze bottle  

The technical drawing is included to help you create a very precise model. 

50

 

 

 

1 Open model Squeeze Bottle.3dm. 

2 Use the pre-drawn rectangle to create a circle, an ellipse, and a profile curve.  

These curves will be used to generate the surfaces of the bottle. 

Note: A set of these curves is already included in the model on layers Rail Curves 

and Profile Curves. These layers are sublayers of a layer named Bottle Curves. 
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3 Make another (smaller)ellipse that will be used for 
the concave part at the bottom of the bottle. 

4 Move this ellipse vertically .25 units. 

  

To create the surfaces for the bottle: 

1 Change to the Bottle Srf layer and turn off the Construction layer. 

2 Select the small ellipse. 

3 Use the PlanarSrf command (Surface > Planar Curves) to make a flat surface. 

 

 

 

4 Select the large ellipse and the circle. 

5 Start the Sweep2 command (Surface > Sweep 2 

Rails). 

The pre-selected ellipse and circle will be the rails 

for the sweep. 

6 For the Select cross section curves, choose the 
profile curve, and then press Enter. 

7 In the Sweep 2 Rail Options dialog box, click Do 
not simplify and check Closed sweep, and then 
click OK. 
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To create a blend surface for the bottom of the bottle: 

1 Hide the rail and profile curves. 

2 Start the BlendSrf command (Surface > Blend 

Surface). 

3 For the Segment for first edge, select the edge of 
the ellipse surface, and then press Enter. 

4 For the Segment for second edge, select the edge 
of the bottle surface, and then press Enter. 

5 For the Drag seam point to adjust, move the seam 

points so that the align with each other, and then 

press Enter. 

6 In the Adjust Surface Blend dialog, make click 
Preview. Make any adjustments that are necessary 
and then click OK. 

  

7 Join the three surfaces. 

Cap the top 

If you close the bottle, thereby creating a solid, Rhino can calculate the bottle’s volume. If you were creating this 

bottle in real life, knowing the volume would be important. Normally, a bottle would have to be designed to hold a 

specified volume. 

If the edges of the remaining open surfaces are planar curves, you can use the Cap command to close them. The 

open edges on the bottle are the top circular shape and the bottom elliptical shape, and they are planar. 

To cap the top and bottom: 

1 Select the surface. 

2 Use the Cap command   (Solid menu > Cap Planar Holes) to close the holes. 
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Flatten the sides 

In this part of the exercise you will create custom surfaces to trim an area on each side of the bottle for a label. 

The new surface will have curvature in only one direction. 

To create the trimming surface: 

1 Change to the Default layer. 

2 In the Front viewport, draw two lines. One line in the 
middle and one on the side.  

Make sure the lines extend a little below and above 

the height of the bottle. 

3 In the Right viewport, Move the lines so that they will 
intersect the bottle, like the illustration on the right. 

  

4 Mirror the line on the side to the other side of the bottle. 

These lines will be used to create a cutting surface for the flat side of the bottle. 

Note: A set of these curves is already included in the model on layer Cut Curves, a 

sublayer of the Bottle Curves layer. 

 

 

5 Change to the Cut Srf layer. 

6 Select the three curves you just created. 
 

7 Use the Loft command (Surface menu > Loft) to 

make the cutting surface. 

8 In the Loft Options dialog, uncheck Closed loft, 
click OK. 

A lofted surface intersects the bottle. 

9 Mirror the surface to the other side of the bottle. 

10 Save your model. 
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To remove the surface from the bottle: 

1 Change to the Bottle Srf layer. 

2 Use the Dir command (Analyze menu > Direction) to 

check the surface normal direction. Flip the normals if 

necessary. 

The normals should be pointing toward the center of 

the bottle. 

3 Select the bottle. 

4 Use the BooleanDifference  command (Solid 

menu > Difference) to subtract the two lofted 

surfaces from the bottle. 

  

Note: It is possible to create a hollowed out shell from a solid polysurface, like this bottle. The command for 
doing this is Shell. 
 

Shell only operates on simple, solid, manifold polysurfaces. For more information on this command view 

the Shell Help topic. 

Create the bottle’s top 

To create the bottle top, you are going to revolve a profile curve to create the surface. 

To create the profile curve: 

1 Change to the Default layer. 

2 In the Front viewport, use the Lines command (Curve menu > Line > Line 

Segments) and the Arc command (Curve menu > Arc > Center, Start, 

Angle) to create a profile curve for the outside and the inside of the top. 

3 Use the drawing to the right to draw the correct dimensions. 

4 Begin the drawing anywhere in the viewport.  

You will move it to a precise location after it is made. 

Tip: When drawing line segments, you can use object snaps, the distance 

constraint, and ortho to draw precisely.  

5 Use the Join command (Edit menu > Join) to join the segments together. 

Note: A profile curve for the top is already included in the model on layer 

Bottle Top Curve, a sublayer of the Bottle Curves layer. 
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6 Use the Move command (Transform menu > Move) 

to move the profile from the midpoint of the bottom 

edge to the midpoint of the top of the bottle. 

7 Change to the Bottle Top layer. 

  

To create the top surface: 

1 Select the profile curve. 

2 Use the Revolve command  (Surface menu > 

Revolve) to make the surface. 

3 Type 0 and press Enter for the first axis point 

4 Turn Ortho on and pick another point up or down 
from the first point for the other axis point. 

5 For the Start Angle click FullCircle. 

The top is created. 

 

  

6 Use the BooleanUnion  command (Solid menu > Union) to join the two 

polysurfaces together. 

 

Note: Practice additional surface modeling techniques by creating threads on the bottle top model. Here are two 
web links that include a video on techniques to make threads with Rhino: 

 Modeling Screw Threads, Part 1: http://tips.rhino3d.com/2009/01/modeling-screw-threads-1-of-2.html 

 Modeling Screw Threads, Part 2: http://tips.rhino3d.com/2009/01/modeling-screw-threads-2-of-2.html 
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10 Importing and exporting 
Rhino supports many different import and export formats, making it possible to model in Rhino and then export 

your model to downstream processes, or import models from other software applications into Rhino. For a 

complete list of import and export file types refer to the Rhino Help > Contents > File I/O > File Formats. 

Exporting Rhino File Information 

When you export to a format like 3DS, STL or DWG, Rhino has to convert from smooth NURBS surfaces to a 

polygon mesh representation made of triangles. To do a good approximation of the curved surfaces, Rhino can 

sometimes use many polygons. The density of triangles can be adjusted when exporting. You can create a mesh 

object and export it, or Rhino can create the mesh during the export process. 

There are two methods to export models to other formats. You can use the Save As command to choose a 
specific export format to export an entire model. Or, you can select some objects and use the Export Selected 
command to choose a specific export format to export a portion of the model. In the following exercise you will 

use the Save As method to export three of the most common file formats. 

Importing other file formats into Rhino 

We will not be importing any models in this class. Importing files from other applications is covered in our Level 2 

Training course. If you have any specific questions about importing models into Rhino, consult your instructor. 

Exercise 68—Exporting models 

To export a model to a mesh format: 

1 Open the model Export.3dm. 

2 From the File menu click Save As. 

3 In the Save dialog box, change the Save as type to Stereo lithography 
(*.stl). 

4 In the file name box type Export and click Save. 

 

5 In the STL Mesh Export Options dialog box, set the Tolerance to 0.01, 
and click Preview. 

6 Set the Tolerance to 0.1, click Preview, and then click OK. 

7 In the STL Export Options dialog box, select Binary, check Export 
open objects, and click OK. 

Detailed mesh controls are discussed in more depth in the Level 2 

training class. 
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To export a model to IGES: 

1 From the File menu click Save As. 

2 In the Save dialog box, change the Save as type to IGES (*.igs). 

3 In the IGES Export Options dialog box, select Pro E Windows 
solids as the IGES type, click Detailed Controls. 

Detailed controls allow the user more input. 

4 Click Cancel to terminate, or OK to create the IGES file. 

 

 

To export a model to STEP: 

1 From the File menu click Save As. 

2 In the Save dialog box, change the Save as type to STEP (*.stp, *.step). 

3 In the STEP Options dialog box, use the default setting. 
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11 Rendering 
Rendering is available for showing your model as if it was photographed or sketched. If you render to look like a 

photo, this is called photorealistic rendering. Flamingo nXt is an example of a photorealistic render plug-in for 

Rhino. If you render to look hand sketched, this is called non-photorealistic. Penguin is an example of this type of 

render. 

Both types of renderers are available as plug-ins for Rhino. The built-in Rhino renderer may be good enough for 

much of your work. If not, use another rendering program such as Flamingo nXt, V-Ray, Maxwell, Brazil or other 

plug-ins for higher quality results. Plug-ins for Rhino are listed on the Resources page of the Rhino web site. 

Apply materials 

Rhino’s built-in renderer uses materials with color, gloss and transparency settings, spotlights, displays shadows, 

and does antialiasing. It also allows the attachment of textures and bump maps. In this exercise we will focus on 

the full rendering capability. 

Exercise 69—Practice rendering a model 

1 Open the model Render.3dm. 

2 From the Render menu click Current Renderer, and then click Rhino 

Render.  

3 Right click on the Perspective title bar, and then click Rendered display. 

The viewport mimics but does not exactly duplicate what you will get in 

a Render. 

 
 

To assign a material to the handle by object: 

To render the handle in color, we will first assign a red glossy material to the handle object. This material assigned 

to the object will override any material that might be assigned to the layer of the object. 

1 Select the handle. 

2 In the Properties panel, click on the 

Material page. 
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3 On the Material page box, at Assigned 
material by: choose Object. 

4 From the Material page, in the name field 
type Red_glossy. 

 

 

 

5 Next click the Color 
swatch. 

6 In the Select Color dialog 
box, select a color, like 

Red, and click OK. 

To give the handle a 

highlight, change the 

Gloss finish setting. 

 

 

 

7 Change the Gloss finish setting slider to value between 80 and 90. 

A gloss finish of 0 means that the object is not shiny at all and it will not 

have a specular highlight. A low value of gloss finish makes the shiny spot 

to be small, and the object will look glossier. As the gloss finish increases in 

value, the shiny spot gets larger—this makes the object look more like it is 

made out of a reflective material. 

The shiny spot only appears when you are looking at an object at a certain 

angle relative to the angle of the light. 
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8 From the Render menu click Render.  

A display window appears with the current viewport rendered in colors, 

but it will probably lack detail. You can close the Display Window without 

disturbing your model. Placing lights will add depth and detail to the 

rendered image. 

 

To assign a material to the blade by layer: 

To render the blade in color, we will next assign a yellow glossy material to the blade layer.  All the objects on the 

blade layer that do not have an object material override, are rendered in the material. That is an advantage of 

rendering with material set to by layer. Changing the layer’s material will result in all the objects on that layer 

updating. 

1 Select the blade. 

2 Right-click on the Properties panel.  

3 From the right-click menu pick on Layers. 
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4 In the Layers panel, click on the Material icon. 

5 In the Layer Material dialog, type the name 

Yellow_glossy. 

 

 

 

6 Under Basic Settings, 
click the Color swatch. 

7 In the Select Color dialog 
box, select a color, like 

Yellow, and click OK. 
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8 Change the Gloss finish setting slider to value between 80 and 90. 

 

 

9 From the Render menu click Render.  

 

 

To add a new material to a layer: 

1 In the Layers panel, click on the Material 
icon. 

2 In the Layer Material dialog, click the down 
arrow next to the Yellow_Glossy material. 

3 When the list of materials appears, click 

Default material. 

It’s best to use the Default material when 

making new materials.  
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4 In the Name box type White_glossy, and 
change the Gloss finish setting slider to 

value between 80 and 90. 

5 Render the model. 

6 The next time you click on the down arrow 
for a material listed in the Layer Material 
dialog, you will see a list of the Default 

material and the three materials you just 

created. 

You can switch between the any of the 

materials in the model or make a new one 

at any time. This works whether you are 

assigning the material by layer or object. 

 
 

Add lights 

Start with a standard lighting scheme. You can experiment to develop your own lighting schemes later. 

To place a light: 

1 Zoom out in the Top and the Front viewport. 

2 Change to the Lights layer. 

3 From the Render menu click Create Spotlight.  

 

4 For the Base of cone, type 0 and press Enter. 

5 For the Radius, pick a point so that the circle is 
larger than the entire screwdriver in the Top 

viewport. 

6 For the End of cone, hold down the control 
key, and pick a point below and to the right in 

the Top viewport. 

This starts elevator mode. 

  

7 For the End of cone, pick above the object in 
the Front viewport. 

This will be your main light. 

8 Click in the Perspective viewport. 

9 From the Render menu click Render. 

The image has some highlights and shadows. 
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To place a second light: 

1 Zoom out in the Top and the Front viewport. 

2 From the Render menu click Create Spotlight. 

3 For the Base of cone, type 0 and press Enter. 

4 For the Radius, pick a point so that the circle is 
larger than the handle of the screwdriver in the 

Top viewport. 

5 For the End of cone, hold down the control 
key, and pick a point below and to the left in the 

Top viewport. 
  

This starts elevator mode. 

6 For the End of cone, pick above the object in 
the Front viewport. 

This will be your secondary (fill) light. 

7 Click in the Perspective viewport. 

8 From the Render menu click Render. 

  

To assign properties to the light: 

1 Select the new light. 

2 In the Properties 

panel, , click the 

Light page. 

3 On the Light page, 
change the Shadow 
intensity to 0 and 
the Spotlight 
hardness to 60. 

Experiment with 

these settings to 

get the desired 

effect. 

4 Click in the 
Perspective 

viewport. 
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5 From the Render menu click Render. 

 

Add textures 

To add a bumpy surface to the handle:  

1 Select the handle.  

2 In the Properties panel , click on the Material 
page. 

 

 

 

 

 

3 In the Material Editor page, under Bump, click 
(empty-click to assign).  

4 In the Open dialog box, select cell2.bmp, and then 
click Open. 

Note: You can use any bitmap file for a bump. The bumps 
come from the pattern of light and dark in the 

bitmap image. 
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5 In the Material Editor dialog box, under Bump, click 
cel2.bmp. 

6 In the Mapping area, change the U Repeat to 2.0 and 
the V Repeat to 2.0, click OK. 

 

 

 

7 The Render display will update 
to display the bump. 

The surface of the handle has 

a bumpy appearance, however 

the color of the material and 

gloss setting is still used. 

8 From the Render menu click 
Render. 

8 From the File menu in the 
Render dialog, click Save As.  

 

9 Under Save as type, click PNG. enter your file name and 
location. 

10 Click Save button.  
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To add a texture to the handle: 

1 Highlight the handle. In the Properties panel , 

click on the Material page. 

2 In the Textures area, uncheck Bump. 

3 In the Textures area, for Color click (empty 
click to assign). 

  

 

 

Uncheck Bump and click 

to assign Color texture. 

 

4 In the Open Bitmap dialog box, 
select Wood.jpg, and then click 
Open. 

Wood color texture is mapped to 

handle. 
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5 Click Wood to open the Editing Wood 
dialog. 

6 In Mapping area, set the U Repeat to 4 
and the V Repeat to 6. 

7 Click OK to close the Editing Wood 
dialog. 

 

 
 

8 From the Render menu click Render or use a Rendered viewport. 

The surface of the handle has a wood texture appearance tiled at 4 times in 

the U and 6 times in the V. 
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To make the wood handle transparent: 

1 Highlight the handle. In the Properties 

panel, click on the Material page. 

2 In the Basic Settings area of the Material 
Editor dialog box, change the 
Transparency slider to 30. 

 

 

 

 

3 Click back into the graphics area. 

4 From the Render menu click Render. 

The handle will look transparent with the Wood texture. 
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To make the red handle transparent: 

1 Highlight the handle. In the Properties 

panel, click on the Material page. 

2 In the Basic Settings area of the Material 
Editor dialog box, change the 
Transparency slider to 30 and uncheck 
the Color texture. 

 

 
 

 

3 Click back into the graphics area. 

4 From the Render menu click Render. 

The handle will look transparent with the 

red glossy material. 
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Use a groundplane 

The Rhino Render has a ground plane option. The ground plane provides an infinite horizontal platform for the 

image that stretches to the horizon in all directions positioned at a defined elevation. A ground plane renders 

much faster than using a surface as a background. Any material can be assigned to the ground plane. 

Adding a ground plane:  

1 Right-click Properties panel tab. 

2 Click the Ground Plane panel. 

3 In Ground Plane panel pick On. 

Viewport will now show a ground 

plane. Let’s assign a material. 

4 In the Material area assign the 

existing yellow_glossy, a material 
created earlier in this exercise. 

Viewport will now show a yellow 

glossy ground plane. 

 

 

 

 

 

5 From the Render menu click Render. 
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6 In Ground Plane panel, click the down 
arrow next to the Yellow_Glossy 

material. 

7 When the list of materials appears, click 
Default material. 

A new default material will be added. 

8 In the Material editor dialog in the 
Name area type Wood_table. 

9 In the Textures area, check Color 

texture. 

10 In the Open Bitmap dialog box, select 
Wood.jpg, and then click Open. 

11 In the Texture mapping area, type X 
size 100 and Y size 75. 

  

12 From the Render menu click Render. 

13 From the File menu in the Render dialog, click Save As. 

14 Under Save as type, click PNG. enter your file name and 
location. 

15 Click Save button. 

The viewport will now show and render a wood ground 

plane. 
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12 Annotating your model 
Rhino can also produce 2D drawings of your models. Rhino has these annotation objects: 

• Dimensions 

• Annotation Text 

• Leaders 

• Dots 

• Hatching 

Dimensions 

You can create dimensions on all viewports.  They will be created parallel to the current viewport’s Cplane. 

Dimension commands are combined with object snaps to give precise values.  There are many different types of 

dimensions that are used to annotate a model. We will look at linear, radial, diameter, and angular. 2-D 

annotation text, Leaders, and Dots will also be covered. 

The dimension style controls the way a dimension displays. For example the dimension text location can be above 

the dimension line or in the dimension line. The end of a dimension line can display an arrow, a tick, or a dot. The 

dimension text can show decimal, fractional, or feet and inches numbers. A new model will open with Default as 

the dimension style. 

You can make additional dimension styles, assign existing dimensions to a different style, or update a style to 

make all the dimensions assigned to that style update.  You can also import a dimension style from another model. 

Or add the dimension style to a template so new models always have it. 

Let’s look at the dimension types: 

Dimension types 

 

Dimension tools 

Button Command Description 

 

Dim Linear Dimension creates a horizontal or a vertical dimension. 

 

DimAligned Creates an aligned dimension. 

 

DimRotated Creates a rotated dimension. 

 

DimAngle Creates an angular dimension. 

 

DimRadius Creates a radius dimension. 

 

DimDiameter Creates a diameter dimension. 

 

Text Creates 2-D annotation text. 

 

Leader Draw an arrow leader. 
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Button Command Description 

 

Properties Edit dimensions and text. 

 

DimRecenterText Returns text that has been moved away from its default position to its original 
location. 

 

Make2-D Creates curves from the selected objects as silhouettes relative to the active 

construction plane. The silhouette curves are projected flat and then placed on 
the world x,y-plane. 

Exercise 70—Dimensioning the model 

To start this exercise we will create a new dimension style. 

To make a new dimension style: 

1 Open the model Dimension.3dm. 

2 From the Tools menu click Options.  

3 In the Rhino Options dialog, click the + 

next to Annotations, click the + next to 
Dimensions to expand the list.  

4 Click Dimensions, and on the Current 
Dimension Style page, click New. 

5 Select (built-in) Millimeter Small as the 
new dimension style template. 

 

 

6 Click the Edit button 

7 Change Model space scale to 1.0. Click 
OK. 

Dimensions created will be assigned to the 

Millimeters Small dimension style. 
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Linear Dimensions 

Linear dimension creates a horizontal or a vertical dimension.  

To make linear dimensions: 

1 From the Dimension menu click Linear Dimension.  

2 Snap to the lower left end of the part in Top viewport. 

3 Snap to the lower right end of the part in the Top viewport. 

4 Pick a point below the part in the Top viewport. 

5 From the Dimension menu, click Linear Dimension.  

6 Snap to the lower left end of the part in Front viewport. 

7 Snap to the upper left end of the part in Front viewport. 

8 Pick a point to the left of the part in the Front Viewport. 

9 Create two additional linear dimensions on the top and right sides of the 
part in the Front viewport. 

Note: Use object snaps to locate the extension line origins. To move 
extension line or text locations for dimensions, turn on control points 

for the dimension and move the control points. 

 

 

Leaders 

To draw an arrow leader and text: 

1 From the Dimension menu click Leader .  

2 Click the top of the part in the Front viewport. This will be where the arrow 

will be created 

3 Turn Grid Snap on and click a point to the right and at an angle from the 
first point. 

4  Click to the right of the second point and press Enter. 
 

5 In the Leader Text 
dialog box, type Finish 
Smooth and click OK.  

6 To edit the text, double-
click and make changes 

in text box. Click in 

graphics area when 

editing is complete. 

For long notes try 

Wrap. Wrap activates 

the word-wrap feature 

on the leader object. 
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Radial and Diameter Dimensions 

To make a radius or diameter dimension: 

1 From the Dimension menu click 

Radial Dimension.  

2 Select the lower right quadrant of the 
arc in the Top viewport. 

3 Click to place the dimension text. 

4 From the Dimension menu click 

Diameter Dimension.  
  

5 Select the upper right quadrant of the hole in the Top viewport. 

6 Click to place the dimension text. 

Continuous Linear Dimensions 

The Dim command has a Continue option, that when activated adds chained dimensions along the same 

dimension line. This option needs to be activated for each Dim command that you begin. 

To make continuous (chained) dimensions: 

1 From the Dimension menu click Linear Dimension.  

2 In command line, click Continue=No. It will toggle to Continue=Yes. 

3 Snap to the left end of the part in Top viewport (1). 

4 Snap to the end of the vertical part in the Top viewport (2). 

5 Pick a point above the part in the Top Viewport (3). 

6 Continue to snap to the center of the hole (4), and the right end of the 
object (5). 

7 Press Enter to end continuous linear dimension. 

8 Create one additional linear dimension on the right side of the part in the 
Top viewport and the top of the part in Right Viewport. 

 

 

9 Dimension the rest of the drawing using leaders, text blocks, horizontal, 
vertical, radius, and diameter dimensions. 

10 Save your model. 
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Making a 2-D drawing from a 3-D model 

Rhino has the ability to generate a two-dimensional drawing from a three-dimensional model, by projecting the 

geometry to the world coordinate plane, and aligning the views. Options for first angle projection or third angle 

projection are available. In addition to the three orthographic views, a two-dimensional perspective drawing is 

also generated. Hidden lines are removed and placed on a separate layer. 

Options for creating four views (three parallel viewports and a perspective viewport), or single views of individual 

viewports are supported.  

Exercise 71—Practice making a 2-D drawing 

1 Open the model Make2D.3dm. 

2 Select the 3D model. 

3 From the Dimension menu click Make 

2-D Drawing.   

4 In the 2-D Drawing Options dialog box, 
click 4-view (USA) and check Show 
hidden lines, and then click OK. 

The 2-D drawings are created on the 

Top CPlane near the origin on the world 

xy plane. View them in the Top 

viewport.  

 
 

 

5 Dimension the 2-D drawing. 
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13 Printing and Layouts 

Printing  

The Rhino Print command will let you print one viewport at a time. 

Exercise 72—Printing the model 

1 Open the model Dimension.3dm. 

2 Make the Top viewport active and from the File 
menu click Print. 

3 In the Print Setup Destination dialog, select 
a printer, Letter Size paper, Landscape 
orientation, Raster Output, and Display 
Color. 

 

4 In the View and Output Scale area, select 
Scale of 2:1, On Paper 1.0 Millimeter, and 
In Model 0.5 Millimeter.  

Rhino will print .5 mm of the model in every 1 

mm on the printed sheet. 

 

 

Layouts 

Rhino has a Layout feature that will print multiple details of the model on one sheet. The details can have different 

scales, sizes, layer color, layer visibility, and object visibility. In addition, you can add multiple layouts to a model. 

To add a layout: 

1 From the View menu click Layout and New Layout. Or click the  on the 
Viewport Tabs bar, located below the Rhino graphics area. 

  

2 The layout name is Page 1, by default.  The sheet size is offered in the units 

of the model. 

However, selecting another unit here like inches will let you specify the 

sheet in a more familiar unit, without changing the layout unit. 
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3 From the New Layout dialog, select Inches, set Width to 11 and Height 
to 8.5. Set the Initial Detail Count to 4. 

 

4 Double-click to activate Perspective 
detail. From the View menu, pick the 
Shaded display mode. 
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To configure the perspective detail: 

You can suppress the display of geometry in any detail by hiding the object in the detail or by turning off the layer 

in the details. Objects are hidden in the details with the HideObjectInDetails command and made visible with the 

ShowObjectsInDetail command 

In addition, the Layers panel allows a layer to be turned off only in the detail, but remain visible in other details or 

viewports. 

1 Double-click to activate Perspective 
detail. In the Layers panel, scroll to the 
right or undock and stretch Layers panel. 

2 Highlight the Dimension layer, and pick on 
the lightbulb icon in the Detail On column. 

 

All the objects on the layer that was turned 

off in the Detail On column are not visible 

in the Perspective view but remain visible 

in all other details. 

 

3 Double-click the Perspective detail to de-
activate. Highlight the boundary edge of the 

detail. In Object Properties set the Print 

Width to No Print 

The edge of the detail will not print unless 

you assign a width. 
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To assign a scale to details: 

Details that are parallel can get a scale assigned to them. The scale will tell Rhino how many model units are in 

each paper unit. By assigning the scale to the detail, the layout can be plotted 1=1. Also by assigning the scale to 

the detail, details can have different scales. 

1 Highlight the Top detail. Do not double-click to activate.  

2 In the Properties panel, click the Detail page. 

 

3 In the Scale area, set 1.0 mm on layout equal to 1 mm in model.  

The scale is now set to 1=1. 

If you set 1 mm in the layout equal to 2 mm in the model detail, it 

is half size or 1=2. 

If you set 1 mm in the layout equal to 10 mm in the model detail, 

the scale is 1=10. 

 

4 Make detail active by double clicking it and pan geometry to center 
in viewport. Deactivate detail by double clicking.  

5 Select detail and in the Properties panel, click the Detail page and 

then click Locked. 

Details that are locked prevent zooming or panning, making it 

easy to keep them from changing scale. 

6 Repeat this procedure for the Front and Right details. 

 

To label details: 

1 Make a new layer called Notes.  Make it 
Red and current. 

2 Turn Ortho off and deactivate any details. 
You should be on the layout and not in an 

active detail. 

3 From the Dimension menu click Text 
Block. 

4 Pick a Start point, below the Top view of 
the part. 
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5 In the Text dialog set the Height to 7mm and type Top View. 

 

6 Repeat to add labels for Front View and Right 
View. 

 

To add a border: 

1 From the Curve menu click 
Rectangle, Corner to Corner. 
Snap to the lower left corner of the 

Front detail boundary and the 

upper right corner of the 

Perspective viewport boundary. 

2 Select the border.  In the 

Properties panel, on the Object 
page, click Print Width, and then 
click 0.70mm. 
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3 Right click on the Layout Title (Page 1), and then click Print 
Preview. 

The layout has a thick border around the detailed viewports. 

You can also add a title block at this stage if you choose. 

 

To print the layout: 

1 From the File menu click Print.  

2 Select a physical printer or a virtual printer like 
PDF995.  Select sheet size as letter or 
11x81/2 landscape. 

3 In the View and Output Scale area, set the 
scale to 1=1. 

 

 

4 Toggle Output color between Black & White and 
Display Color. 

5 Pick OK to print. Cancel if no printer is available. 

6 Save the file. 
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Exercise 73—Scaling and locking details on a layout. 

1 Open the model 

SimpleLayout_Print.3dm. 

2 Click in the Top viewport. 

3 From the View menu, click Layout, 
click New Layout. 

4 In the New Layout dialog, click 
Landscape. Set the Initial Detail 
Count to 4. Adjust any other options 

appropriate for your printer or 

plotter, click OK. 
 

 

A layout page opens and a new viewport tab labeled Page 1 appears at the lower edge of the Rhino window. 

The new layout has four detail views, showing the object from the same direction as the four default Rhino 

viewports. 

Details are windows into the 3-D model. They can be activated as modeling viewports by double-clicking in 

the viewport. 

5 Double-click in the Right detail. 

 

Set scale and lock details: 

1 If the Properties panel is not open, open it now 

(Edit>Object Properties) and dock it to one side. 

With nothing selected, the properties panel shows 

the viewport properties.  

With no detail active, the properties shown are for 

the layout as a whole. 
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2 Click the Edit button to edit the title, and size and printer properties.  

3 On the command line, for the Distance on layout (mm), set it to 1 and press 

Enter. 

4 On the command line, for the 1.000 millimeter on layout = Distance in model 
(m), set it to 1 and press Enter. 

5 Change the title to Right Profile, and Lock the detail. 

6 Repeat this in the Top and Front details to set all of these details to the same 
scale. 

 

7 Activate the Perspective detail. 

8 From the View menu, click Shaded. 

 

 

To draw borders and title blocks in the layout space: 

1 Double-click in the Perspective detail to deactivate it and make 
the layout space active. 

2 Draw a Rectangle (Curve>Rectangle>Corner to corner) around 

the viewports on the Layout. 

3 From the File menu, click Insert. 

4 On the Insert dialog box, check Prompt for Insertion point, 
uncheck Prompt for Scale and Rotation. 

5 On the Insert dialog box, click File…, select TitleBlock.3dm, 
click Open, click OK, click OK to close the Insert dialog box and 

insert the title block. 

 

6 For the Insertion Point, snap to the lower right corner of the rectangle. 

A title block is inserted on the layout. 

7 You can add information to the title block with the text command.  

To edit the text on the title block, explode it first.  
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To add dimensions to the layout space: 

1 On the layout use Linear dimensions to measure some features. 

The dimensions are located on the layout. The will not display in the 

model views. 

2 Add more dimensions as needed to the other layout viewports. 

 

To set linetypes and line weights for curves: 

These are used in printing and can be displayed in the Rhino views using the PrintDisplay and LinetypeDisplay 

commands.  

1 From the Edit menu, click Layers, then click Edit Layers. 

2 On the Layers panel, in the Print Width column, change the width of 
some of the layers. 

3 Select the Border rectangle and the Title Block. 

4 On the Properties panel, change the Print Width to a thicker weight. 

5 Right click on the Layout Title (Page 1), and then click Print Preview. 

Note the difference in thickness of the curves. 

Linetypes can be adjusted the same way.  
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PART FOUR 
Extras 
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14 Transforming solids 
It’s much easier to model things on a flat plane than it is on an organic surface or any other 3D shape. Rhino has 

several tools that allow you to model something in a simple way and then transform it onto a surface or a curve in 

3D space. In this chapter we will demonstrate two commands that make this easy to accomplish—Flow and 

FlowAlongSrf. 

Flow along surface 

Morphs objects from a source surface to a target surface. 

Options Description 

Copy=Yes/No Specifies whether or not the objects that you are flowing are copied. A plus sign appears at 
the cursor when copy mode is on. 

Rigid=Yes/No Note: This option does not apply to polysurfaces and will not be displayed if polysurfaces are 
selected for editing. 

Yes Individual objects are not deformed as they are transformed. 

No Individual selected objects are deformed 

Plane Allows you to draw a plane instead of using an existing surface as the base object. 

Exercise 74—Flowing Solids to a Surface 

Modeling on a curved surface is difficult and hard to achieve accurate results. FlowAlongSrf command simplifies 

the process by allowing you to model on the flat construction plan first. Then FlowAlongSrf to morphs objects from 

a source surface to follow target surface.  

To Flow Solid Text 

1 Open model FlowAlongSrf.3dm 

2 From the Transform menu click Flow Along 
Surface. 

3 For the Select objects to flow along a 

surface, select the solid text and press 
Enter.  

The text is a group and will select as one. 
  

4 For the Base surface, select the lower left 
corner of cyan surface. 

5 For the Target surface, select the lower left 
corner of the magenta target surface. 

The text is flowed to the target surface. 

  

6 Undo the FlowAlongSrf. 
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Surface direction 

The success of the FlowAlongSrf is dependent on the direction of the base and target surface. Each surface has a 

normal direction, a U direction, and a V direction. 

Ideally, the normal, U and V directions on the base surface should correspond to the normal, U and V directions 

on the target surface. 

The direction arrow colors are: 

• U=Red 

• V=Green 

• Normal=White 

To check the surface direction: 

1 Select both the cyan and magenta colored surfaces. 

2 From the Analyze menu click Direction. 

3 At the Select object to flip direction, you can click on either 
surface to change the normal direction, press Enter when done. 

You can use the NextMode option to toggle through all of the 

possible changes to U, V, and Normal directions.  

4 If you only need to change one surface, select it and start the 
Dir command again. 

5 Make any necessary changes to the direction of the surface so 
that the U, V, Normal directions match between the two 

surfaces. 
 

History and Gumball 

Now let’s combine FlowAlongSrf with RecordHistory. RecordHistory keeps the objects to be flowed and the objects 

that have been flowed linked. If the original objects are moved, scaled, or rotated, the flowed objects will update. 

To Flow with History and Gumball: 

1 In the Status bar turn on Gumball and RecordHistory. 

 

2 From the Transform menu click Flow Along Surface. 

3 For the Select objects to flow along a surface, select the solid text and 
press Enter.  

 

4 For the Base surface, select the lower left 
corner of cyan surface. 

5 For the Target surface, select the lower left 

corner of the magenta target surface. 

The text is flowed to the target surface.  
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Note: The Record History pane is toggled off as soon as the flow command is complete. By default the Always 

Record History option is not checked. If you want to record history on another command, you will need 
to select it before you run the next command that supports history.  

 See the Help for a complete listing of History Enabled Commands. 

6 Select the original text on the base surface. 

  

7 Use the Gumball arrow to move the text to the 
right.  

Notice that after you release the text on the 

base surface, the flowed text is updated on the 

target surface. 

 

  

Hint: If the flowed text does not update, return to step 1 and make sure Record History is on before starting 

FlowAlongSurface. 

8 Select the original text on the base surface. 

9 Use the Gumball arc to rotate the text to the 
left. Release your mouse button and watch 

the flowed text update. 

 

  

10 Select the original text on the base surface. 

11 Using the Gumball red scale handle, and the 
Shift key held down, pull to the handle to the 

left. Release your mouse and watch the 

flowed text update. 
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Exercise 75—Flowing a logo onto a freeform surface 

To create the base surface: 

1 Open the model PenguinBrand.3dm. 

 

2 On the Layer panel, make the Curves layer current.  

3 Select the magenta surface (front panel) on the 

penguin. 

4 From the Curve menu click Curve from Objects, 

then Create UV Curves  and press Enter. 

The UV curves are created at the origin of the World 

XY plane. 
  

 

5 From the Layer panel, make the Surface layer 

current. 

6 Highlight the closed curve and from the Surface 
menu click Planar Curves. 

 

  

To Flow the Logo: 

1 Turn on RecordHistory in the Status bar. 

2 On the Layer panel turn on the logo layer.  

The logo appears. 
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3 Select the logo. 

4 From the Transform menu click Flow Along 
Surface and press Enter. 

5 For the Base surface, select the lower left corner of 
green surface. 

 

  

6 For the Target surface, select the lower left corner 
of the magenta surface. 

  

 

7 Turn on Gumball in the Status bar. 

8 Use Gumball to move, scale and rotate the original 

logo on the base surface. 

The flowed logo updates. 

 

  

9 From the Render menu, Render to render the model. 
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Flow 

The Flow command re-aligns an object or group of objects from a base curve to a target curve. 

Steps 

1 Select objects. 

2 Select the base curve near one end. 

3 Select the target curve near the matching end. 

Options Description 

Copy=Yes/No Specifies whether or not the objects that you are flowing are copied. A plus sign appears at the cursor when 
copy mode is on. 

Rigid=Yes/No Yes Individual objects are not deformed as they are transformed. 

No Individual selected objects are deformed 

Line Allows you to draw a line to be used as the base curve. 

Stretch=Yes/No No The length of the objects along the curve directions are not changed. 

Yes Objects are stretched or compressed in the curve direction so that the relationship to the target curve 
is the same as it is to the base curve. 

Similar to Flow Along Surface, Flow allows you to flow solids along a curve. This makes designing in 3D easier and 

lets Rhino do all the morphing work. The command is called Flow.  

Exercise 76—Making a Ring with Flow 

To flow the parts of a ring along the shank curve:  

1 Open the model Flow_ring.3dm. 

2 Select the green polysurface as the object to flow. 

3 From the Transform menu click Flow along Curve. 

 

 

4 Select the red linear curve towards 
the left end for the Base curve. 

5 Stop at this stage and confirm the 
following option settings on the 

command line (Copy=Yes 
Rigid=No Stretch=No). 

6 Select the circle curve slightly below 
the point location as the Target 
curve. 

The polysurface is morphed or 

flowed to the shape of the target 

curve. 

Notice that the polysurface doesn’t 

flow completely around the circle. 
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7 Undo. 

 

We will flow this polysurface a few more times using different options.  

First, we will change the direction of the Flow. 

To flow the parts of a ring along the shank curve in a different direction: 

1 Repeat Flow along curve with 
identical steps, except pick the Base 
Curve near opposite end. 

2 Select the circle curve slightly below 
the point location as the Target 
curve. 

  

Notice that the inside and outside of 

the original polysurface has flipped. 

3 Undo again. 
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Second we will stretch the original polysurface so that it fits completely around the circle. 

To flow the parts of a ring along the shank curve, stretching it to fit the whole curve: 

1 Repeat Flow along curve the same 

way you did it the first time, picking 

the Base Curve towards the left end. 

2 Stop at this stage and confirm the 
following option settings on the 

command line (Copy=Yes 
Rigid=No Stretch=Yes). 

3 Select the circle curve slightly below 

the point location as the Target 
curve. 

 

  

The polysurface is morphed or 

flowed completely around the 

circular shape of the target curve.  

4 Use the What command to confirm 
that it is a closed solid polysurface. 

 
 

To flow the gems and bezels:  

1 Hide both the original polysurface and the flowed polysurface. 

2 From the Transform menu click Flow along Curve. 

3 For the Objects to flow, select the group of gems and bezels.  

They are a group and will select as one. 
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4 Select the Base Curve towards the left end. 

5 Stop at this stage and confirm the following option settings on the 
command line: 

(Copy=Yes Rigid=No Stretch=Yes). 

6 Select the circle curve slightly below the point location as the Target 
curve. 

The bezels and gems are morphed to fit around the circle. 

 

7 Examine the results. 

The sides of the bezels are not perpendicular, the top surface is not flat, 

and gem is stretched. 

8 Undo. 

 

To Flow the gems and bezels with Rigid=Yes: 

1 From the Transform menu click Flow along Curve. 

2 For the Objects to flow, select the group of gems and bezels.  

They are a group and will select as one. 

 

3 Select the Base Curve towards the left end. 

4 Stop at this stage and confirm the following option settings on the 
command line: 

(Copy=Yes Rigid=Yes Stretch=Yes). 

5 Select the circle curve slightly below the point location as the Target 
curve. 

The bezels and gems are stretched to fit around the circle. But the 

objects are not deformed. 
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6 Examine the results. 

The sides of the bezels are perpendicular, the top surface is flat, and 

gem is not stretched. 

 

 

7 Show the green polysurface again. 

 

To view the ring in a rendered viewport: 

1 From the View menu click Rendered. 

A Ruby material was assigned to the Gem_ruby 

layer. A Gold material was assigned to the Bezel 

and Ring layers. 

 

 

 

 

2 Render the ring. 

 

 


